Textpattern Forum

You are not logged in. Register | Login | Help

#1 2007-12-21 04:41:07

davebias
Member
From: New York, NY
Registered: 2006-04-11
Posts: 16
Website

Problems with zem_contact_reborn

I’m sure this has been covered before and probably has nothing to do with TXP and everything to do with my host, but I thought I’d ask…

I’m using zem_contact_reborn on two sites. EXACT same code except for the to=“email@address.com”.

It works here: http://www.trevorexter.com/contact – this site is hosted at MediaTemple
But not here: http://www.spottiswoode.com/contacts – this site is hosted at Mosso
(sending anything gives “Sorry, unable to send this email”)

Like I said, the TXP form that generates both HTML forms is exactly the same.

What could be the problem?

Any help would be much appreciated.

-Dave Bias

Offline

#2 2007-12-21 05:21:03

net-carver
Admin
From: UK
Registered: 2006-03-08
Posts: 1,646

Re: Problems with zem_contact_reborn

Probably some difference with your host’s setups. Possibly one of them doesn’t like the format of the mail headers or is doing outgoing filtering of some kind.

(Possible references here, here and here.)


Steve
Textile | My plugins on GitHub | @netcarver

Offline

#3 2008-11-22 20:44:29

kevinpotts
Member
From: Kansas City
Registered: 2004-12-07
Posts: 364
Website

Re: Problems with zem_contact_reborn

OK I am resurrecting this thread because I need a few seconds of technical assistance. I just set up a local install of XAMPP (originally contemplated here), and following the instructions from Textpattern Solutions (brilliant work), successfully have a full website going on my machine. Everything works except for the e-mail.

I looked at the FAQ entry and php.net, and I undertsnad I need to change a setting in php.ini. However, I am unsure what to change it to. I assume this is the bit that needs attention:

[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25

However, what should SMTP and smtp_port actually get changed to?

For the record, the error originally occured using zem_contact_reborn, but I verified this is indeed a global problem because I cannot generate a new user account from the Admin > Users panel. Any insight would be appreciated.

Offline

#4 2008-11-23 09:20:19

jakob
Moderator
From: Germany
Registered: 2005-01-20
Posts: 1,891
Website

Re: Problems with zem_contact_reborn

Kevin, it’s been a while since I used XAMPP but I don’t remember having to change the php.ini, I just had to start up Mercury Mail which if I remember rightly is bundled with XAMPP. I remember there being a problem with the server denying relaying outward going mails that needed changing in the mercury mail settings. Google says do this:

Go to configuration-> Mercury SMTP Server-> Connection control and remove the tick-mark from “Do not permit SMTP relaying of non-local Mail”.

I only needed this on my local setup, online it was no problem.


TXP Builders – finely-crafted code, design and txp

Offline

#5 2008-11-23 14:18:11

kevinpotts
Member
From: Kansas City
Registered: 2004-12-07
Posts: 364
Website

Re: Problems with zem_contact_reborn

jakob wrote:

Kevin, it’s been a while since I used XAMPP but I don’t remember having to change the php.ini, I just had to start up Mercury Mail which if I remember rightly is bundled with XAMPP.

Good to know. The client has Exchange on this server, so Mercury Mail is out of the question. Hunting around on other forums, it seems like SMTP needs to be a server name like mail.yourhost.com. Could be wrong. My lack of knowledge here is wider than the Chunnel.

Last edited by kevinpotts (2008-11-23 14:18:43)

Offline

Board footer

Powered by FluxBB