Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#25 2022-05-16 20:37:29

Destry
Member
From: Haut-Rhin
Registered: 2004-08-04
Posts: 4,851
Website

Re: RSS not working

gaekwad wrote #333313:

Fugly link works, fwiw:

wion.com/index.php?rss=1&section=notes

That does work for me, too, in Reeder.app. Which makes me realize having it set for excerpts only is a little lacking. I will just put that URL under the link, if that’s the fix.

colak wrote #333329:

Wild guess. Would it be ♬ appearing on /notes/dark-mode?

Gosh, I hope not. A glyph would be a sad thing to trip up a feed with. But I’ll check.

/ a few minutes later /

Glyph wasn’t the problem, but I took it out anyway.

Last edited by Destry (2022-05-16 21:39:32)

Offline

#26 2022-05-17 01:46:55

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,700
Website

Re: RSS not working

gaekwad wrote #333313:

Fugly link works, fwiw:

wion.com/index.php?rss=1&section=notes

…which leads me to wonder if it’s a .htaccess rewrite issue.

Probably, although at first I don’t see any issue with the contents of the .htaccess as posted.

That fuggly link works fine in NNW and Vienna here. Haven’t checked on the iPhone.

As Firefox does not know about feeds anymore, unless you specifically tell it, I should download that file, I think.


Where is that emoji for a solar powered submarine when you need it ?

Offline

#27 2022-05-17 08:52:39

Destry
Member
From: Haut-Rhin
Registered: 2004-08-04
Posts: 4,851
Website

Re: RSS not working

Bloke wrote #333320:

I get the RSS XML file downloaded as index.php in Firefox.

That’s what I get, too, versus the .rss file downloaded using the feed_link tag’s clean URL.

The difference in this case is the crusty URL actually works in the Reeder.app.

Here is a more complete set of .htaccess contents, if anyone sees anything popping out. I’m sure I could refine it a bit, but I’ve not had the time to look into it.

# ----------------------------------------------------------------------
#   A] CROSS-ORIGIN
# ----------------------------------------------------------------------

# A.1] Cross-Origin Requests

# <IfModule mod_headers.c>
#     Header set Access-Control-Allow-Origin "*"
# </IfModule>

# A.2] Cross-Origin Images

#<IfModule mod_setenvif.c>
#    <IfModule mod_headers.c>
#        <FilesMatch "\.(bmp|cur|gif|ico|jpe?g|png|svgz?|webp)$">
#            SetEnvIf Origin ":" IS_CORS
#            Header set Access-Control-Allow-Origin "*" env=IS_CORS
#        </FilesMatch>
#    </IfModule>
#</IfModule>

# A.3] Cross-Origin Fonts

<IfModule mod_headers.c>
    <FilesMatch "\.(eot|otf|tt[cf]|woff2?)$">
        Header set Access-Control-Allow-Origin "*"
    </FilesMatch>
</IfModule>

# ----------------------------------------------------------------------
# B] ERRORS
# ----------------------------------------------------------------------
# B.1] Custom Error Messages/Pages

# ErrorDocument 404 /404.html
# ErrorDocument 403 default

# ----------------------------------------------------------------------
# C] MEDIA TYPES & CHARACTER ENCODINGS
# ----------------------------------------------------------------------

# C.1] Media Types

<IfModule mod_mime.c>

	# Data interchange

	AddType application/atom+xml						atom
	AddType application/json                json map topojson
	AddType application/ld+json             jsonld
	AddType application/rss+xml            rss
	AddType application/geo+json           	geojson
	AddType application/rdf+xml            rdf
	AddType application/xml                xml

	# Media files

	## This one used by Textpattern, too

	AddType image/svg+xml  								svg svgz

	# Web fonts

	AddType font/woff                      woff
	AddType font/woff2                     woff2
	AddType font/ttf                       ttf
	AddType font/collection                ttc
	AddType font/otf                       otf

	# Other

	AddType text/markdown markdown md		

</IfModule>

# C.2] Character Encodings

AddDefaultCharset utf-8

# C.3]  Type 'charset' to 'UTF-8'

<IfModule mod_mime.c>
	AddCharset utf-8 .appcache \
                     .bbaw \
                     .css \
                     .htc \
                     .ics \
                     .js \
                     .json \
                     .manifest \
                     .map \
                     .markdown \
                     .md \
                     .mjs \
                     .topojson \
                     .vtt \
                     .vcard \
                     .vcf \
                     .webmanifest \
                     .xloc
</IfModule>

# ----------------------------------------------------------------------
# D] REWRITES
# ----------------------------------------------------------------------

# D.1] Textpattern CMS

<IfModule mod_rewrite.c>
	RewriteEngine On
	#RewriteBase /relative/web/path/
	#Options +FollowSymLinks

	RewriteCond %{REQUEST_FILENAME} -f [OR]
	RewriteCond %{REQUEST_FILENAME} -d
	RewriteRule ^(.+) - [PT,L]

	RewriteCond %{REQUEST_URI} !=/favicon.ico
	RewriteRule ^(.*) index.php

	RewriteCond %{HTTP:Authorization}  !^$
	RewriteRule .* - [E=REMOTE_USER:%{HTTP:Authorization}]		
</IfModule>

# D.2] Forcing `No WWW`

<IfModule mod_rewrite.c>
	RewriteEngine On
	RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
	RewriteRule ^(.*)$ http://%1/$1 [R=301,L]	
</IfModule>

# D.3] Forcing `https://`
# This needs commented out on local. Uncomment when live!

<IfModule mod_rewrite.c>
	RewriteEngine On
	RewriteCond %{HTTPS} !=on
	RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
</IfModule>

# D.4] Block Access to Hidden Files/Directories

<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_URI} "!(^|/)\.well-known/([^./]+./?)+$" [NC]
    RewriteCond %{SCRIPT_FILENAME} -d [OR]
    RewriteCond %{SCRIPT_FILENAME} -f
    RewriteRule "(^|/)\." - [F]
</IfModule>

# ----------------------------------------------------------------------
# E] SECURITY
# ----------------------------------------------------------------------

# E.1] Clickjacking                                                       |

<IfModule mod_headers.c>
     Header set X-Frame-Options "DENY" "expr=%{CONTENT_TYPE} =~ m#text/html#i"
</IfModule>

# E.2] File Access

#DirectoryIndex index.php index.html

# E.3] Block Access to Directories w/o Default file

<IfModule mod_autoindex.c>
    Options -Indexes
</IfModule>

# E.4] Block Access to Files of Sensitive Nature

<IfModule mod_authz_core.c>
    <FilesMatch "(^#.*#|\.(bak|conf|dist|fla|in[ci]|log|orig|psd|sh|sql|sw[op])|~)$">
        Require all denied
    </FilesMatch>
</IfModule>

# E.5] Reducing Mime Type Security Risks

<IfModule mod_headers.c>
    Header set X-Content-Type-Options "nosniff"
</IfModule>

# E.6] Reflected Cross-Site Scripting (XSS) attacks

<IfModule mod_headers.c>
    Header set X-XSS-Protection "1; mode=block" "expr=%{CONTENT_TYPE} =~ m#text/html#i"
</IfModule>

# E.7] ETags

<IfModule mod_headers.c>
    Header unset ETag
</IfModule>

FileETag None

# E.8] Server-side Technology Information

<IfModule mod_headers.c>
    Header unset X-Powered-By
</IfModule>

# E.9] Server Software Information

ServerSignature Off

# ----------------------------------------------------------------------
# F] WEB PERFORMANCE
# ----------------------------------------------------------------------

<IfModule mod_deflate.c>

  # F.1] Force compression for mangled `Accept-Encoding` request headers.

  <IfModule mod_setenvif.c>
    <IfModule mod_headers.c>
      SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
      RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
    </IfModule>
  </IfModule>

  # F.2] Compress all output labeled with one of the following media types.

  <IfModule mod_filter.c>
    AddOutputFilterByType DEFLATE "application/atom+xml" \
                                  "application/javascript" \
                                  "application/json" \
                                  "application/ld+json" \
                                  "application/manifest+json" \
                                  "application/rdf+xml" \
                                  "application/rss+xml" \
                                  "application/schema+json" \
                                  "application/geo+json" \
                                  "application/vnd.ms-fontobject" \
                                  "application/wasm" \
                                  "application/x-font-ttf" \
                                  "application/x-javascript" \
                                  "application/x-web-app-manifest+json" \
                                  "application/xhtml+xml" \
                                  "application/xml" \
                                  "font/eot" \
                                  "font/opentype" \
                                  "font/otf" \
                                  "image/bmp" \
                                  "image/svg+xml" \
                                  "image/vnd.microsoft.icon" \
                                  "text/cache-manifest" \
                                  "text/calendar" \
                                  "text/css" \
                                  "text/html" \
                                  "text/javascript" \
                                  "text/plain" \
                                  "text/markdown" \
                                  "text/vcard" \
                                  "text/vnd.rim.location.xloc" \
                                  "text/vtt" \
                                  "text/x-component" \
                                  "text/x-cross-domain-policy" \
                                  "text/xml"

  </IfModule>

  # F.3] Force Apache to serve file types w/ appropriate `Content-Encoding` response header.

  <IfModule mod_mime.c>
		 AddEncoding gzip       svgz
  </IfModule>

</IfModule>

There’s also a large section at the end for robot blocking, but I don’t think that has any effect here, and it’s long, in any case, so I’ll not pollute the space here.

Offline

#28 2022-05-17 16:18:09

bici
Member
From: vancouver
Registered: 2004-02-24
Posts: 1,952
Website

Re: RSS not working

As News App seems to hi-jack xml RSS files and then do nothing with them i have reached out to Apple Support to see what they have to say.


…. texted postive

Offline

#29 2022-05-17 22:26:51

bici
Member
From: vancouver
Registered: 2004-02-24
Posts: 1,952
Website

Re: RSS not working

so i setup NetNewsWire as my default Reader. ploped in https://wion.com/index.php?rss=1&section=notes

and it read all the posts. … and all is golden in Wion Land.

new

_PS this textile does not work !https://bicilogic.com/assets/txp_forumimages/WIONNews.png! _


…. texted postive

Offline

#30 2022-05-18 00:26:33

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,700
Website

Re: RSS not working

bici wrote #333360:

so i setup NetNewsWire as my default Reader. […]

curious: how does one set NNW as default RSS reader, it does not seem to offer any preference for doing that (like any other browser or RSS reader does).

_PS this textile does not work !https://bicilogic.com/assets/txp_forumimages/WIONNews.png! _

That seems a known issue with images


Where is that emoji for a solar powered submarine when you need it ?

Offline

#31 2022-05-18 06:00:15

bici
Member
From: vancouver
Registered: 2004-02-24
Posts: 1,952
Website

Re: RSS not working

phiw13 wrote #333362:

curious: how does one set NNW as default RSS reader, it does not seem to offer any preference for doing that (like any other browser or RSS reader does).

That seems a known issue with images

i have an older version of NNW and it has a preference although it seems to get ignored after each quit. but while active it will open the rss link.

i decide to vist https://daringfireball.net/feeds/ and on safari clicking of the RSS or the Json file just opens the xml files…. in other words not any solution, on my old laptop there is no option for NNW.

Next I decided to install NNW on iOS and lo an behold visting the rss on wion.com works just fine!

And finally now that i have finished this testing i’ll probably never click a RSS link again. and so it goes.


…. texted postive

Offline

#32 2022-05-18 06:35:30

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,700
Website

Re: RSS not working

bici wrote #333365:

i have an older version of NNW and it has a preference although it seems to get ignored after each quit. but while active it will open the rss link.

aha. An older version, with the typical NNW quirks to boot. I have the latest (NNW 6.1.something) and there does not seem to be a way to do that (e.g eventually override a system default). Vienna does offer a drop-down in the preferences window (and I see it recognizes that NNW exists and is RSS reader).

finally now that i have finished this testing i’ll probably never click a RSS link again. and so it goes.

Lol ! You win the internet(s) for today!

–^–

BTW (to Destry) – Speaking of Wion.com. I found it much more readable / easier on the eyes on the old worn-out iPhoneSE that on both the iMac or MBA (both Retina displays and latest OS). Dunno exactly what made it less confortable, maybe the font came over as a little hard, dunno.


Where is that emoji for a solar powered submarine when you need it ?

Offline

#33 2022-05-18 11:14:25

Destry
Member
From: Haut-Rhin
Registered: 2004-08-04
Posts: 4,851
Website

Re: RSS not working

bici wrote #333365:

Next I decided to install NNW on iOS and lo an behold visting the rss on wion.com works just fine!

I had since put the crufty feed URL under the link, and that one does work, so no surprise there. It’s the clean URL for the feed that is problematic, for some reason. But I’m not bothered about not having a clean feed URL, per se. That one hardly matters, I think.

phiw13 wrote #333366:

I found it much more readable / easier on the eyes on the old worn-out iPhoneSE that on both the iMac or MBA (both Retina displays and latest OS). Dunno exactly what made it less confortable, maybe the font came over as a little hard, dunno.

Thanks for the report. My apple gear, both laptop and phone, are ancient, so I don’t have the same means to see it. Not sure what to say except that I do like using a serif, and I chose this one only because it most approximated Livery (better) in appearance, what I would actually use if it was free. But I do remain open to finding a new serif, whatever style, if it pleases me. (I’ll get back to that hunt eventually.) The current one has the unfortunate lacking of an italic, so I drop in a different typeface for i, em, etc, but so it goes.

I have been trying to convince myself to get rid of fonts entirely, losing that page weight and file complexity, and just let system defaults take over, but gawd that shit is uncomfortable to look at.

Last edited by Destry (2022-05-18 11:23:27)

Offline

#34 2022-05-18 11:49:45

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,700
Website

Re: RSS not working

Destry wrote #333370:

Thanks for the report. My apple gear, both laptop and phone, are ancient, so I don’t have the same means to see it. Not sure what to say except that I do like using a serif, and I chose this one only because it most approximated Livery (better) in appearance, what I would actually use if it was free. But I do remain open to finding a new serif, whatever style, if it pleases me. (I’ll get back to that hunt eventually.) The current one has the unfortunate lacking of an italic, so I drop in a different typeface for i, em, etc, but so it goes.

I have been trying to convince myself to get rid of fonts entirely, losing that page weight and file complexity, and just let system defaults take over, but gawd that shit is uncomfortable to look at.

The character of that font is certainly most appropriate for you or your site, or that woodworking stuff you’re playing with. I wouldn’t change that. Maybe just a small tweak in the background-color? Maybe I’ll play a little with it trough the WebInspector.

And yes, the default browser fonts, any OS, are nothing but a headache, especially the serif choice (Times/Times New Roman) :-(.


Where is that emoji for a solar powered submarine when you need it ?

Offline

#35 2022-05-19 11:04:04

gaekwad
Server grease monkey
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,905
GitHub

Re: RSS not working

If this were me, I’d back up the current .htaccess, bash in the stock Textpattern .htaccess and then see if the RSS works in pretty mode. If it does, start adding stuff back in from the backed up one, incrementally test it, and see where it snaps.

Offline

#36 2022-05-19 12:01:12

Destry
Member
From: Haut-Rhin
Registered: 2004-08-04
Posts: 4,851
Website

Re: RSS not working

I kind of tried that with the current file, taking out all the things except what Txp needed. But a newer stock file is a good double-check.

On hold until the battery arrives, though. :)

Offline

Board footer

Powered by FluxBB