Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#49 2021-05-11 16:04:05

demoncleaner
Plugin Author
From: Germany
Registered: 2008-06-29
Posts: 180
Website

Re: bot_wtc v8 for Textpattern v4.7 (beta)

Have a look at $bot_arr_item_groups

Adding

'#main_content' => array (
         '.excerpt'
    ),

to the array solved the problem. Not sure if this solution brings other issues.
I guess there must be a better way to generally solve this than adding all custom_fields that are moved to main_content to this array.

Offline

#50 2021-07-14 09:49:49

gomedia
Plugin Author
Registered: 2008-06-01
Posts: 1,357
Website

Re: bot_wtc v8 for Textpattern v4.7 (beta)

Just had a tentative prod at bot_wtc. On TXP 4.8.7 running v8.0, when I untick the last hidden section I get:

Notice "Undefined variable: static_sections_string"
in /Users/adi/Sites/textpattern-4.8.7/textpattern/plugins/bot_write_tab_customize/bot_write_tab_customize.php at line 803.
textpattern/plugins/bot_write_tab_customize/bot_write_tab_customize.php:803 adminErrorHandler()
bot_wtc_tab()
textpattern/lib/txplib_misc.php:1589 call_user_func_array()
textpattern/index.php:231 callback_event()

BTW for anyone using adi_menu, be aware that may fiddle with the section list as well (if the user so chooses). This can cause issues with bot_wtc, as deamoncleaner has discovered. The next release of adi_menu will put a stop to this, in the meantime just set the two prefs to “name” & “no”.

Offline

Board footer

Powered by FluxBB