Textpattern CMS support forum

You are not logged in. Register | Login | Help

#101 2008-12-20 17:39:38

vittorio
Member
From: Roma caput mundi
Registered: 2006-02-01
Posts: 122
Website

Re: asv_tumblelog

merz1 wrote:

Does the code example #92 from above help?
In my 4.0.6 and 4.0.7 a delicious.com feed is handled fine and the items titles are used to generate the clean URLs.
Which feed is making problems? All feeds?

The problem doesn’t concern the feeds, it is with the bookmarklet and the quick-post you publish with it (like in tumblr): when I use the bookmarklet provided with the plugin to quick-post links/images/etc, the url of the source i’m taking from is correctly saved in a custom field, but the url of the post i’m creating is not saved in the url-title field, and the new post doesn’t get a permalink. To do it, i have to re-open the post in the “classic” write panel and re-save it.

I think a small hack to the bookmarklet’s code should suffice, but I have no idea of how to do it…


Happily served with Txp: Strampelli.net, Brain Essence, NicolaTranfaglia.com

Offline

#102 2008-12-20 23:54:23

stopsatgreen
Member
Registered: 2008-07-03
Posts: 50

Re: asv_tumblelog

I can’t believe I found this plugin! It seems like it’s going to save me a LOT of work!

Offline

#103 2008-12-21 21:26:33

stopsatgreen
Member
Registered: 2008-07-03
Posts: 50

Re: asv_tumblelog

Mostly very impressed, but have a few questions:

1. Is it possible to collate all entries to one article per date? That is, to have all Tweets (for example) for each day appear as one article, rather than many?

2. Is there a special command to run a cron job? In my site control panel I have a link to the URL (http://www.mysite.co.uk/?asv_tumblelog_updatefeeds=1), but it doesn’t seem to work; do I need to provide a more specific command?

3. The created articles don’t have a URL title; have I missed a step to make that work?

Last edited by stopsatgreen (2008-12-21 21:34:22)

Offline

#104 2009-01-10 22:07:55

Michel
New Member
From: Mülheim/Germany
Registered: 2007-02-10
Posts: 6
Website

Re: asv_tumblelog

Oh no :(

Defekter oder leerer Plugin-Code

in English:

broken or empty plugin code

Offline

#105 2009-02-01 18:10:32

neondragon
New Member
Registered: 2008-05-13
Posts: 2

Re: asv_tumblelog

umm, does anyone know how to implement this in a form (actually, which tag to use to make some things show up on the form, such as link for link-type post)?

Offline

#106 2009-02-02 00:33:25

merz1
Member
From: Hamburg
Registered: 2006-05-04
Posts: 994
Website

Re: asv_tumblelog

@neondragon Some pages back in the thread I have posted my form example.


Get all online mentions of Textpattern via OPML subscription: TXP Info Sources: Textpattern RSS feeds as dynamic OPML

Offline

#107 2009-02-11 22:05:08

danwoodward
Member
From: Brooklyn NY
Registered: 2006-08-06
Posts: 51
Website

Re: asv_tumblelog

Ok, I was really frustrated for a minute but I’m up and running now, locally on MAMP. I was getting the “Not Importing” notice, plus some initial errors.

1. So I went back to square 1, made a new database, my original was suffix of a parent database. DATABASENAME_no1, DATABASENAME_no2. So I made a whole new database without a suffix. I’m not sure that solved anything but it was a precaution I made. Maybe someone would want to confirm the validity of this.

2. I made a custom field name of “url” for custom 3, it didn’t matter what the name was as long as it was named.
3. Then made sure to set the “Source Link Field” to that custom field i just made. You could probably set it to any of your fields though
4. Made sure to set “Feed ID Field” to a unique custom field too.
5. And of course as previously mentioned, get the whole path to the simplepie.inc file like this if your running local /Users/USERFOLDER/SITENAME/php/simplepie.inc
6. heres where i was getting tripped up After trying to import a feed and getting one error then trying to import the same feed again it was saying “Not Importing”. And that is because, it may have not imported the articles before but it did import images, if you selected that. The plugin was assuming an import already occured and wouldn’t import the same thing. So I just went to my images tab and delete those imported images then with the proper settings running the manual import again and it should be all set.

I hope this helps someone.

Offline

#108 2009-03-25 23:48:06

fowler
Member
Registered: 2007-02-12
Posts: 79

Re: asv_tumblelog

i’ve been pouring through this thread and it seems like no one has figured this out..

i keep getting mysql errors when i’m importing rss feeds..

tried a bunch of different things, including the above post… and nothing.

using 4.0.8 and the latest plugin. any figure anything out?

Offline

#109 2009-08-31 11:37:17

nardo
Member
From: tuvalahiti
Registered: 2004-04-22
Posts: 741

Re: asv_tumblelog

also getting mysql errors:

A problem occured while loading the plugin: asv_tumblelog -> User_Warning: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '
						uid             = '850dca7b4a50824015b59a4d466bfead',
						feed_time    ' at line 21
insert into textpattern set Title           = 'My title',
						Body

using version 1.6.1 of the plugin with Txp 4.2.0

and anyone who has used this plugin successfully – I want to get a georss feed from Flickr – is it possible to grab the lat/long with this? I’d like to store them in a custom field in each article to generate a map

thanks

Last edited by nardo (2009-08-31 11:37:34)

Offline

#110 2009-08-31 11:58:37

nardo
Member
From: tuvalahiti
Registered: 2004-04-22
Posts: 741

Re: asv_tumblelog

I got 1.6.2 and it works

Last edited by nardo (2009-08-31 14:45:46)

Offline

Board footer

Powered by FluxBB