Textpattern CMS support forum

You are not logged in. Register | Login | Help

#21 2007-04-01 19:55:48

bzx
Member
Registered: 2007-01-11
Posts: 15

Re: [plugin] [ORPHAN] ako_write_page_email

net-carver wrote:

Looks like it might be a PHP4 issue … are you running on a PHP4 host?

hm.. didn’t think of it, but i don’t think that’s the cause. i can switch between PHP 4 and 5, i’ll see what’s the result and let you know…
just checked – nope, that’s not the issue.

btw. can anyone check if the insert buttons work when you open that link not in popup but in a new tab of firefox ?

peace

Offline

#22 2007-04-01 20:16:42

akokskis
Plugin Author
From: Baltimore-ish, USofA
Registered: 2004-11-28
Posts: 230
Website

Re: [plugin] [ORPHAN] ako_write_page_email

I just tried with a new tab instead of a popup and it didn’t seem to work.
The way the JS works, as I recall, it should only actually work in a popup window, as a new tab is treated by the browser differently than a new poped up window (as in they have different JS variables, etc).
I would think that if you used it as a popup, the insert buttons should work.
Cheers.


My Photoblog, and my personal site. Got nav? ako_nav.
Thanks for taking the time to look…

— vc3 —

Offline

#23 2007-04-01 21:11:51

bzx
Member
Registered: 2007-01-11
Posts: 15

Re: [plugin] [ORPHAN] ako_write_page_email

Thanks man (that was my mistake, i thoguht i can’t get the console with a popup, but i can.. nevermind..)

anyway here’s the error from the console:
Error: window.opener.edInsertContent is not a function

And i found the error in your plugin code, and i was able to fix it :)
Errors in line 131 and 133, just before the declaration of the function “edInsertContent”:

Not working for me:
if (body) { window.opener.edInsertContent(window.opener.document.getElementById("body"), insert); } else { window.opener.edInsertContent(window.opener.document.getElementById("excerpt"), insert); } }

Working for me:
if (body) { edInsertContent(window.opener.document.getElementById("body"), insert); } else { edInsertContent(window.opener.document.getElementById("excerpt"), insert); } }

I’m sure that I have the latest version of your plugin, but it’s kinda strange that it worked for everyone else but me, even with that strange error – which I can’t tell if the fix is correct because I don’t know JS ;)

Peace

Last edited by bzx (2007-04-01 21:15:34)

Offline

#24 2007-04-03 22:08:03

bzx
Member
Registered: 2007-01-11
Posts: 15

Re: [plugin] [ORPHAN] ako_write_page_email

no comments ?
ok cool, i’m glad it worked for me.

i also changed the function to have the link displayed under Textile Help, which is quicker than having it all the way down in Advanced.
just replaced “advanced” with “textile_help” in the declaration of ako_write_page_email() (optionally for those with txp 4.0.3 it’s in the function ako_write_page_email_old()).

peace

Offline

#25 2007-04-03 22:21:00

akokskis
Plugin Author
From: Baltimore-ish, USofA
Registered: 2004-11-28
Posts: 230
Website

Re: [plugin] [ORPHAN] ako_write_page_email

Hmmm… haven’t had a chance to look at that change you made – I’ll look at it sometime soon and get back to you.


My Photoblog, and my personal site. Got nav? ako_nav.
Thanks for taking the time to look…

— vc3 —

Offline

#26 2007-04-04 06:28:35

bzx
Member
Registered: 2007-01-11
Posts: 15

Re: [plugin] [ORPHAN] ako_write_page_email

no probs, i hope it could help someone.
i’ll check here in a few weeks.

peace

Offline

#27 2008-04-02 18:05:55

masa
Member
From: Asturias, Spain
Registered: 2005-11-25
Posts: 1,091

Re: [plugin] [ORPHAN] ako_write_page_email

This used to be a handy little addition for clients, but I’ve just installed it under 4.0.6 and it doesn’t seem to work anymore:

the tag produced shows all special characters converted to html entities, e.g. &lt;txp:email email=&quot; etc. instead of <txp:email email=" and the insert buttons don’t do anything.

The tag builder on the forms page – which this plugin calls upon as far as I understand – works fine.

Any chance for a fix?

Last edited by masa (2008-04-02 18:06:53)

Offline

#28 2009-08-31 18:23:47

masa
Member
From: Asturias, Spain
Registered: 2005-11-25
Posts: 1,091

Re: [plugin] [ORPHAN] ako_write_page_email

Just to bump this up one more time.

I know Adrian isn’t around anymore, but it would be nice if someone could fix this plugin – it would be very useful.
Or if there are other ways allowing clients to easily insert spam-proof email links, I’m all ears.

Last edited by masa (2009-08-31 18:24:44)

Offline

#29 2009-08-31 19:48:17

TheEric
Plugin Author
From: Wyoming
Registered: 2004-09-17
Posts: 564

Re: [plugin] [ORPHAN] ako_write_page_email

I’m updating this plugin and I’ll take it over. It’s a rather basic rewrite.

Offline

#30 2009-09-01 17:27:51

masa
Member
From: Asturias, Spain
Registered: 2005-11-25
Posts: 1,091

Re: [plugin] [ORPHAN] ako_write_page_email

Thanks, Eric.

I was hoping it would be simple.

Offline

Board footer

Powered by FluxBB