Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2006-09-26 05:05:24

akokskis
Plugin Author
From: Baltimore-ish, USofA
Registered: 2004-11-28
Posts: 230
Website

[plugin] [ORPHAN] ako_write_page_email

ako_write_page_email
Add a little link to the email tagbuilder on the write page of the TXP interface.

Just install and activate this plugin and it’ll work. I’m not sure about 4.0.3 compatability, but most certainly compatable with 4.0.4. If someone would be willing to test and let me know, that’d be great.

Well, here’s another quick and easy one from me, myself and I, as requested by ma_smith.

Download v.2
(No help file yet)

Last edited by akokskis (2006-10-06 18:57:46)


My Photoblog, and my personal site. Got nav? ako_nav.
Thanks for taking the time to look…

— vc3 —

Offline

#2 2006-09-26 17:22:21

hamba
Member
Registered: 2006-08-04
Posts: 22

Re: [plugin] [ORPHAN] ako_write_page_email

Thanks this is working perfectly on
version: 4.0.3 (r1836)

Cheers

Offline

#3 2006-10-06 15:52:13

feragnoli
Member
From: the hague
Registered: 2005-02-10
Posts: 150

Re: [plugin] [ORPHAN] ako_write_page_email

actually… what is that this plugin actually does?
thanks.


what was that again…?

Offline

#4 2006-10-06 16:13:05

squaredeye
Member
From: Greenville, SC
Registered: 2005-07-31
Posts: 1,495
Website

Re: [plugin] [ORPHAN] ako_write_page_email

it adds a link to your “write” tab (left side bar), so that you can build an obfuscated email tag to insert into articles. Makes it easier for clients. I think AKO is making it insertable via JS as well :)


Offline

#5 2006-10-06 18:48:27

masa
Member
From: Asturias, Spain
Registered: 2005-11-25
Posts: 1,091

Re: [plugin] [ORPHAN] ako_write_page_email

Adrian,

I installed the current version under 4.0.3, but sadly it still doesn’t show. What could be the problem?
My installation is unmodified except for the following plug-ins:

  • glx_admin_image
  • rss_thumbpop
  • upm_img_popper
  • upm_quicktags
  • wet_article_thumb
  • zem_contact

I’ve tried disabling Mary’s upm_img_popper & upm_quicktags since they also modify the ‘Write’ tab, but to no avail.

Cheers Martin

Offline

#6 2006-10-06 18:56:21

akokskis
Plugin Author
From: Baltimore-ish, USofA
Registered: 2004-11-28
Posts: 230
Website

Re: [plugin] [ORPHAN] ako_write_page_email

That’s quite correct, ma_smith.

In any event, here’s version 0.2 coming at you all. In this version, you can now click a cute little button in the tag builder to automatically insert the link into either the body or the excerpt of the article.

As an aside concerning compatability, I think that 4.0.3 support is still sketchy (wish those <code>textarea</code>s had <code>id</code>s). I’m pretty sure that the pop-up window will work and all, but I don’t believe that automatic insertion of the <txp:email> tags is functional. This is something that I’d like to remedy in the next few days. Sorry about it though. It may seem odd that it doesn’t fully work with the current version of TXP, but I do my development in a TXP install that I keep up to date with the svn repo.

Download v.2

As always, I’m open for ideas or what not.
Cheers.

Last edited by akokskis (2006-10-06 18:58:10)


My Photoblog, and my personal site. Got nav? ako_nav.
Thanks for taking the time to look…

— vc3 —

Offline

#7 2006-10-06 18:57:20

akokskis
Plugin Author
From: Baltimore-ish, USofA
Registered: 2004-11-28
Posts: 230
Website

Re: [plugin] [ORPHAN] ako_write_page_email

Martin, I think that the new version will go a little ways in solving your problem. Give it a try, and let me know how things work out with that.


My Photoblog, and my personal site. Got nav? ako_nav.
Thanks for taking the time to look…

— vc3 —

Offline

#8 2006-10-06 19:13:48

masa
Member
From: Asturias, Spain
Registered: 2005-11-25
Posts: 1,091

Re: [plugin] [ORPHAN] ako_write_page_email

It’s getting there. It now shows up under the ‘advanced’ options, at the bottom.

When clicking it however, it opens in a new tab in the current browser window (FF 1.5.0.7) and after filling in the form and submitting it, it just does nothing.

Any ideas?

Offline

#9 2007-03-31 20:38:54

squaredeye
Member
From: Greenville, SC
Registered: 2005-07-31
Posts: 1,495
Website

Re: [plugin] [ORPHAN] ako_write_page_email

akoksis, I hadn’t even noticed you’d added v.2.

Nice. I’ll test soon.

m


Offline

#10 2007-03-31 21:15:00

akokskis
Plugin Author
From: Baltimore-ish, USofA
Registered: 2004-11-28
Posts: 230
Website

Re: [plugin] [ORPHAN] ako_write_page_email

Cool beans!
Let me know if something goes awry.


My Photoblog, and my personal site. Got nav? ako_nav.
Thanks for taking the time to look…

— vc3 —

Offline

Board footer

Powered by FluxBB