Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2024-04-02 17:34:27

MacBanshee
Member
Registered: 2016-03-15
Posts: 12

one event won't show details

I have posted several events, which have details which expand from the events list, but one particular event does not expand. It can only be seen with this URL: https://tucsonirishcommunity.com/index.php?s=Events, but the details won’t expand from here: https://tucsonirishcommunity.com/Events/celtic-woman-20th-anniversary-tour-concert-at-centennial-hall, which is what you click when you click on the event from the events listing at https://tucsonirishcommunity.com/. I put the other two current events in at the same time and the same way and can’t figure out the problem. I have recreated this event from scratch several times, but I get the same result. I am using version 4.5.7 and haven’t upgraded because I am not a web person and don’t understand how to do it. (My daughter, who originally created this website died, so I can’t ask her. I have been able to maintain this site for the past 11 years, but am stumped on this.)

Offline

#2 2024-04-02 18:29:20

etc
Developer
Registered: 2010-11-11
Posts: 5,053
Website GitHub

Re: one event won't show details

I don’t know what kind of calendar (plugin?) is used, but I’d suspect the problem comes from here:

We will put the correct date in the event title if the generated date is wrong

  • Old Blind Dogs Concert at Berger Center – 04/20/2024
  • The Wild Swans, The Wind that Shakes the Corn – 04/27/2024
  • Celtic Woman Concert at Centennial Hall 5/5/2024 -

As you see, the last event has no date set (after -), please compare with other events.

Offline

#3 2024-04-02 20:10:29

MacBanshee
Member
Registered: 2016-03-15
Posts: 12

Re: one event won't show details

I had to put the date in the title becasue even though the date is entered in the event settings panel, it does not “stick” after I save the entry. That’s my problem. No matter how many times I re-enter everything in the event settings panel, as soon as I hit save, it disappears. (It still shows on the screen after it says the event has been posted, but as soon as I am off that screen and pull up the article, the event panel setting information is no longer there.)

Last edited by MacBanshee (2024-04-02 20:16:37)

Offline

#4 2024-04-02 21:59:50

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 11,269
Website GitHub

Re: one event won't show details

Are you using my smd_calendar plugin? Do you know which version? If so, I’m happy to take a look if you’ll please send me a login. Might be something wonky with the plugin.

Before that though, please check this. When you save the article (event) do you get a green success message at the bottom of the screen, or does it throw an amber or red warning box? Or display nothing at all?

If it’s any of the latter, I wonder if there is something in your server host’s anti-spam filters that is tripping up the save process. We’ve seen this before where, for whatever reason, a word or something in the post just makes the spam filter twitchy and it refuses to save, when other articles are just fine.

What happens if you cut most of the body text out and stash it somewhere safe, then add your event date as you normally would and save the article? Preview it to check the date has ‘taken’. If it has, paste your article body text back in a few sentences at a time and save after each one, checking the article on the website each time to make sure it shows up fine. At some point you might come across a line or word or something that doesn’t save. That’s the trigger. Sometimes just rewording that bit slightly can make things work.

I once had a host that wouldn’t save an article and I did the above trick to narrow it down. Turns out it was the word “CD” which, combined with all the other words in the article, made the anti-spam filter have a hissy fit. I changed the word to ‘Compact Disc’ and it saved just fine. Go figure, as they say.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Online

#5 2024-04-03 02:35:37

MacBanshee
Member
Registered: 2016-03-15
Posts: 12

Re: one event won't show details

I tried your suggestion re: not putting much in the body text (I just wrote Celtic Woman concert), but got the same result as previously. There is an amber bar that reads: Article posted. The same URL-only title is used by 2 different articles. The other ones are hidden (there were 4 with Celtic Woman in the title). I have deleted the hidden articles, and put the inofrmation in again, which got me a green “article posted.” However it still doesn’t show the date in the list, and the event settings panel is back to being blank when I go to the article.

I think this is plugin information (I cut and pasted the line from Administration>plugins):
zem_event Alex Shiels 0.30 Yes Event calendar

Note that I tried accessing in two different browsers and cleared the cache, to no effect.

Last edited by MacBanshee (2024-04-03 02:36:26)

Offline

#6 2024-04-03 06:50:59

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 11,269
Website GitHub

Re: one event won't show details

Hmmm that’s very weird then. Thank you for trying. I don’t know much about that ancient plugin. Maybe it’s interfering with the saving process somehow and it’s throwing a wobbly.

How do you enter the event date(s)? Is it in a custom field somewhere? If so, try disabling the plugin by toggling its Status to No in the Plugins panel, then edit your article and save it. Turn the plugin back on and see if that makes any difference.

Doing that should determine if the plugin is meddling with the Write panel.

If the plugin itself adds dedicated fields for the event dates, then you won’t be able to test it that way.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Online

#7 2024-04-03 09:33:34

etc
Developer
Registered: 2010-11-11
Posts: 5,053
Website GitHub

Re: one event won't show details

MacBanshee wrote #337007:

I had to put the date in the title becasue even though the date is entered in the event settings panel, it does not “stick” after I save the entry.

Did it happen after a server update? Recent db versions are picky about datetime fields, you’ll probably need to update textpattern as well.

Offline

Board footer

Powered by FluxBB