Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2023-04-18 13:39:46

dg
Member
Registered: 2023-03-29
Posts: 15

Fixing broken sliders after upgrade

After upgrading to Txp v4.8.8 a couple of sliders have stopped working. On the home page, there is a picture in the background with a slider on the bottom right of it. The picture remained fixed and as you go down the page the content slides up over the picture.

But after the upgrade, the items in the slider now show as a list on the picture which has also become smaller, about half of it missing at the bottom and no longer fixed in the background.

Second slider (testimonial) is further down the page and two items in it appear one after the other as normal text on a page.

As suggested by Gaekwad, I give below some of the code from Presentation>Pages>default. Not sure if this is what is needed but please let me know if something else is needed to try and fix the sliders.

<!— home content —> <section id=“home” data-stellar-background-ratio=“0.5” > <div class=“slider”> <ul class=“home_slider”> <txp:article_custom category=“slider” break=”“> <li> <span><txp:title /></span> <p><txp:body /></p> </li> </txp:article_custom> </ul> </div>

<div class=“container”> <div class=“welcome_block”>

</div>

<!— section header —> </div> <div class=“home_fill”></div> </section><!— //home content —>

Code re second slider: <!— Testimonials content —> <section class=“testimonials”> <!— bxSlider—> <ul class=“booking_testimonials”> <txp:article_custom category=“booking-testimonials”> <li> <div class=“testimonials_block”> <div class=“testimonials_txt”><txp:body /></div> <div class=“author_inf”><txp:excerpt /></div> </div> </li> </txp:article_custom>

</ul><!— //bxSlider—> <div class=“testimonials_fill”></div> </section><!— //Testimonials content —>

Hope you can help.

Last edited by dg (2023-04-18 13:40:44)

Offline

#2 2023-04-18 13:48:16

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 11,299
Website GitHub

Re: Fixing broken sliders after upgrade

Is it possible to share a URL to the site please? Sometimes scripts that control the slider might be prevented from downloading or running for some reason.

If you can’t share the URL, take a look at the browser console (usually, right click a page element and choose Inspect). Switch to the Console tab in the inspector and refresh the page. If you scroll through the list of errors/warnings that show up, it might give a clue what’s going on.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#3 2023-04-18 14:34:41

dg
Member
Registered: 2023-03-29
Posts: 15

Re: Fixing broken sliders after upgrade

Browser console comes up with a number of errors; most of them mean nothing at all to me!

The URL is FreeBookingService.co.uk

Offline

#4 2023-04-18 16:09:34

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 11,299
Website GitHub

Re: Fixing broken sliders after upgrade

Thanks. The first thing to look at then is this console error:

Blocked loading mixed active content "http://ajax.googleapis.com/ajax/libs/jquery/1.10.1/jquery.min.js"

What that’s saying is that your site is serving secure content (https) but that request is trying to fetch jQuery over a non-secure protocol (plain http). And the browser has decided that’s not a good idea so it blocked the script. You’ll need to find where that’s loaded in your page (looks like it’s somewhere near the end of your page template, perhaps in a Presentation->Form) and change it.

If you can’t find it hunting by hand, install the smd_where_used plugin and enable it from your Administration->Plugins panel. You’ll then be able to visit the Extensions->Where used panel and search for jquery. That should help locate it.

When you find the relevant line of template code, just change its URL from http to https, save the changes and refresh. We’ll go from there and see if that improves things.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#5 2023-04-18 23:12:43

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 3,105
Website

Re: Fixing broken sliders after upgrade

I see two issues (possibly) related to your sliders: the error highlighted by Stef (Bloke) above, and then a failure to find the /css/prettyPhoto.css – either the URL given is wrong ro that file is missing. Unclear to me at the moment if the latter is actually used.

A similar issue with fonts, where http://fonts.googleapis.com/css?family=Lato is not allowed. The fix is the same as for the jQuery.js – replace http: with https:

Actually, it might be a good idea to search for all occurrences of http: in your templates; the “smd_where_used” extension is great for that work.


Where is that emoji for a solar powered submarine when you need it ?
Sand space – admin theme for Textpattern

Offline

#6 2023-04-19 09:12:35

dg
Member
Registered: 2023-03-29
Posts: 15

Re: Fixing broken sliders after upgrade

Thank you Stef. I installed & enabled the smd_where_used plugin; jquery search produces 3 pages:
archive | default
default | default
test | default

Do I need to change http: to https: on all three pages?

Also, there is another plugin (soo_editarea) which is not active. Do I need to activate it?

Offline

#7 2023-04-19 09:18:32

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 11,299
Website GitHub

Re: Fixing broken sliders after upgrade

Yes, I would alter any reference of http to https, since your site is being served as https. Once you’ve done that, refresh the page and see if it’s any better.

As phiw13 says, that CSS file is also not loading. Could be because it’s not physically in that place on the server, or the permissions to that directory/file are incorrect, or the browser is rejecting it for some security reason. We can tackle that issue next, once the https thing is sorted.

As for the other plugin, I’m not sure what it does but it may be an admin side helper plugin. Leave it disabled for now and I’ll do some research on what it is and get back to you.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#8 2023-04-19 09:57:28

dg
Member
Registered: 2023-03-29
Posts: 15

Re: Fixing broken sliders after upgrade

Changing to https has fixed the site – all working as it was originally designed to do. CSS file not loading does not seem to matter. Also, there are a couple of other errors in the site inspection console but again they do not seem to affect the site.

Stef, thank you so much for all your help. As you would have gathered, I have little or no understanding of Txp and without your help would not have got the site fixed. It’s not the best site in the world (doesn’t look good on mobiles) but will have to do until we can afford to have something better put together.

Offline

#9 2023-04-19 10:48:22

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 11,299
Website GitHub

Re: Fixing broken sliders after upgrade

You’re welcome. There’s a tonne of information here in the forum or the documentation. We’re here to help so feel free to ask questions.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

Board footer

Powered by FluxBB