Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2022-07-21 03:10:51

peterj
Member
From: Melbourne, Australia
Registered: 2005-06-02
Posts: 99

Newer / Older tag error on upgrade to 4.8.8

I’m just updating an older site which has some sections basically acting as single pages, so not using txp:article to output a list.

After an upgrade from 4.8.2 to 4.8.8 I saw this:

Tag error: <txp:newer rel="prev"><txp:text item="newer" /></txp:newer> ->  Textpattern Warning: secondpass < 2 while parsing form None on page default_1

Resolved, sort of, by finding the pesky sections and excluding them.

                        <txp:if_section name="authors,contact,books" not>
							<txp:evaluate test="newer,older">
								<nav class="paginator" aria-label="<txp:text item="page_nav" />">
									<txp:newer rel="prev">
										<txp:text item="newer" />
									</txp:newer>
									<txp:older rel="next">
										<txp:text item="older" />
									</txp:older>
								</nav>
							</txp:evaluate>
                        </txp:if_section>

Offline

#2 2022-07-21 09:34:16

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,886
Website

Re: Newer / Older tag error on upgrade to 4.8.8

I think on the road between 4.8.2 and 4.8.8 some loose ends got tightened with prev / next, or may be it was a necessity for PHP 4.8.1 support. The actual result is that warning you get on pages/sections that actually have nothing to paginate.

Ran into a very similar error (warning) yesterday when being overly zealous while cleaning up some code (the result of my cleaning: no output… and then that warning).


Where is that emoji for a solar powered submarine when you need it ?

Offline

#3 2022-07-21 10:59:00

etc
Developer
Registered: 2010-11-11
Posts: 4,881
Website GitHub

Re: Newer / Older tag error on upgrade to 4.8.8

This warning has been added to help with setting up some new facilities, but you can safely ignore it in your case.

Offline

#4 2023-04-12 13:48:11

funtoosh
Member
From: Münster, Germany
Registered: 2006-10-09
Posts: 151
Website

Re: Newer / Older tag error on upgrade to 4.8.8

So I get the same error … but why?
And why are some sections pesky and cause while parsing form None

Not really sure about how to repair this.

Cheers! -f

Offline

#5 2023-04-12 20:57:19

etc
Developer
Registered: 2010-11-11
Posts: 4,881
Website GitHub

Re: Newer / Older tag error on upgrade to 4.8.8

This probably means that your page template contains <txp:newer|older /> tags, but no <txp:article /> tag needed for their functioning. There is nothing really wrong with this, but you can try to <txp:hide /> the offending block.

We can remove this warning, but then debugging such cases will be more difficult.

Offline

#6 2023-04-13 08:21:09

funtoosh
Member
From: Münster, Germany
Registered: 2006-10-09
Posts: 151
Website

Re: Newer / Older tag error on upgrade to 4.8.8

Okay, thanx, I’ll go check that!

Offline

Board footer

Powered by FluxBB