Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#13 2023-04-03 12:09:56

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 11,299
Website GitHub

Re: My site won't upgrade from CMS 4.5.7

zem_contact_reborn is out of date and has been superseded by com_connect. There’s an upgrade guide in the plugin help.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#14 2023-04-03 14:33:46

etc
Developer
Registered: 2010-11-11
Posts: 5,090
Website GitHub

Re: My site won't upgrade from CMS 4.5.7

dg wrote #335240:

I think this may have to do with the plugins folder which is now in the textpattern folder in the root directory but wasn’t in the old oversion. Should I delete this?

No, they would be recreated anyway. If you can access the admin side, just go to Preferences/Plugins and disable zem_contact_reborn. You’ll get some warning about unregistered tags (those of the plugin), though.

Offline

#15 2023-04-04 10:57:23

dg
Member
Registered: 2023-03-29
Posts: 15

Re: My site won't upgrade from CMS 4.5.7

Thank you etc. If I make zem_contact_reborn and zem_contact_lang inactive, wont this affect something on the website (may be contacts form)?

Offline

#16 2023-04-04 11:14:24

gaekwad
Server grease monkey
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 4,154
GitHub

Re: My site won't upgrade from CMS 4.5.7

dg wrote #335262:

If I make zem_contact_reborn and zem_contact_lang inactive, wont this affect something on the website (may be contacts form)?

Best route here would be to translate the contact form tags you’re using at the moment into the com_connect parlance, and drop them into place. Have a look here for the info.

Offline

#17 2023-04-04 12:24:57

dg
Member
Registered: 2023-03-29
Posts: 15

Re: My site won't upgrade from CMS 4.5.7

Many thanks Gaekwad.

This is a one page site and looking at Oage Coe in Presentation>Pages there is this re zem_contact:

<!— Contact content —> <section id=“contact” class=“page_section”> <!— section header —> <div class=“container”> <h3>Get a call back!</h3> <div class=“row”> <div class=“span6”> <txp:zem_contact to=“info@xyz.co.uk”> <span> <txp:zem_contact_text label=“Your Name” />
<txp:zem_contact_email /> <txp:zem_contact_text label=“Your Phone Number” required=“0” /> </span> <span> <txp:zem_contact_radio label=“H Booking Service” group=“Service” /> <txp:zem_contact_radio label=“V Booking Service” /> </span> <span> <txp:zem_contact_textarea required=“0” label=“Optional Message” /> <txp:zem_contact_submit label=“Send” /> </span> </txp:zem_contact> </div> <div class=“span6”>

<txp:article_custom category=“contact” />

If replace all instances of zem_contact_??? with com_connect, will that do?

I have downloaded the com_connect-V4.7.txt file from the link you gave. After making above changes, should I install the plugin by pasting the code in the file into install plugin box?
And delete zem_contact_reborn and zem_contact_lang plugins?

Offline

#18 2023-04-04 12:46:39

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 11,299
Website GitHub

Re: My site won't upgrade from CMS 4.5.7

dg wrote #335264:

If replace all instances of zem_contact_??? with com_connect, will that do?

Yes, in your case the upgrade is that simple.

I would:

1. Download and install the com_connect plugin.
2. Activate it.
3. Make the changes to the page code template as outlined above, and save them.
4. Disable zem_contact_reborn and zem_contact_lang

Check your site still works as intended. If all seems good you can delete both zem_contact plugins.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#19 2023-04-05 10:49:08

dg
Member
Registered: 2023-03-29
Posts: 15

Re: My site won't upgrade from CMS 4.5.7

Thank you Bloke, that’s done it! Site upgraded to 4.8.8

I would also like to thank all the other contributors for their help. Without you I would not have got there.

All that remains to be done now is to fix the sliders which have stopped functioning. Haven’t a clue how to do that but will have to figure it out.

Offline

#20 2023-04-05 22:30:26

bici
Member
From: vancouver
Registered: 2004-02-24
Posts: 2,077
Website Mastodon

Re: My site won't upgrade from CMS 4.5.7

dg wrote #335277:


All that remains to be done now is to fix the sliders which have stopped functioning. Haven’t a clue how to do that but will have to figure it out.

perhaps it is using javascript ? Are the file paths all correct?


…. texted postive

Offline

#21 2023-04-06 16:23:45

gaekwad
Server grease monkey
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 4,154
GitHub

Re: My site won't upgrade from CMS 4.5.7

dg wrote #335277:

Site upgraded to 4.8.8

Congratulations!

All that remains to be done now is to fix the sliders which have stopped functioning. Haven’t a clue how to do that but will have to figure it out.

Post some code (& errors if you have them) in a new thread, we can have a look.

Offline

Board footer

Powered by FluxBB