Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2022-06-23 19:59:29

raminrahimi
Member
From: India
Registered: 2013-03-19
Posts: 249

Saving problem

I’ve TXP v4.8.0 and PHP 7 in a shared hosting server.
When I make any changes in the article, preferences etc… after saving it will appear saved successfully, but when I’m going back to that article list again the previous title shows. After that if i sort the articles ASC/DESC or logout txp and login back, the new changes appear.
Again when I click that article to edit, the previous contents will appear, looks coming from the cache !

Here is an example of article which it’s title is TitleOld and the body content has BodyOld:
TitleOld , BodyOld —> I edited to TitleNew , BodyNew
Click Content —> Articles (article will list and shows TitleOld)
Clicked Sort by ID two times, now the article title shows TitleNew
Or if I logout from txp and login, going to articles list —> the title shows TitleNew
When I click the article to edit, again the previous content comes (TitleOld , BodyOld)

Offline

#2 2022-06-24 00:30:01

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,276

Re: Saving problem

Ramin, if these problems are admin side only, you could try rah_nocache.


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#3 2022-06-24 02:43:23

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,697
Website

Re: Saving problem

Just after saving an article or preferences, do you see (unexpected) messages in the browser console?

It could be, as Uli says, a caching problem. I don’t know that extension, what I (and other users) have done is always keep the browser developper tools open – on the Network pane you should see a “disable cache” button (icon) or checkmark. It usually turned to “on” by default.


Where is that emoji for a solar powered submarine when you need it ?

Offline

#4 2022-06-24 08:05:44

raminrahimi
Member
From: India
Registered: 2013-03-19
Posts: 249

Re: Saving problem

I tried the following steps and now works fine for me:
1. Disabled the NGINX Caching which is the new feature of cPanel.
2. Disabled the ModSecurity feature in the cPanel.
3. Installed the rah_nocache plugin.
4. Cleared the browser cache and cookies.

Note: By default in each hosting account ModSecurity is enabled, but we must turn off that for textpattern websites, because we can’t save article, preferences, pages template. If possible to consider this issue and solve in the next TXP version.
___
Thank you all :-)

Offline

#5 2022-06-24 15:57:00

etc
Developer
Registered: 2010-11-11
Posts: 4,662
Website GitHub

Re: Saving problem

raminrahimi wrote #333620:

If possible to consider this issue and solve in the next TXP version.

To help with fixing this issue, could you tell us whether rah_nocache alone suffices?

Offline

#6 2022-06-24 20:11:10

raminrahimi
Member
From: India
Registered: 2013-03-19
Posts: 249

Re: Saving problem

Yes, I think that fixed the problem of admin cache.
But, the issue of saving article, preferences, pages template needs to turn off the mod_security through cPanel is available. Because when the mod_security is turn ON through cPanel and we save pages template, the 404 error page comes.

Last edited by raminrahimi (2022-06-24 20:15:43)

Offline

Board footer

Powered by FluxBB