Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2022-03-30 12:27:30

helsinkifrostbites
Member
From: Ystad, Sweden
Registered: 2007-11-16
Posts: 44
Website

[SOLVED] Articles and Sections pages on admin side show no content?

Txp 4.8.8. New install, everything else working as normal as far as I can see. Only the Presentation > Sections page is blank. The Default section selector is there, and it lists all the sections I’ve created. Directly below that, there’s the “Display x per page” pagination buttons, and nothing in between.

Same thing with Content > Articles. There’s the New article button and the Search bar, and nothing else.

I can see the 6 latest articles in the list on the Write page, and I can edit articles, and all the sections are there in the selector. I can access other articles by writing the ID directly in the address bar, or using the Prev/Next buttons.

Everything works normally on the frontend site, my sections show up in the nav and the articles show up where expected.

But I can’t edit or delete sections, and the Articles list would be pretty bloody convenient.

Any ideas what could be causing this?

Last edited by helsinkifrostbites (2022-03-30 13:25:29)

Offline

#2 2022-03-30 13:00:58

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,877
Website GitHub Twitter

Re: [SOLVED] Articles and Sections pages on admin side show no content?

Hi,
Do the diagnostics provide you with any hint?


Yiannis
——————————
neme.org | hblack.net | EMAP | NeMe @ github
I do my best editing after I click on the submit button.

Offline

#3 2022-03-30 13:14:14

helsinkifrostbites
Member
From: Ystad, Sweden
Registered: 2007-11-16
Posts: 44
Website

Re: [SOLVED] Articles and Sections pages on admin side show no content?

I’m no wiser, the diagnostics look typical to me. Here it all is in case someone sees something:

Textpattern version: 4.8.8 (a5969b336c096d872a7ecab9ee25914b)
Last update: 2022-03-30 12:05:43/2022-03-30 12:04:45
Site URL: ystadskulturhistoriska.se
Admin URL: ystadskulturhistoriska.se/textpattern
Document root: /customers/4/e/8/ystadskulturhistoriska.se/httpd.www
$path_to_site: /customers/4/e/8/ystadskulturhistoriska.se/httpd.www
Textpattern path: /customers/4/e/8/ystadskulturhistoriska.se/httpd.www/textpattern
Article URL pattern: section_id_title
Production status: live
Temporary directory path: /customers/4/e/8/ystadskulturhistoriska.se/httpd.www/textpattern/tmp
PHP version: 7.4.28
GD Graphics Library: bundled (2.1.0 compatible); Supported formats: GIF, JPEG, PNG, WebP.
Intl extension: 7.4.28
Multibyte String extension: 7.4.28
Server time zone: Europe/Stockholm
Server local time: 2022-03-30 15:04:57
Daylight Saving Time enabled?: 1
Automatically adjust Daylight Saving Time setting?: 1
Time zone (GMT offset in seconds): Europe/Stockholm (3600)
MySQL: 5.5.5-10.3.34-MariaDB-1:10.3.34+maria~focal (mariadb.org binary distribution)
Database server time: 2022-03-30 13:04:57
Database server time offset: 1 s
Database server time zone: SYSTEM
Database session time zone: SYSTEM
Locale: sv_SE.UTF-8
Site / Admin language: sv / sv
Web server: Apache
PHP server API: cgi-fcgi
PHP SSL version: OpenSSL 1.1.1f 31 Mar 2020
RFC 2616 headers: 0
Server OS: Linux 5.4.0-80-generic
Admin-side theme: hive 4.8.8
Active plugins: soo_article_filter-0.3.3 soo_image-1.0.b.9 soo_txp_obj-1.1.3
Pre-flight check:
————————————
The following PHP functions (which may be necessary to run Textpattern) are disabled on your server: disk_total_space, diskfreespace
————————————
.htaccess file contents:
————————————
#BEGIN Textpattern
#DirectoryIndex index.php index.html
<IfModule mod_rewrite.c> RewriteEngine On #Options +FollowSymlinks #RewriteBase /relative/web/path/ RewriteCond %{REQUEST_FILENAME} -f [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^(.+) – [PT,L] RewriteCond %{REQUEST_URI} !=/favicon.ico RewriteRule ^(.*) index.php RewriteCond %{HTTP:Authorization} !^$ RewriteRule .* – [E=REMOTE_USER:%{HTTP:Authorization}]
</IfModule>
<IfModule mod_mime.c> AddType image/svg+xml svg svgz AddEncoding gzip svgz
</IfModule>

Offline

#4 2022-03-30 13:23:58

helsinkifrostbites
Member
From: Ystad, Sweden
Registered: 2007-11-16
Posts: 44
Website

Re: [SOLVED] Articles and Sections pages on admin side show no content?

Found the problem!

Illegal mix of collations on the db. All the tables in the database were utf8_swedish_ci, but the database itself was still utf8_general_ci.

Now everything works. I feel a bit dumb, but at least I learned something. Thanks colak, and anyone else who invested braintime.

Offline

Board footer

Powered by FluxBB