Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2022-01-14 14:29:04

Destry
Member
From: Haut-Rhin
Registered: 2004-08-04
Posts: 4,824
Website

Homebrew - MySQL

Can anyone that uses brew’s MySQL for macOS tell me what is supposed to happen when I upgrade an old installation… It’s been a while since I’ve done it.

Keep in mind, I have a late 2011 machine that is no longer supported. The latest OS it can run is High Sierra, which must be four OSs old already(?). Every time I run a brew command, it reminds of of this:

Warning [sometimes ‘Error’]: You are using macOS 10.13. We (and Apple) do not provide support for this old version. You will encounter build failures with some formulae. Please create pull requests instead of asking for help on Homebrew’s GitHub, Twitter or any other official channels. You are responsible for resolving any issues you experience while you are running this old version.

Last night I tried to brew update mysql. I’m pretty sure it was not the upgrade command, but I can’t recall for sure. Whatever it was, I lost connection to the database and started to panic. I tried some kind of brew fix command, or restart command, don’t remember, and it miraculously brought the old database connection back.

Currently, Txp diagnostics say I’m running MySQL: 5.7.13 (Homebrew), which is the old one I’ve been running a while.

If I run brew outdated, I get this:

mysql (5.7.13) < 8.0.27_1
openssl@3 (1.0.2h_1, 1.0.2k) < 3.0.1

If I run the command, brew info mysql, it reports mysql: stable 8.0.27.

The command line output goes on to say:

Open source relational database management system
https://dev.mysql.com/doc/refman/8.0/en/
Conflicts with:
  mariadb (because mysql, mariadb, and percona install the same binaries)
  percona-server (because mysql, mariadb, and percona install the same binaries)
/usr/local/Cellar/mysql/5.7.13 (13,344 files, 445.0MB) *
  Poured from bottle on 2016-06-20 at 12:57:11
From: https://github.com/Homebrew/homebrew-core/blob/HEAD/Formula/mysql.rb
License: GPL-2.0-only with Universal-FOSS-exception-1.0
==> Dependencies
Build: cmake ✔, pkg-config ✔
Required: icu4c ✔, libevent ✔, lz4 ✔, openssl@1.1 ✔, protobuf ✘, zstd ✔

I actually had to install the icu4c, libevent, lz4, and zstd dependencies, which were red exes before.

The protobuf dependent does not seem to want to install, though. When I try, it tries to install a dependency of its own…

Installing protobuf dependency: python@3.10

Which it seems to do until it runs into an error at the end:

==> ./configure --prefix=/usr/local/Cellar/python@3.10/3.10.1 --enable-ipv6 --datarootdir=/usr/local/C
==> make
==> make install PYTHONAPPSDIR=/usr/local/Cellar/python@3.10/3.10.1
==> make frameworkinstallextras PYTHONAPPSDIR=/usr/local/Cellar/python@3.10/3.10.1/share/python@3.10
==> /usr/local/Cellar/python@3.10/3.10.1/bin/python3 -m venv /private/tmp/pythonA3.10-20220114-30687-1
Last 15 lines from /Users/destry/Library/Logs/Homebrew/python@3.10/05.python3:
2022-01-14 12:23:56 +0000

/usr/local/Cellar/python@3.10/3.10.1/bin/python3
-m
venv
/private/tmp/pythonA3.10-20220114-30687-1bqwhe9/Python-3.10.1/whl_build

Error: Command '['/private/tmp/pythonA3.10-20220114-30687-1bqwhe9/Python-3.10.1/whl_build/bin/python3', '-Im', 'ensurepip', '--upgrade', '--default-pip']' returned non-zero exit status 1.

Do not report this issue to Homebrew/brew or Homebrew/core!

I don’t know what the ‘returned non-zero exit status 1’ part of the error means.

Another thing puzzling me is when installing the libevent dependency, for example, it says this at the end of the installation run:

Warning: The following dependents of upgraded formulae are outdated but will not
be upgraded because they are not bottled:
  mysql

This is where Homebrew semantics elude me, when it talks about casks, shelves, bottles, and whatever.

Oh, one final bit at the end of the output after running brew info mysql:

A “/etc/my.cnf” from another install may interfere with a Homebrew-built
server starting up correctly.

To restart mysql after an upgrade: brew services restart mysql

I do in fact have a my.cnf file at that location, and it gives a port number that is equal to what appears in the php configuration details via the diagnostics panel, under the mysqli section: mysqli.default_port: 3306.

Questions:

  1. Is the error for the Python3 dependent because my operating system is old? Is that the show stopper here for upgrading?
  2. What does it mean that mysql is not bottled?
  3. If all was optimal and well when I run brew upgrade mysql, then I should only need to then run brew services restart mysql and bingo, I’m connected with 8.0.27 functioning and appearing in Diagnostics?
  4. Should I try to run brew upgrade mysql at this point and see what happens? Or are there some obvious things needing addressed first (e.g. installing Python3 and ‘bottling’ mysql)?

Last edited by Destry (2022-01-14 14:37:21)

Offline

#2 2022-01-14 14:44:42

Destry
Member
From: Haut-Rhin
Registered: 2004-08-04
Posts: 4,824
Website

Re: Homebrew - MySQL

I did see that Homebrew works with Linux now, too, so that’s interesting. New to me, anyway. I like Homebrew because it makes it easy for me to install things that would probably be impossible otherwise. And I do want to make the jump to Linux eventually.

Offline

#3 2022-01-14 14:51:39

Destry
Member
From: Haut-Rhin
Registered: 2004-08-04
Posts: 4,824
Website

Re: Homebrew - MySQL

Btw, here is my current brew list output:

==> Formulae
ca-certificates	icu4c		lz4		openssl		readline	xz
cmake		libevent	mpdecimal	openssl@1.1	ruby		zstd
gdbm		libyaml		mysql		pkg-config	sqlite

It shows openssl and openssl@1.1, but not openssl@3 as brew outdated reflects:

mysql (5.7.13) < 8.0.27_1
openssl@3 (1.0.2h_1, 1.0.2k) < 3.0.1

Do I just run…

brew install openssl@3

…to bring that item current? And why the discrepancy with the labeling of the openssl forumulae between those two commands?

Update:

Was just looking at the available formulate, and they have only openssl@1.1 and openssl@3 listed as two separate options. So, answering my question here, I can probably install the latter and cleanup (remove) the former, theoretically.

And I was just going to ask about php, inevitably, as that is really outdated LIPP version in my system, and I’ve been meaning to use brew for that too. Brew has php (‘also known as: php@8.1’) and php@8.0. Which is the better option for Txp at this point?

Update 2:

Okay, I see, php8.1 is supported in upcoming release.

I’ll just cross that bridge when 4.8.8 is out.

Last edited by Destry (2022-01-14 15:56:05)

Offline

#4 2022-01-15 17:00:13

gaekwad
Server grease monkey
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,868
GitHub

Re: Homebrew - MySQL

Destry wrote #332424:

I did see that Homebrew works with Linux now, too, so that’s interesting. New to me, anyway. I like Homebrew because it makes it easy for me to install things that would probably be impossible otherwise. And I do want to make the jump to Linux eventually.

This is the relevant pull quote. Run a Linux virtual machine and do your stuff that way. You’re gonna have a rough time keeping up with modern tooling if you’re on old macOS (and I say that from Mojave, so I feel your pain). Spin up a VM and learn by doing.

Online

#5 2022-01-16 01:06:50

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,653
Website

Re: Homebrew - MySQL

  • openssl ? I suspect that you are safer with openssl@1.1 as that is what most webservers seem to use (and what is installed if you follow the getgrav tutorial, here)
  • MySQL 8 should work; I use the package downloaded from the mysql.com website. The most recent version ‘officially’ supports macOS 10.15+, but I suspect older OS will work just fine. Else, archived versions here, at least v8.0.20 is listed as supporting macOS 10.13. I have version MySQL 8.0.7, I think; runs just fine on macOS 12. I may need to think about upgrading though.

I agree with Pete that, given the toolchain dependency issues on your old OS, you may want to investigate a VM path. It is not so much an issue of running the packages as it is installing those packages.


Where is that emoji for a solar powered submarine when you need it ?

Offline

Board footer

Powered by FluxBB