Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2019-12-13 08:35:48

Myusername
Member
Registered: 2019-12-12
Posts: 141

Textpattern with problems in PHP version 7.4

While upgrading the PHP version of my hosting, I got an error message ‘Deprecated: Function get_magic_quotes_gpc () is deprecated in “/lib/constants.php”’

I just had to go back to the old version and everything went back to work. I don’t know if the error is common knowledge. Anyway, I just wanted to leave the warning that TextPattern seems to be having problems with PHP 7.4. Keep using version 7.3 for now.

Last edited by Myusername (2019-12-13 08:38:56)

Offline

#2 2019-12-13 09:22:12

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,568
Website GitHub

Re: Textpattern with problems in PHP version 7.4

Thank you for the report. PHP 7.4 was only released a few weeks ago and we’re not that fast at releases :) But we have patched it for the next Textpattern release, due out very soon.

If you want to test out the latest development build in a sandbox, try the demo server. Pete keeps the dev installation up-to-date with the latest bleeding edge PHP versions, as demonstrated in the demo site thread so we can keep an eye on what’s coming down the pipe and patch it. He’s a marvellous chap.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#3 2019-12-13 09:51:31

Myusername
Member
Registered: 2019-12-12
Posts: 141

Re: Textpattern with problems in PHP version 7.4

Bloke wrote #320504:

If you want to test out the latest development build in a sandbox, try the demo server. Pete keeps the dev installation up-to-date with the latest bleeding edge PHP versions, as demonstrated in the demo site thread so we can keep an eye on what’s coming down the pipe and patch it. He’s a marvellous chap.

Okay, thanks for the answer.

Last edited by Myusername (2019-12-13 09:53:02)

Offline

#4 2019-12-16 19:35:59

gaekwad
Server grease monkey
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,691
GitHub

Re: Textpattern with problems in PHP version 7.4

Bloke wrote #320504:

Pete keeps the dev installation up-to-date with the latest bleeding edge PHP versions, as demonstrated in the demo site thread so we can keep an eye on what’s coming down the pipe and patch it.

7.4.1 is at RC1 stage, I would not be surprised if it dropped tomorrow (Tuesday) around Christmas Eve. I tend to avoid RC releases, though that’s a trivial policy decision based on…well, nothing of note.

Since we’re at point releases for 7.4 now, I’ll leave it at non-RC releases for now, and start on RC & beta releases for 7.5 or 8.0 (whichever route they take).

Last edited by gaekwad (2019-12-16 19:47:37)

Offline

#5 2019-12-17 16:53:00

gaekwad
Server grease monkey
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,691
GitHub

Re: Textpattern with problems in PHP version 7.4

gaekwad wrote #320574:

7.4.1 is at RC1 stage, I would not be surprised if it dropped tomorrow (Tuesday) around Christmas Eve.

I was correct, 7.4.1 just appeared. Clearly Christmas Eve not the best time for a release…

Demo site updating now.

Offline

#6 2021-10-26 16:49:19

raminrahimi
Member
From: India
Registered: 2013-03-19
Posts: 245

Re: Textpattern with problems in PHP version 7.4

I’ve developed the websites in TXP v4.6.2 for my clients, now this message comes to all my clients websites, as they upgraded to PHP latest version.
Is there any solution for this like removing that function or changing that to any other function ?
I think upgrading all websites will be little hard for me :-(

Offline

#7 2021-10-26 20:44:06

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,568
Website GitHub

Re: Textpattern with problems in PHP version 7.4

4.6.2 is not compatible with PHP 7+ as far as I recall.

That said, you can probably alter line 149 of lib/constants.php to read:

define('MAGIC_QUOTES_GPC', false);

You might find a heap of other things that don’t work. YMMV.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#8 2021-10-27 10:17:24

gaekwad
Server grease monkey
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,691
GitHub

Re: Textpattern with problems in PHP version 7.4

This is an interesting situation. My first suggestion would be to see if the host has an older PHP version available as an interim fix until you (or someone) can update Textpattern to a newer version.

The nature of PHP development is that new minor and/or major versions arrive each year, and patch releases arrive every 4 weeks. Any Textpattern patching to make v4.6.2 work with this PHP version will have to be re-done as new versions of PHP roll through.

The only safe solution long term is to factor in upgrades of Textpattern for your clients.

This is the PHP vendor support table: www.php.net/supported-versions.php

Right now, PHP 7.4 is entering the final stages of ‘full’ support, and will switch over to ‘security’ support for a year, then it will be end-of-life’d in late 2022. PHP 8.1 arrives in November 2021. PHP 8.2 will likely arrive in November 2022.

Textpattern is updated to handle new PHP releases, and the dev team actively follow changes made in the pre-release candidates so when the full release arrives we’re ready.

Textpattern v4.8.8 will have support for PHP 8.1.0…and PHP 8.0…and PHP 7.4…and PHP 7.3…PHP 7.2…and PHP 7.1…and PHP 7.0…and PHP 5.6…and PHP 5.5. Textpattern drops support for older versions eventually: Textpattern v4.9 will need at least PHP 5.6, for example.

Textpattern v4.6.2 has bugs, and they’re public. The bugs we know about are fixed in newer releases. Textpattern v4.6.2 is 5 years old, it won’t run reliably with PHP 7.4. Support for PHP 7.4 was officially available in Textpattern v4.8.0, which arrived in February 2020.

Offline

Board footer

Powered by FluxBB