Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2021-08-08 08:15:17

firehit
New Member
Registered: 2021-08-08
Posts: 4

Site does not load, says "config.php is missing or corrupt"

This is my first time trying out Text Pattern.

Decided to do it locally.

Running Caddy server as a user not `root`. All the Text Patter files located in `~/srv/blog` are also owned by the user. The usual `phpinfo( );` page is loading fine.

What I did:

Downloaded the current Textpattern CMS release (4.8.7).

Caddy server config is

:55555
root * /home/moss/srv/blog/
php_fastcgi unix//run/php-fpm/php-fpm.sock

Outcome:

When I visit `http://localhost:55555/` the following error message is show on the webpage:

config.php is missing or corrupt. To install Textpattern, visit textpattern/setup/.

What seems to be the problem?

Edit by gaekwad: code tidying.

Last edited by gaekwad (2021-08-08 11:42:25)

Offline

#2 2021-08-08 08:29:18

jakob
Admin
From: Germany
Registered: 2005-01-20
Posts: 4,172
Website

Re: Site does not load, says "config.php is missing or corrupt"

Hi and welcome to the forum!

firehit wrote #331229:

When I visit `http://localhost:55555/` the following error message is show on the webpage: config.php is missing or corrupt. To install Textpattern, visit textpattern/setup/. What seems to be the problem?

Nothing’s wrong. Just follow the instructions :-)

Click on the link and it will take you to the setup routine where you can give your site a name, set up the database, user etc. It will provide with you what you need to put in config.php and tell you where to put it.

Here’s a link to Setup and configuration in the Textpattern docs.


TXP Builders – finely-crafted code, design and txp

Offline

#3 2021-08-08 09:39:30

firehit
New Member
Registered: 2021-08-08
Posts: 4

Re: Site does not load, says "config.php is missing or corrupt"

jakob wrote #331232:

Hi and welcome to the forum!

Nothing’s wrong. Just follow the instructions :-)

Click on the link and it will take you to the setup routine where you can give your site a name, set up the database, user etc. It will provide with you what you need to put in config.php and tell you where to put it.

Here’s a link to Setup and configuration in the Textpattern docs.

Thank you that worked!

But I now have another problem.

Looks like the CSS for the admin panels is not loading! It is just a wall of text with no layout etc…

Edit: Looks like this is a server issue. Server is only bothering with php files. Adding `file_server` did the trick.

Updated caddy config works:

```
:55555 {
root * /home/moss/srv/blog/
php_fastcgi unix//run/php-fpm/php-fpm.sock
file_server
}
```

RESOLVED.

Last edited by firehit (2021-08-08 10:26:11)

Offline

Board footer

Powered by FluxBB