Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#85 2020-09-10 16:54:37

GugUser
Member
From: Quito (Ecuador)
Registered: 2007-12-16
Posts: 1,454

Re: glz_custom_fields v2 beta for Textpattern v4.7

In various installations it works without problems so far.

Offline

#86 2020-09-10 23:32:12

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,347
Website

Re: glz_custom_fields v2 beta for Textpattern v4.7

jayrope wrote #325870:

Just for clarity: Does the the beta 2.0 from github work with 4.8.2 or should one be careful? I read through the thread here, but can’t see a clear “yes! it works!”

ditto what GugUser says – the latest from GH you linked to works OK from here.

(as always have a backup of the DB at hand before any upgrading etc etc and so on)


Where is that emoji for a solar powered submarine when you need it ?

Offline

#87 2020-09-19 15:18:12

peterj
Member
From: Melbourne, Australia
Registered: 2005-06-02
Posts: 63

Re: glz_custom_fields v2 beta for Textpattern v4.7

Hi, I’m just playing with the multi-select, as I build up the courage to make a custom script based field. My multi-select field is throwing an alert on the write tab (see below), though values save.
Running 2.0 Beta on TXP 4.8.2 on PHP 7.4. In debug mode.

8192 "implode(): Passing glue string after array is deprecated. Swap the parameters"
in /home/xoxoxo/2020dev/textpattern/plugins/glz_custom_fields/glz_custom_fields.php at line 1808.
adminErrorHandler()
textpattern/plugins/glz_custom_fields/glz_custom_fields.php:1808 implode()
textpattern/lib/txplib_misc.php:1506 glz_custom_fields_before_save()
textpattern/index.php:224 callback_event()

I found the code in glz_custom_fields_before_save():

$value = implode($value, '|');

Changed this around to

$value = implode('|', $value);

Now it’s happy. Old way deprecated in 7.4.

Last edited by peterj (2020-09-19 15:18:48)

Offline

#88 2020-10-15 03:46:59

wavesource
Member
From: Australia
Registered: 2011-08-02
Posts: 56

Re: glz_custom_fields v2 beta for Textpattern v4.7

peterj wrote #325968:

I found the code in glz_custom_fields_before_save():
$value = implode($value, '|');...
Changed this around to
$value = implode('|', $value);...
Now it’s happy.

This bug is confirmed in TXP 4.8.3. Fix works.

Last edited by wavesource (2020-10-15 03:49:10)

Offline

#89 2021-03-24 04:48:43

peterj
Member
From: Melbourne, Australia
Registered: 2005-06-02
Posts: 63

Re: glz_custom_fields v2 beta for Textpattern v4.7

Same problems with checkboxes.
TXP 4.8.4 on PHP 7.4.

Offline

#90 2021-03-24 09:05:55

jakob
Admin
From: Germany
Registered: 2005-01-20
Posts: 4,129
Website

Re: glz_custom_fields v2 beta for Textpattern v4.7

peterj wrote #329414:

Same problems with checkboxes.
TXP 4.8.4 on PHP 7.4.

Thanks for prodding me. I’ve updated that online and done a minor re-issue with that change included.


TXP Builders – finely-crafted code, design and txp

Offline

Board footer

Powered by FluxBB