Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2020-12-19 10:09:16

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,451
Website

valitation links and https

In the bottom right of the NeMe pages, I have included links to various validation services. Since I have moved the site to https, links such as https://validator.w3.org/check?uri=referer no longer work, perhaps understandably.

Hand crafting them may be a problem as the html validator for example converts the slashes and the column to their entities, https://validator.w3.org/nu/?doc=https%3A%2F%2Fwww.neme.org%2Fprojects%2Freprogramming-earth.

Can anyone recommend another method to include the validation links?


Yiannis
——————————
neme.org | hblack.net | State Machines | NeMe @ github
I do my best editing after I click on the submit button.

Offline

#2 2020-12-19 11:09:13

gaekwad
Admin
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,344

Re: valitation links and https

http -> https is not the cause, there’s nothing inherently different about a referrer being passed between http or https. I just tested this on the demo site with:

"$":https://validator.w3.org/check?uri=referer

…and it works just fine. I realise this doesn’t answer your question, however.

It’s common for URLs like the one you listed to percent-encode the incoming URL (NeMe) as a parameter to the active URL (W3), so as not to trip things up.

My old and possibly outdated way to achieve this was the figure out the page URL and then use rah_replace to manually encode the colons & slashes. Knowing how things have come along in TextpatternWorld over the past decade I am sure there are other ways to achieve this, even in core. How? No idea. Sorry.

Offline

#3 2020-12-19 11:17:37

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,451
Website

Re: valitation links and https

Hmmm, I’m revisiting my htaccess, maybe there is something there!


Yiannis
——————————
neme.org | hblack.net | State Machines | NeMe @ github
I do my best editing after I click on the submit button.

Offline

#4 2020-12-19 12:22:12

etc
Developer
Registered: 2010-11-11
Posts: 4,052
Website

Re: valitation links and https

gaekwad wrote #327664:

My old and possibly outdated way to achieve this was the figure out the page URL and then use rah_replace to manually encode the colons & slashes. Knowing how things have come along in TextpatternWorld over the past decade I am sure there are other ways to achieve this, even in core. How? No idea. Sorry.

escape="url"?

Online

#5 2020-12-19 12:27:08

gaekwad
Admin
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,344

Re: valitation links and https

etc wrote #327674:

escape="url"?

escape="url"!

Edit: I have no valid defence, beyond not making much with Textpattern recently. I still love you, Textpattern, it’s just been hard recently. We’ll make it work, I believe in us.

Last edited by gaekwad (2020-12-20 10:02:00)

Offline

#6 2020-12-19 14:27:38

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,451
Website

Re: valitation links and https

etc wrote #327674:

escape="url"?

I’ll try it but I think that the problem is elsewhere. Even when I hardcode the link, the validator returns “No Referer header found!”


Yiannis
——————————
neme.org | hblack.net | State Machines | NeMe @ github
I do my best editing after I click on the submit button.

Offline

#7 2020-12-19 15:43:46

etc
Developer
Registered: 2010-11-11
Posts: 4,052
Website

Re: valitation links and https

I’m lost: I see no validator links on your pages to test. Sending referer header is a browsers job. It is not sent when you paste URLs directly into URL bar. Some extensions can block it too.

Online

#8 2020-12-19 15:57:32

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,451
Website

Re: valitation links and https

etc wrote #327682:

I’m lost: I see no validator links on your pages to test. Sending referer header is a browsers job. It is not sent when you paste URLs directly into URL bar.

Hi Oleg,
Indeed, I did wrap them temporarily with the if_logged_in tag until I solve the issue.

Some extensions can block it too.

I did check them on different browsers to make sure it is not my very customised ff install and the result was the same. My first second instinct was to comment out my mod_headers directives in the htaccess but the result was the same.


Yiannis
——————————
neme.org | hblack.net | State Machines | NeMe @ github
I do my best editing after I click on the submit button.

Offline

Board footer

Powered by FluxBB