Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2020-11-22 08:32:27

saccade
Plugin Author
From: Neubeuern, Germany
Registered: 2004-11-05
Posts: 510

Override form missing in plain Write Tab - but not in article edit

Good morning,
I’ve ran into a weird effect in a 4.8.2>4.8.3 brand new install:
Override Forms is on by default in my install.
I think I even used it when writing an article from scratch.

But now suddenly this is different:

When opening the Write-Tab, there is no override forms.

If I write and save and close,
and the re-open (as for all other articles I open for editing) the override form field is present and working.

I already disabled each and every plugin, but even without any plugin override form is not available in the plain Write tab.

I already checked another fresh install: Different. override form present even in a plain not yet filled or saved Write tab.

Last edited by saccade (2020-11-22 09:39:10)

Offline

#2 2020-11-22 09:59:41

saccade
Plugin Author
From: Neubeuern, Germany
Registered: 2004-11-05
Posts: 510

Re: Override form missing in plain Write Tab - but not in article edit

OK, urgently needing a solution I at least found out whats the reason (or the beginning):

I renamed the “articles” Section (to German “artikel” because I want an understandable URL).

But this causes the vanishing of the override_form-field.

If I rename it again to “articles” the field is there again!

I could of course make a second section “artikel”, but “articles” then will remain in my section-field, which is very uncomfortable for my clients.

Offline

#3 2020-11-22 10:29:15

etc
Developer
Registered: 2010-11-11
Posts: 3,989
Website

Re: Override form missing in plain Write Tab - but not in article edit

Hello,

have you checked the state of Allow form override? pref when renaming sections?

Weird issue…

Offline

#4 2020-11-22 10:45:38

etc
Developer
Registered: 2010-11-11
Posts: 3,989
Website

Re: Override form missing in plain Write Tab - but not in article edit

It looks like the value of Default publishing section pref is not updated on section rename. Try updating it manually when renaming the corresponding section. Thank you for the report.

Edit: Neither is it updated when the default section is deleted.

Offline

#5 2020-11-22 11:10:35

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 9,832
Website

Re: Override form missing in plain Write Tab - but not in article edit

etc wrote #326973:

Neither is it updated when the default section is deleted.

*gulp* It’s possible to delete the default section? I thought a default section had to exist so the front page worked. Worrying…

Thanks for the report, Michael.

Last edited by Bloke (2020-11-22 11:11:22)


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Online

#6 2020-11-22 11:14:51

etc
Developer
Registered: 2010-11-11
Posts: 3,989
Website

Re: Override form missing in plain Write Tab - but not in article edit

Bloke wrote #326974:

gulp It’s possible to delete the default section?

I meant the default publishing section, sorry.

Offline

#7 2020-11-22 11:28:35

saccade
Plugin Author
From: Neubeuern, Germany
Registered: 2004-11-05
Posts: 510

Re: Override form missing in plain Write Tab - but not in article edit

No, I didn’t delete the default section (and I couldn’t have done so I think). I didn’t delete anything but (as I did for 12 years now1 ;) ) renamed the “articles” section to “artikel”, which never was a problem.

Allow_form_override has not been touched, which is correct in my view.
as I looked into the core code and experimented a little bit I also noticed, tha “allow_form_override” has not any influence on the behaviour (in fact I even short circuited this as a test). the function form_pop didn’t do anything (but I didn’t find where the use of “articles” comes into effect).

So I think etc is right: its the “default publishing section” which on rename isn’t changed. I’ll check that.
EDIT which is “default_section” in the prefs. and true it still has the value “articles”.
Wonder what happens, if I switch it to another third one (which on a fresh install I had not generated yet) and switch it then again to “artikel”

1 I have to concede that I didn’t use “override-form” systematically. Maybe it has disappeared all the time before, and I only used it in article-edit view. So I didn’t miss it until now. But now I have an install, where I have three choices of display, and want that to be present from the beginning.

Last edited by saccade (2020-11-22 11:45:24)

Offline

#8 2020-11-22 11:39:23

saccade
Plugin Author
From: Neubeuern, Germany
Registered: 2004-11-05
Posts: 510

Re: Override form missing in plain Write Tab - but not in article edit

Result: Works like a charm :)
By switching the default_(publish)section to another one the default_section-entry is updated. By switching it to the renamed articles/artikel the new value is correctly “artikel”.
And the form-override is there again!

This also is the workaround until it is fixed.

Offline

#9 2020-11-22 12:12:42

etc
Developer
Registered: 2010-11-11
Posts: 3,989
Website

Re: Override form missing in plain Write Tab - but not in article edit

It’s mostly fixed in 4.8.4, up to display refresh on sections delete.

Offline

#10 2020-11-22 13:00:04

saccade
Plugin Author
From: Neubeuern, Germany
Registered: 2004-11-05
Posts: 510

Re: Override form missing in plain Write Tab - but not in article edit

Fine! Thank you!
best wishes and hopefully a sunny relaxing sunday for all of you!

Offline

Board footer

Powered by FluxBB