Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2020-09-24 06:00:06

jodeci
Member
From: Taipei
Registered: 2008-01-13
Posts: 38
Website

503 errors everywhere after clearing cookies

My neglected site was recently upgraded from 4.5.5 to 4.8.2. At first, things looked not broken enough so I put things aside…

Anyway, after I enabled SSL and cleared cookies, everything now leads to a 503 error. Well, everything except the default page, that is.
(disclaimer: it was 503ing BEFORE I enabled SSL, so not sure if it’s relevant)

- weirdly, the provider’s server error logs are empty. No help from here.
- txp is in testing mode, but it’s just redirected to the error_default page. Not getting clues from here either.

I can try to work with error logs but I’m lost here without a trail to follow. Any ideas?

Offline

#2 2020-09-24 07:59:29

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 9,776
Website

Re: 503 errors everywhere after clearing cookies

Interesting. The usual advice is to remove (or rename) the .htaccess files in your site root and /textpattern directories (and any others you may have enabled).

See what happens (you won’t be able to use clean URLs but messy mode should work). Then, switch them on one by one until the site starts to break. Then go into that .htaccess file and comment out (‘#’) or remove lumps of stuff until it starts working. Strip it back to just the one that ships with Textpattern until you find what’s causing it then focus there.

If it’s not that, try disabling all plugins and turn them back on one by one until you find one that might be breaking things.

Hope that helps.

Last edited by Bloke (2020-09-24 08:00:57)


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#3 2020-09-24 08:41:11

jodeci
Member
From: Taipei
Registered: 2008-01-13
Posts: 38
Website

Re: 503 errors everywhere after clearing cookies

Turning off plugins did the trick, thanks!

Offline

Board footer

Powered by FluxBB