Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#21 2018-11-16 11:31:54

etc
Developer
Registered: 2010-11-11
Posts: 3,940
Website

Re: SOLVED: 4.0.5 -> 4.7.1 update problem

Bloke wrote #315305:

Hmmm, maybe we shouldn’t have removed them. Perhaps the upgrade script from very old versions expects them to exist for reasons I can’t quite fathom right now. It’s no hardship to add those empty files back into Txp 4.7.2 if it helps upgradeability.

Since the files are gone (dunno why and when), I have removed their includes in 4.7.2 _update.php. That’s all I know…

Offline

#22 2018-11-16 11:38:15

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 9,792
Website

Re: SOLVED: 4.0.5 -> 4.7.1 update problem

etc wrote #315306:

Since the files are gone (dunno why and when), I have removed their includes in 4.7.2 _update.php.

Ahhh, that explains it. I see now that they’re referenced in 4.7.1’s _update.php but the files themselves were removed. Oopsie. In which case, having those DB entries removed from the _update.php array in 4.7.2 should fix things. Nice one. We should probably mention that in HISTORY.txt when we talk about improving the upgrade experience.

Last edited by Bloke (2018-11-16 11:39:33)


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#23 2020-07-16 11:38:45

funtoosh
Member
From: Münster, Germany
Registered: 2006-10-09
Posts: 149
Website

Re: SOLVED: 4.0.5 -> 4.7.1 update problem

funtoosh wrote #315301:

Worked for me as well!

FIX:
— Uploaded Textpattern 4.7.1 to server
— Made two empty files, _to_1.0.0.php and _to_4.0.2.php in update folder
and used _to_4.6.0.php from dev version 4.7.2 @ github
— Then ran /textpattern/update/update.php directly

Frontend and backend are back, languages are updated, yay!

Ups. I have the exact same problem after trying to update from 4.6.2 to 4.8.1 in preparation for a PHP update from 5.5 to 7.4 … Textpattern backend is available, frontend is gone with error “Unknown section”. In backend there’s a couple error notes, see below.

Oh and the above solution fails …

Any ideas??

User_Error "Unknown column 'prefs_id' in 'field list'"
in /data/www/medienforum/textpattern/lib/txplib_db.php at line 409.
textpattern/lib/txplib_misc.php:1676 adminErrorHandler()
updateErrorHandler()
textpattern/lib/txplib_db.php:409 trigger_error()
textpattern/lib/txplib_db.php:483 safe_query()
textpattern/update/_to_1.0.0.php:203 safe_insert()
textpattern/update/_update.php:90 include()
textpattern/index.php:180 include()

Offline

#24 2020-07-16 12:40:51

gaekwad
Admin
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,176

Re: SOLVED: 4.0.5 -> 4.7.1 update problem

funtoosh wrote #324577:

Any ideas??

User_Error "Unknown column 'prefs_id' in 'field list'"...

textpattern/lib/txplib_misc.php:1676 adminErrorHandler()...

forum.textpattern.com/viewtopic.php?pid=314124#p314124 might be helpful.

Offline

#25 2020-07-16 14:47:52

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,297
Website

Re: SOLVED: 4.0.5 -> 4.7.1 update problem

or

forum.textpattern.com/viewtopic.php?id=50844
forum.textpattern.com/viewtopic.php?pid=310901#p310901
forum.textpattern.com/viewtopic.php?id=47268
etc

Do check the forum for textpattern/lib/txplib_misc.php:1676 adminErrorHandler and you’ll get more results.


Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | NeMe @ github | Covid-19; a resource
I do my best editing after I click on the submit button.

Online

#26 2020-09-01 11:03:22

funtoosh
Member
From: Münster, Germany
Registered: 2006-10-09
Posts: 149
Website

Re: SOLVED: 4.0.5 -> 4.7.1 update problem

Hi there,
I’m back from holidays and back at work with my one Textpattern Install from Hell ,-)

To sum up: trying to update from 4.6.2 to 4.8.2, none of the tips above have helped, making a copy of the site now to be able to freely edit the database to hopefully find & eliminate any culprits.

Wish me luck!

Offline

#27 2020-09-01 22:10:30

jakob
Admin
From: Germany
Registered: 2005-01-20
Posts: 3,946
Website

Re: SOLVED: 4.0.5 -> 4.7.1 update problem

If you can look at the database, take a look at the txp_prefs table and see what value is given for the version entry. In rare cases that needs resetting to make it run through the update steps.

If you need some help getting it working again, you’re welcome to send me an email.

Otherwise: good luck!! :-)


TXP Builders – finely-crafted code, design and txp

Offline

#28 2020-09-02 12:32:57

funtoosh
Member
From: Münster, Germany
Registered: 2006-10-09
Posts: 149
Website

Re: SOLVED: 4.0.5 -> 4.7.1 update problem

Jakob, besten Dank! The version is exactly what I’ll be focussing on, as I had trouble with the entry in a previous update.

Offline

#29 2020-09-02 13:09:21

funtoosh
Member
From: Münster, Germany
Registered: 2006-10-09
Posts: 149
Website

Re: SOLVED: 4.0.5 -> 4.7.1 update problem

Okay … this is what happened in the copy:

I deactivated plugins and logged off, then I copied the 4.8.2 files over.

When logging back in, the frontend was gone, with an unkonown section error.
I logged in and found the following errors:

The last ones were easily fixed by deleting the dir and changing permissions. The first ones disappeared after I looked into SQL and found that in txp_prefs the version was actually still at 4.6.2

I changed that to 4.8.2 and all errors disappeared. I then looked at the language tab and deleted de-de which has been replaced by de.

But … still, no frontend.

When I went to sections, it looked like this v v v below. There were no themes, and all pages were empty … no forms, too. No frontend code at all.

So, the good thing is, I can probably get back to a working site by copying all templates over manually, into a new theme. But why weren’t the old templates recognized?

Offline

#30 2020-09-03 11:58:54

funtoosh
Member
From: Münster, Germany
Registered: 2006-10-09
Posts: 149
Website

Re: SOLVED: 4.0.5 -> 4.7.1 update problem

Okay, I can’t create a theme … “Themes creation failed”. Any ideas? Could I manually add the table for a theme to help me get going?

Offline

Board footer

Powered by FluxBB