Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#251 2020-08-09 06:51:59

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,296
Website

Re: com_connect - form and contact mailer

After hitting two separate errors on two plugins which use the deprecated EvalElse function I decided to check my other active plugins and found that the function is also used on com_connect return parse(EvalElse($thing, $cond));. Should this be updated to return parse($thing, $cond);?


Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | NeMe @ github | Covid-19; a resource
I do my best editing after I click on the submit button.

Offline

#252 2020-08-09 09:09:16

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 9,789
Website

Re: com_connect - form and contact mailer


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#253 2020-08-09 09:43:49

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,145
Website

Re: com_connect - form and contact mailer

Bloke wrote #325259:

Patched.

How backwards compatible is this, for people still using TXP4.7 ?


Where is that emoji for a solar powered submarine when you need it ?

Offline

#254 2020-08-09 11:49:20

etc
Developer
Registered: 2010-11-11
Posts: 3,940
Website

Re: com_connect - form and contact mailer

phiw13 wrote #325260:

How backwards compatible is this, for people still using TXP4.7 ?

Yes, it should work in 4.6+.

Offline

#255 2020-08-09 11:59:38

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 9,789
Website

Re: com_connect - form and contact mailer

It is 4.7+ only. The lang strings are designed for the 4.7 shorter langs identifiers.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#256 2020-08-09 12:05:17

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,145
Website

Re: com_connect - form and contact mailer

etc wrote #325267:

Yes, it should work in 4.6+.

Bloke wrote #325268:

It is 4.7+ only. The lang strings are designed for the 4.7 shorter langs identifiers.

selfishly, 4.7+ is OK !
Thank you both.

(we really should start looking at upgrading that site to 4.8.x)


Where is that emoji for a solar powered submarine when you need it ?

Offline

Board footer

Powered by FluxBB