Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#101 2019-01-09 11:13:33

Gallex
Member
Registered: 2006-10-08
Posts: 1,160

Re: adi_notes - leave notes for Textpattern users

uploaded /Netcarver/Textile folder again. nothing changed for now.
noticed that text under diagnostic tab:

There was a problem connecting to the Textpattern update server. Please try again later.

could this somehow been related with my error?

Offline

#102 2019-01-09 11:33:33

jakob
Admin
From: Germany
Registered: 2005-01-20
Posts: 3,937
Website

Re: adi_notes - leave notes for Textpattern users

General error 16384: Parser::textileThis() is deprecated. Use Parser::parse() instead.

the latest textile not coming with txp 4.7.2?

For the moment this is just a notice. The way textile is called changed from 4.6 onwards and the old method is caught and directed to the proper method but you get this notice in debugging mode … i.e. to let plugin authors know to update their plugins.

This will happen with many plugins that textile output. For example it came up recently with smd_featured. This was my proposed fix for that plugin. I don’t know if that’s the best solution but Stef kindly accepted it.


TXP Builders – finely-crafted code, design and txp

Offline

#103 2019-01-09 11:34:29

jakob
Admin
From: Germany
Registered: 2005-01-20
Posts: 3,937
Website

Re: adi_notes - leave notes for Textpattern users

There was a problem connecting to the Textpattern update server.

That’s unrelated but has come up before: please search the forum. Often it was a problem with older versions or updating…


TXP Builders – finely-crafted code, design and txp

Offline

#104 2019-01-09 12:11:48

Gallex
Member
Registered: 2006-10-08
Posts: 1,160

Re: adi_notes - leave notes for Textpattern users

For the moment this is just a notice. The way textile is called changed from 4.6 onwards and the old method is caught and directed to the proper method but you get this notice in debugging mode … i.e. to let plugin authors know to update their plugins.

correct. disappeared in live mode.

OT: clicking “quote” under your post doesn’t quote anymore, any ideas why? noticed this behavior already little while ago…

Offline

#105 2019-01-09 12:18:14

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 9,724
Website

Re: adi_notes - leave notes for Textpattern users

Quoting is a known issue as of a few days ago.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#106 2019-01-10 11:23:47

gomedia
Plugin Author
Registered: 2008-06-01
Posts: 1,262
Website

Re: adi_notes - leave notes for Textpattern users

Hi Gallex,

Try this one – I’ve updated how it calls Textile in TXP 4.7.

jakob – thanks for the code.

Offline

#107 2020-03-08 15:05:35

RedFox
Member
From: Netherlands
Registered: 2005-03-25
Posts: 773
Website

Re: adi_notes - leave notes for Textpattern users

gomedia wrote #316041:

Try this one – I’ve updated how it calls Textile in TXP 4.7.

Install locally (Txp 4.8.0, MAMP 5.4, PHP 7.3.7) gives error: “Not installed”. Install on external servers: everything fine … :)

!?

Last edited by RedFox (2020-03-08 15:06:34)

Offline

#108 2020-03-08 21:06:23

gomedia
Plugin Author
Registered: 2008-06-01
Posts: 1,262
Website

Re: adi_notes - leave notes for Textpattern users

I’ve just been able to install it successfully on 4.8.0 – both as a cached plugin and a conventionally installed plugin – locally on my Mac. Admittedly I’m still on PHP 5.6.

Is this a new set up? What do you see when you visit the plugin’s options tab? Any juicy error messages?

Offline

#109 2020-03-09 15:07:11

RedFox
Member
From: Netherlands
Registered: 2005-03-25
Posts: 773
Website

Re: adi_notes - leave notes for Textpattern users

Activating adi_notes (v1.4beta4) gives >

Options >

Offline

#110 2020-03-09 21:51:59

gomedia
Plugin Author
Registered: 2008-06-01
Posts: 1,262
Website

Re: adi_notes - leave notes for Textpattern users

Looks like some code crappage has been exposed. Caused by a used-to-be-ok-but-now-possibly-dodgy default value for a DATETIME column.

I’ve had a fiddle, so please try adi_notes-1.4beta5

Offline

Board footer

Powered by FluxBB