Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#25 2019-11-01 08:55:05

etc
Developer
Registered: 2010-11-11
Posts: 4,548
Website GitHub

Re: Dev news

Hi Philippe, thanks for testing. Syncing via git does not trigger db update. Try to logout/in or add manually varchar 63 permlink_mode column to txp_sections table.

Offline

#26 2019-11-01 12:13:14

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,513
Website

Re: Dev news

etc wrote #319885:

Hi Philippe, thanks for testing. Syncing via git does not trigger db update. Try to logout/in or add manually varchar 63 permlink_mode column to txp_sections table.

I suspected something like that might be the case. A logout/login didn’t fix or help in any way. I’ll have to try manually adding the column to the table.

(care to remind me of an easy way to do add the column? My MySQL-fu is poorer than ever… Thank you. No hurry I don’t think I’ll have time over the next couple of days.)

The whole thing seemed to work well in a quick test on Pete’s demo site. But that was without the chaos I am used to from more real world content. That is why I like to test with my old test site, full of “articles” and snippets and weirdness.


Where is that emoji for a solar powered submarine when you need it ?

Offline

#27 2019-11-02 12:51:44

etc
Developer
Registered: 2010-11-11
Posts: 4,548
Website GitHub

Re: Dev news

phiw13 wrote #319887:

(care to remind me of an easy way to do add the column? My MySQL-fu is poorer than ever… Thank you. No hurry I don’t think I’ll have time over the next couple of days.)

Probably the easiest way is to include this snippet in some article and visit it:

<txp:php>
define('TXP_UPDATE', true);
include_once(txpath.'/update/_to_4.8.0.php');
</txp:php>

Offline

#28 2019-11-05 02:55:55

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,513
Website

Re: Dev news

etc wrote #319902:

Probably the easiest way is to include this snippet in some article and visit it:

<txp:php>...

Thank you for that. It worked like a charm.

Overall, those additional URL schemes seem to work fine with my chaotic test site. Lovely. One weakness though, which I think you mentioned somewhere above. The view link on the edit panel uses the default URL scheme. But everywhere from the front-end (index page, category pages etc) the correct URL is used.


Where is that emoji for a solar powered submarine when you need it ?

Offline

#29 2019-11-05 05:56:13

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,513
Website

Re: Dev news

Some nitpicking (maybe?) on the updated section panel. The sections that use the default URL pattern list the type of pattern (e.g section_title) but on the dit panel, it is listed as “Default”, that confused me for a moment.

And also, on the listing panels, those entries are displayed using the .disabled class. that is a bit weird… we have the .footnote and the .txp-form-field-instructions class, but that last one is semantically tied to forms (preferences panels, edit panels) and does actually more that just handle the text string. I guess we might need a more generic class for secondary text… But I‘ll leave that Mr Wareham.


Where is that emoji for a solar powered submarine when you need it ?

Offline

#30 2019-11-05 18:46:25

etc
Developer
Registered: 2010-11-11
Posts: 4,548
Website GitHub

Re: Dev news

phiw13 wrote #319928:

The view link on the edit panel uses the default URL scheme. But everywhere from the front-end (index page, category pages etc) the correct URL is used.

Thanks, will look for a fix.

phiw13 wrote #319930:

The sections that use the default URL pattern list the type of pattern (e.g section_title) but on the dit panel, it is listed as “Default”, that confused me for a moment.

And also, on the listing panels, those entries are displayed using the .disabled class. … I guess we might need a more generic class for secondary text… But I‘ll leave that Mr Wareham.

The technical reason behind it is that default permlink value is empty, which means “use the global permlink_mode pref”. Hence, when sorting sections list by permlink mode column, these sections come first/last. So I needed some visually “blank” but still informative text and have not found anything better than disabled class. +1 for leaving it with Phil :-)

Offline

#31 2019-11-05 19:42:31

gaekwad
Server grease monkey
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,691
GitHub

Re: Dev news

My waaaay-out-there request would be for HTTP 451 Unavailable For Legal Reasons headers on articles by way of a dropdown (i.e. Draft, Hidden, Pending, Live, Sticky, Busted) when the heat gets too much and the po-po coming a-knockin’. Ahem.

Offline

#32 2019-11-06 11:53:36

etc
Developer
Registered: 2010-11-11
Posts: 4,548
Website GitHub

Re: Dev news

You’ve asked (no dropdown though). Usage:

<txp:txp_die status="451" />

or

<txp:header name value="451 Unavailable For Legal Reasons" />

Offline

#33 2019-11-06 12:04:27

gaekwad
Server grease monkey
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,691
GitHub

Re: Dev news

I’m slightly disturbed by how little persuasion that took…

Thanks very much, etc!

Offline

#34 2019-11-06 20:17:44

singaz
Member
Registered: 2017-03-12
Posts: 150

Re: Dev news

What is <txp:txp_die />?

In the “ Tag reference index “ missing.


Sorry my horror English. I’m learning textpattern, I’m learning English

Offline

#35 2019-11-06 20:26:14

gaekwad
Server grease monkey
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,691
GitHub

Re: Dev news

singaz wrote #319970:

What is <txp:txp_die />?

docs.textpattern.com/tags/txp_die

Offline

#36 2019-11-06 23:42:32

michaelkpate
Moderator
From: Avon Park, FL
Registered: 2004-02-24
Posts: 1,372
Website GitHub Mastodon

Re: Dev news

etc wrote #319876:

Dunno why you wanted it, but per section permlink modes are there. Please test it thoroughly, that was not a few-liner.

I have 4.8.0-dev installed on CMS Styles

In preferences, the site is set to Section/Title.

So I go to the Section, choose Article and try to set a custom url pattern.

And every time get taken back to the Section Screen with this error message.

Am I missing something obvious?

Offline

Board footer

Powered by FluxBB