Textpattern CMS support forum

You are not logged in. Register | Login | Help

#181 2019-07-17 11:51:57

hilaryaq
Plugin Author
Registered: 2006-08-20
Posts: 209
Website

Re: rah_sitemap

Just realised mine isn’t working.. I have <txp:header value=“application/xml; charset=utf-8” /> on the page template but it’s not executing as the error on view source is ‘attempt to use an xml processing instruction on xml’, so it looks like the header isn’t working, is there any other way to force the header?

I’m running 4.7.3 :/ thanks for any help!


…………………
I <3 txp
…………………

Offline

#182 2019-07-17 12:31:14

hilaryaq
Plugin Author
Registered: 2006-08-20
Posts: 209
Website

Re: rah_sitemap

Found the issue! You must have allow php in pages set to on, then the header tag above will work properly!


…………………
I <3 txp
…………………

Offline

#183 2019-09-17 12:33:04

peterj
Member
From: Melbourne, Australia
Registered: 2005-06-02
Posts: 37

Re: rah_sitemap

hilaryaq wrote #318705:

Thanks Yiannis who pointed me in the right direction! The best tip.

Thanks Hillary, Yiannis. Making some headway now sans plugin. The new native tags are great.

Offline

#184 2019-09-17 15:56:25

etc
Developer
Registered: 2010-11-11
Posts: 3,399
Website

Re: rah_sitemap

hilaryaq wrote #318784:

You must have allow php in pages set to on, then the header tag above will work properly!

Yep, that’s an overzealous security feature. But you should be able to use custom xml-typed forms to the same effect if php is not desirable.

Offline

Board footer

Powered by FluxBB