Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#25 2017-12-07 01:02:36

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,286
Website GitHub

Re: com_connect - form and contact mailer

Gallex: Sorry for the delay. Try v1.0.1 and see if it fixes the file upload issue. It works for me with smallish limits, haven’t tried anything massive yet.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#26 2017-12-09 08:45:47

Gallex
Member
Registered: 2006-10-08
Posts: 1,202

Re: com_connect - form and contact mailer

Bloke wrote #308142:

Gallex: Sorry for the delay. Try v1.0.1 and see if it fixes the file upload issue. It works for me with smallish limits, haven’t tried anything massive yet.

now it uploads and sends the message, but the email i receive, is without the attachment

Offline

#27 2017-12-09 09:21:36

Gallex
Member
Registered: 2006-10-08
Posts: 1,202

Re: com_connect - form and contact mailer

at the top of a email i receive is: “This may be a spoofed message. Gmail couldn’t verify that it was actually sent from your account. Learn more”

could this be related somehow to the issue?

actually i get this warning from gmail almost in every new site i send a testmail with (CC or ZCR) contact mailer.

Last edited by Gallex (2017-12-10 07:51:02)

Offline

#28 2017-12-09 16:16:29

gaekwad
Multi-hyphenate
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,531
GitHub

Re: com_connect - form and contact mailer

Gallex wrote #308202:

“This may be a spoofed message. Gmail couldn’t verify that it was actually sent from your account. Learn more”

This is probably a problem outside Textpattern. This error appears when Gmail (or any email provider) checks if the email received came from a location that the domain owner approves of.

There are two things to investigate, and update on your domain(s): DKIM and SPF (both links safe for work) These two systems help email servers decide if email is good or bad.

Also, you could confirm in Gmail that the email is not spam, and then Gmail will learn to allow it.

Offline

#29 2017-12-10 00:00:21

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,357
Website

Re: com_connect - form and contact mailer

gaekwad wrote #308204:

This is probably a problem outside Textpattern. This error appears when Gmail (or any email provider) checks if the email received came from a location that the domain owner approves of.

There are two things to investigate, and update on your domain(s): DKIM and SPF (both links safe for work) These two systems help email servers decide if email is good or bad.

Also, you could confirm in Gmail that the email is not spam, and then Gmail will learn to allow it.

Yes, that could a part of the problem, see also this and following post.


Where is that emoji for a solar powered submarine when you need it ?

Offline

#30 2017-12-10 08:34:21

Gallex
Member
Registered: 2006-10-08
Posts: 1,202

Re: com_connect - form and contact mailer

gaekwad wrote #308204:

There are two things to investigate, and update on your domain(s): DKIM and SPF (both links safe for work) These two systems help email servers decide if email is good or bad.

how does it go? how i can update my domains with DKIM and SPF? totally unknown topic for me :(

Also, you could confirm in Gmail that the email is not spam, and then Gmail will learn to allow it.

i know what to do if gmail sends the email into spam folder, but this email is not a spam, it is “spoofed message”. i cant find instructiońs for that situation https://support.google.com/mail/

Offline

#31 2017-12-10 08:46:11

Gallex
Member
Registered: 2006-10-08
Posts: 1,202

Re: com_connect - form and contact mailer

phiw13 wrote #308205:

see also this and following post.

my form:

<txp:com_connect to="ma...@gmail.com" label="Send a message" subject="Message from website" thanks="Thank you!" lang="en-gb">
<txp:com_connect_text label="Name:" break="" />
<txp:com_connect_email name="email" type="email" label="Email:" break="" />
<txp:com_connect_text type="tel" label="Phone:" break="" />
<txp:com_connect_textarea rows="5" cols="25" label="Message:" break="" />
<txp:com_connect_submit label="Send" />
</txp:com_connect>

what else i could do?

Offline

#32 2017-12-10 09:22:57

Gallex
Member
Registered: 2006-10-08
Posts: 1,202

Re: com_connect - form and contact mailer

in the last few months, i have received many compilations from my clients using ZCR contact mailer (request forms, booking forms, order forms… different kind of forms) – they don’t receive their clients emails. :(

yesterday i created new TXP account to the client. but she didn’t receive activation email. tryed three times. changed its hotmail email address to gmail address – then she finally received.

those email sending problems i have experienced already many years.

how about other CMS-s? do they also have similar “email sending” problems – does anyone know? could you confirm that this is not TXP specific issue?

Offline

#33 2017-12-10 10:10:32

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,357
Website

Re: com_connect - form and contact mailer

Gallex,

I usually include a from=xx[at]my-domain.tld where my-domain.tld is the domain/site that hosts the form and the email address is a real email address.

<txp:com_connect from="xx@my-domain.tld" to="ma...@gmail.com" …

The same email address is also specified on the Preferences > Admin panel (SMTP envelope sender address  and Send login details from this email address ).


Where is that emoji for a solar powered submarine when you need it ?

Offline

#34 2017-12-10 10:21:25

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,286
Website GitHub

Re: com_connect - form and contact mailer

Gallex wrote #308202:

This may be a spoofed message

If you were only getting this from com_connect I’d say it was the new headers I implemented. I stripped out some of the headers that caused issues with newer versions of PHP and replaced them with an enhanced body instead. But if it’s happening with ZCR too then try tinkering with your email sending prefs (see phiw13’s post) and also look into what gaekwad suggests.

Email providers are becoming more opinionated about what they perceive as spam (to the detriment of us all, to some degree) but taking some of the steps to sign/secure your email transport can go a long way towards helping servers route your messages correctly.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#35 2017-12-10 11:19:46

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,615
Website GitHub Twitter

Re: com_connect - form and contact mailer

Gallex

You could whitelist by subject in gmail

  1. Mouse over the Settings menu icon and select Settings.
  2. Click Filters and then “Create a new filter”.

In the subject line, add the subject of the email sent by the form.


Yiannis
——————————
neme.org | hblack.net | State Machines | NeMe @ github
I do my best editing after I click on the submit button.

Offline

#36 2017-12-10 13:43:44

Gallex
Member
Registered: 2006-10-08
Posts: 1,202

Re: com_connect - form and contact mailer

Bloke wrote #308210:

If you were only getting this from com_connect I’d say it was the new headers I implemented. I stripped out some of the headers that caused issues with newer versions of PHP and replaced them with an enhanced body instead. But if it’s happening with ZCR too then try tinkering with your email sending prefs (see phiw13’s post)

i did what phiw13 suggested: included from=”…” to the form and domain-specific email address to preferences. no “spoofing email” warnings anymore, but still no file attached with an email. :(

and also look into what gaekwad suggests.

could anybody tell me, what exactly i need to do to update my domains with DKIM and SPF?

my line: <txp:com_connect_file type="file" accept=".pdf,.xls,.odt,.doc,.docx" label="Lisa fail:" max="8000000" required="0" />

Last edited by Gallex (2017-12-10 14:15:03)

Offline

Board footer

Powered by FluxBB