Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2017-02-23 12:54:56

philwareham
Core designer
From: Haslemere, Surrey, UK
Registered: 2009-06-11
Posts: 3,555
Website GitHub Mastodon

Forum now HTTPS and on .io domain

The Textpattern forum is now on HTTPS and moved to the Textpattern.io domain name thanks to behind the scenes work by Robert and some tweaking from me. Links shouldn’t be broken – but please let us know if you experience any problems. You’ll need to log in again – sorry but that’s unavoidable.

Offline

#2 2017-02-23 14:52:48

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,795
Website GitHub

Re: Forum now HTTPS and on .io domain

Works for me. Top work, you two!


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#3 2017-02-23 14:55:10

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,284

Re: Forum now HTTPS and on .io domain

The redirections of bookmarked URLs are working properly again, thanks guys. (Nice spaghettied tape drawing, Phil :)
Seems, though, as if the Jukka-JS-additions aren’t working: currently I can’t quote posts.


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#4 2017-02-23 14:56:12

philwareham
Core designer
From: Haslemere, Surrey, UK
Registered: 2009-06-11
Posts: 3,555
Website GitHub Mastodon

Re: Forum now HTTPS and on .io domain

uli wrote #304215:

The redirections of bookmarked URLs are working properly again, thanks guys. (Nice spaghettied tape drawing, Phil :)
Seems, though, as if the Jukka-JS-additions aren’t working: currently I can’t quote posts.

Working for me. Try clearing your cache maybe? I’ve just cleared the forum software’s cache too to see if that helps.

Offline

#5 2017-02-23 14:58:46

philwareham
Core designer
From: Haslemere, Surrey, UK
Registered: 2009-06-11
Posts: 3,555
Website GitHub Mastodon

Re: Forum now HTTPS and on .io domain

Can someone also try creating a new user and post a reply here? Just to check new user signup is working as expected?

Offline

#6 2017-02-23 15:00:03

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,284

Re: Forum now HTTPS and on .io domain

Will do!


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#7 2017-02-23 15:05:04

newforumuseronio
New Member
Registered: 2017-02-23
Posts: 1

Re: Forum now HTTPS and on .io domain

Yup, works.

Offline

#8 2017-02-23 15:07:32

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,284

Re: Forum now HTTPS and on .io domain

And in the meantime the Quote link appeared. Thanks!


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#9 2017-02-23 15:10:07

philwareham
Core designer
From: Haslemere, Surrey, UK
Registered: 2009-06-11
Posts: 3,555
Website GitHub Mastodon

Re: Forum now HTTPS and on .io domain

newforumuseronio wrote #304220:

Yup, works.

Thanks newforumuseronio ;)

Offline

#10 2017-02-23 16:00:31

michaelkpate
Moderator
From: Avon Park, FL
Registered: 2004-02-24
Posts: 1,378
Website GitHub Mastodon

Re: Forum now HTTPS and on .io domain

Changing your passsword works as well. (I couldn’t get what I thought was mine to work.)

Offline

#11 2017-02-23 16:03:43

michaelkpate
Moderator
From: Avon Park, FL
Registered: 2004-02-24
Posts: 1,378
Website GitHub Mastodon

Re: Forum now HTTPS and on .io domain

Going straight to forum.textpattern.com is redirecting to https://forum.textpattern.com/https:/forum.textpattern.io/ which generates a 404 and then you can just click the forum index link.

Offline

#12 2017-02-23 16:06:34

philwareham
Core designer
From: Haslemere, Surrey, UK
Registered: 2009-06-11
Posts: 3,555
Website GitHub Mastodon

Re: Forum now HTTPS and on .io domain

Hmm, then something seems to be wrong in the .htaccess file (which isn’t my strong point). Anyone offer up a clue as to what?

<IfModule mod_rewrite.c>
    RewriteEngine On

    # Redirect from `.com` to `.io` domain.

    RewriteCond %{HTTP_HOST} ^forum.textpattern.com [NC]
    RewriteRule ^(.*)$ https://forum.textpattern.com/$1 [R=301]

    # Redirect from `http://` to `https://` protocol.

    RewriteCond %{HTTPS} !=on
    RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301]

</IfModule>

Offline

Board footer

Powered by FluxBB