Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#25 2014-07-23 10:21:38

Destry
Member
From: Haut-Rhin
Registered: 2004-08-04
Posts: 4,909
Website

Re: Markdown as an option for 4.5? Make it pluggable perhaps!

wet,

I’m getting this error when I install the plugin (txt version):

Fatal error: Class 'Textpattern_Textfilter_Base' not found in /users/home/.../domains/.../web/public/textpattern/lib/txplib_misc.php(812) : eval()'d code on line 3

(Don’t know how to wrap code in here.)

Should I be installing something else?

Offline

#26 2014-07-23 12:36:55

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 11,220
Website GitHub

Re: Markdown as an option for 4.5? Make it pluggable perhaps!

Destry wrote #282390:

Fatal error: Class ‘Textpattern_Textfilter_Base’ not found

Without looking at the code, starting with the most likely cause for failure… you do have SVN Textpattern 4.6 installed, right?


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#27 2014-07-23 14:22:58

Destry
Member
From: Haut-Rhin
Registered: 2004-08-04
Posts: 4,909
Website

Re: Markdown as an option for 4.5? Make it pluggable perhaps!

Heh. No. (Brain full of Txp tumbleweeds.)

Offline

#28 2015-10-27 19:57:14

Destry
Member
From: Haut-Rhin
Registered: 2004-08-04
Posts: 4,909
Website

Re: Markdown as an option for 4.5? Make it pluggable perhaps!

Getting that error again, but this time I do have 4.6dev installed locally. Need to update my dev version?

Offline

#29 2015-10-27 20:20:08

jakob
Admin
From: Germany
Registered: 2005-01-20
Posts: 4,555
Website

Re: Markdown as an option for 4.5? Make it pluggable perhaps!

Destry, If you have a recent 4.6 installed, it might have to do with this txp update to the way class namespacing is done. I had this problem yesterday with rah_beacon and had to make a small modification to the code. It looks like wet has already made the corresponding change for his markdown filter.
If you’ve just installed his newest filter from github, then you might need to update your dev version. Both changes happened in the last 10 days or so.


TXP Builders – finely-crafted code, design and txp

Offline

#30 2015-10-27 20:46:07

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 11,220
Website GitHub

Re: Markdown as an option for 4.5? Make it pluggable perhaps!

Destry wrote #296259:

Getting that error again, but this time I do have 4.6dev installed locally.

Yep, what jakob said. Plugins will need a modification unfortunately. One of the pitfalls of working to development code…


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#31 2015-10-28 01:36:19

Destry
Member
From: Haut-Rhin
Registered: 2004-08-04
Posts: 4,909
Website

Re: Markdown as an option for 4.5? Make it pluggable perhaps!

Updating did the trick. Thanks.

Offline

#32 2016-03-17 11:27:23

dos
Member
From: de
Registered: 2014-05-17
Posts: 51

Re: Markdown as an option for 4.5? Make it pluggable perhaps!

Quick question about the plugin: Besides installing in the txp admin site, I need to put both PHP-files in my website root folder, correct?


“HaHa. Your medium is dying.” –Nelson Muntz, Springfield.

Offline

#33 2016-03-17 11:33:58

wet
Developer Emeritus
From: Schoerfling, Austria
Registered: 2005-06-06
Posts: 3,318
Website Mastodon

Re: Markdown as an option for 4.5? Make it pluggable perhaps!

Not correct. You only need to install the plugin from the text file.

Offline

#34 2016-03-17 11:38:01

dos
Member
From: de
Registered: 2014-05-17
Posts: 51

Re: Markdown as an option for 4.5? Make it pluggable perhaps!

Easier than I thought. Thank you :)


“HaHa. Your medium is dying.” –Nelson Muntz, Springfield.

Offline

Board footer

Powered by FluxBB