Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2011-03-15 13:08:55

cuda
Member
From: Georgia, USA
Registered: 2008-02-06
Posts: 70
Website

403 error when saving template

I am getting an odd error when I am saving a template when I past this code in:

<ul style="display: none;">
<li style="display: none;"></li>
<txp:article_custom limit="99999" form="monthly_article" section="article" /> </ul>

If I remove the style=“display :none;” from the ul and li elements it saves fine but with the the style=“display:none;” it gives me a 403 error. Now if I change the style to say style=“color:red;” it saves normally with no error. Bug maybe with parsing I don’t know? Ideas?

I know it is easy enough to work around but just an odd bug thought I would report it.

Offline

#2 2011-03-15 13:23:32

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 9,499
Website

Re: 403 error when saving template

cuda wrote:

Bug maybe with parsing I don’t know? Ideas?

Possibly an over-zealous anti-spam or other content filter on your host/ISP. Some related tomfoolery that might help track this down.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#3 2011-03-15 14:15:10

cuda
Member
From: Georgia, USA
Registered: 2008-02-06
Posts: 70
Website

Re: 403 error when saving template

thanks bloke thought it might be on the hosting side

Offline

#4 2011-03-19 16:31:27

danfarr
New Member
Registered: 2010-05-03
Posts: 9

Re: 403 error when saving template

Did you find a solution to this?

I’m having the same problem but only updating Presentation Forms, I’ve been testing it out for a few days and found that this problem only happens with submitting a form that has more than one tag (HTML or TXP) if it is empty or contains one tag. Otherwise I’m greeted with:

Forbidden

You don’t have permission to access /prav/textpattern/index.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I’ve tried all the documented solutions, switching to messy urls, clearing my .htacess to try and see what else is happening, still get a 403. Added:

<IfModule mod_security.c> SecFilterScanPOST Off
</IfModule>

to a .htaccess in the textpattern dir, spoke to my webhost who disabled mod_security but it still persisted. My Server error log isn’t telling me anything useful. Even upgraded from 4.2.0 to 4.3.0 still the same deal. At first I thought it had to be server side as I had this site hosted on but after more research I’m starting to think it’s something to do with the code as the problem seems to only happen with presntation forms. If anyone has any suggestions I’d be seriously thankful, thanks!

Offline

#5 2011-03-19 22:08:36

cuda
Member
From: Georgia, USA
Registered: 2008-02-06
Posts: 70
Website

Re: 403 error when saving template

I assumed it was a security setting on my host side but could not track it down either. It may in fact have something to do with textpattern I am not ….

Offline

#6 2011-03-20 06:43:08

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,043
Website

Re: 403 error when saving template

Try

RewriteEngine On
SecFilterSelective REMOTE_ADDR ^xxx.xxx.xxx.xxx$ nolog,allow

replace the xs with your ip.


Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | NeMe @ github | Covid-19; a resource
I do my best editing after I click on the submit button.

Offline

#7 2011-04-22 16:38:28

cuda
Member
From: Georgia, USA
Registered: 2008-02-06
Posts: 70
Website

Re: 403 error when saving template

Took me a while to get back to this but I am not on a dedicated IP and in a shared hosted site so doing this fix only gives me a 500 internal error. It is strange though it depends on which tags I am trying to save.

Example if I have a article form with just:
<txp:body/> it will save fine

or
<txp:title/> it saves fine

but put any two tags together:
<txp:body/><txp:title/> and it gives the 403 error

Infact any two sets of <> and it will give the 403
<this wont><save>

Offline

#8 2011-04-23 10:22:51

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,043
Website

Re: 403 error when saving template

You could try adding SecFilterEngine Off to your htaccess.

Somebody here should advise how this would affect the security of your site though.


Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | NeMe @ github | Covid-19; a resource
I do my best editing after I click on the submit button.

Offline

Board footer

Powered by FluxBB