Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#133 2010-07-18 03:16:09

wet
Developer Emeritus
From: Schoerfling, Austria
Registered: 2005-06-06
Posts: 3,327
Website Mastodon

Re: wet_quicklink: Quick internal link builder

Tom, this is a reasonable proposition. Sadly, it’s no small change but a rather massive code extension. I will look into it but don’t hold your breath waiting.

Offline

#134 2010-07-18 14:35:46

renobird
Member
From: Gainesville, Florida
Registered: 2005-03-02
Posts: 786
Website

Re: wet_quicklink: Quick internal link builder

damn…I was hoping it would be easy.
I’ll move it over into the “maybe someday” pile.

;)

Offline

#135 2010-11-29 21:04:23

alanfluff
Member
From: Ottawa, Canada
Registered: 2008-09-15
Posts: 222
Website

Re: wet_quicklink: Quick internal link builder

Hi Robert,

A site that was 4.2.0, is now 4.3.0 and has these (lovely) plugins:

  1. wet_link 0.8
  2. wet_peex 0.4
  3. wet_quicklink 0.7
  4. wet_quickopen 0.1

…amongst others, now refuses, when using wet_quicklink to remember or use link type of wet_link and always inserts links of type permlink.

Any thoughts on this and/or is there anything I can do to help track this down?

Thanks lots in advance, cheers, -Alan


At LAST I’ve cheerfully donated to the core devs at #TXP. I only wish I were able to give more. Thanks to the devs and ALL fellow TXPers. -A

Offline

#136 2010-12-01 13:25:23

wet
Developer Emeritus
From: Schoerfling, Austria
Registered: 2005-06-06
Posts: 3,327
Website Mastodon

Re: wet_quicklink: Quick internal link builder

Alan, I can confirm that there’s not a problem in general with this combination if my plugins, and I cannot reproduce the behaviour you are experiencing.

I assume you’ve performed the usual voodoo already (clear browser cache, hit “refresh” very very hard).

If you happen to have Firebug at your disposal, you could verify this expected behaviour for me:

  1. Open the Textpattern write tab and enable Firebug there
  2. Switch to Firebug’s “Network” panel
  3. Display wet_quicklink’s panel by clicking on “Insert link”. You should see a GET request on Firebug’s network tab now. Carry on…
  4. Click the “URL mode” drop-down. You should see one or even two POST requests in Firebug. These are caused by wet_quicklink trying to save your URL mode preferences in the background.
  5. Expand the POST request and check, whether these three parameters (app_mode, key, wet_quicklink) are present:
  6. The value of key depends on your chosen URL mode
  7. At the “Response” tab, the server should have sent some XML like this:
  8. Report back.

Offline

#137 2010-12-01 14:36:36

alanfluff
Member
From: Ottawa, Canada
Registered: 2008-09-15
Posts: 222
Website

Re: wet_quicklink: Quick internal link builder

Hi Robert,

I just don’t believe it, I cannot reproduce the problem…

I had the problem on a site, in Chrome (latest) on OS X (latest).

So next, I changed to Firefox and also had the problem.

So now, a day or two later, I cannot re-produce the problem.

I am delighted that this at least means I do not pass you more work (debug) but I am dreadfully sorry that something caused me to interrupt you and write your most helpful reply.

Next time I get this sort of problem I will:

  • re-boot
  • move house
  • wear gloves
  • eat more vegetables
  • listen to some music
  • walk around a bit
  • delete OS X and install Windows 7 on bootcamp
  • buy all new apps and install them
  • delete and reinstall OS X
  • login and try to re-produce the problem, and if it STILL exists, only then will I bother you!

Thanks again, sorry and cheers!

-Alan


At LAST I’ve cheerfully donated to the core devs at #TXP. I only wish I were able to give more. Thanks to the devs and ALL fellow TXPers. -A

Offline

#138 2011-03-09 11:13:50

douglgm
Member
From: Bristol
Registered: 2006-08-23
Posts: 182
Website

Re: wet_quicklink: Quick internal link builder

Really love this plug-in. Without it I can imaging that I’d be having some interesting conversations with some of my users!

I don’t suppose that there could ever be an equivalent for linking to files? Attaching files to an article in a custom field is one thing, but it would be great to easily insert file links in the text body.

Doug.

Offline

#139 2011-03-09 11:42:55

wet
Developer Emeritus
From: Schoerfling, Austria
Registered: 2005-06-06
Posts: 3,327
Website Mastodon

Re: wet_quicklink: Quick internal link builder

Currently, there’s no such thing in my plans.

Offline

#140 2011-04-15 13:15:40

alanfluff
Member
From: Ottawa, Canada
Registered: 2008-09-15
Posts: 222
Website

Re: wet_quicklink: Quick internal link builder

Hi Robert,

I had that problem again — I’m sure it must be something to do with me!

This time it’s a 4.3.0 that’s just been upgraded to 4.4.0. But I really don’t think it’s to do with TXP ver or versions of your plugins, my guess is it’s some weird inability for cookie’s to be set or retained or read (maybe?) that I seem to have with this environment here.

Anyway, not wanting to bother you, and because I LOVE wet_link over permalink, I modified wet_quicklink 0.7 source from

// Gather link markup preferences
	$curr_key = get_pref('wet_quicklink.key', 'txp:permlink');

to…

// Gather link markup preferences
	$curr_key = get_pref('wet_quicklink.key', 'txp:wet_link');

It seemed a bit brutal to modify your code, but it’s the preference I would always want anyway and it works so I am happy.

I just thought I’d tell you in case it was of any help in any way.

Thanks again for your brilliant work.

Cheers, -Alan


At LAST I’ve cheerfully donated to the core devs at #TXP. I only wish I were able to give more. Thanks to the devs and ALL fellow TXPers. -A

Offline

#141 2011-04-16 08:52:02

wet
Developer Emeritus
From: Schoerfling, Austria
Registered: 2005-06-06
Posts: 3,327
Website Mastodon

Re: wet_quicklink: Quick internal link builder

alanfluff wrote:

It seemed a bit brutal to modify your code, but it’s the preference I would always want anyway and it works so I am happy.

Glad you could work it out. I haven’t encountered this issue anywhere else so far, so it’s probably the most simple solution for you.

Offline

#142 2011-04-16 13:27:33

alanfluff
Member
From: Ottawa, Canada
Registered: 2008-09-15
Posts: 222
Website

Re: wet_quicklink: Quick internal link builder

Thanks Robert, and I’ll be sure to let you know here if I ever do work out what it was. Cheers, -Alan


At LAST I’ve cheerfully donated to the core devs at #TXP. I only wish I were able to give more. Thanks to the devs and ALL fellow TXPers. -A

Offline

#143 2011-06-11 04:51:27

wet
Developer Emeritus
From: Schoerfling, Austria
Registered: 2005-06-06
Posts: 3,327
Website Mastodon

Re: wet_quicklink: Quick internal link builder

wet_quicklink 0.8 fixes a bug in the bundled Textpacks and lifts the minimum requirements to Textpattern 4.3+.

Offline

#144 2011-06-13 12:00:30

philwareham
Core designer
From: Haslemere, Surrey, UK
Registered: 2009-06-11
Posts: 3,564
Website GitHub Mastodon

Re: wet_quicklink: Quick internal link builder

Cheers Robert, though there seems to be some breakage between v0.8 and bot_wtc on my system (can’t seem to reorder it to a different part of the write page). Can anyone else confirm?

Offline

Board footer

Powered by FluxBB