Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2011-02-26 10:01:49

th3lonius
Member
From: Iowa City, IA
Registered: 2010-02-09
Posts: 67
Website

User(s) Comment Bug

A particular user of my website (a contributing writer in fact) is for some reason unable to post comments on any article. I have had this issue in the past, except that it was I among others who could not comment. I never discovered the source of the problem then because I tried disqus briefly and when I returned to TXP’s comment system I rebuilt my forms from scratch and the problem disappeared… until now. I don’t know where to begin tracing the problem. I was informed of it by a third party so I don’t even know what is happening on the user’s end when he attempts to post comments.

Has any one had this issue before?

Offline

#2 2011-02-26 10:16:12

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 7,246
Website

Re: User(s) Comment Bug

Hi Matthew

check if their ip is banned

list of banned ips can be found on yoursite.com/textpattern/index.php?event=discuss&step=ipban_list


Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | Respbublika! | NeMe @ github

Offline

#3 2011-02-26 10:21:33

th3lonius
Member
From: Iowa City, IA
Registered: 2010-02-09
Posts: 67
Website

Re: User(s) Comment Bug

Thanks for the reply, Yiannis. Definitely not banned. At least not intentionally by me and not visible in TXPs interface. There are only 9 banned IPs on my list and all of them are obvious spam.

Offline

#4 2011-02-26 15:34:24

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 7,246
Website

Re: User(s) Comment Bug

Another idea… Your user’s browser might not accept cookies – or they might have blocked cookies from the site. Did you ask them to try with another browser?

If this is not the case it might be a good idea to clear the cookies as there might be a corruption in there.


Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | Respbublika! | NeMe @ github

Offline

#5 2011-02-26 16:06:58

Gocom
Plugin Author
From: Helsinki, Finland
Registered: 2006-07-14
Posts: 4,530
Website

Re: User(s) Comment Bug

Matthew, do you have any anti-spam plugins installed?

Or, well, is there a possibility that the user has posted the exact same message before? An user can’t post same message twice. For example if the user has once said generic “Nice.”, TXP will never after allow the same user to post comment with just the same single word, not in any article.

colak wrote:

Another idea… Your user’s browser might not accept cookies – or they might have blocked cookies from the site.

Textpattern’s comment system doesn’t require cookies.

Last edited by Gocom (2011-02-26 16:15:58)

Offline

#6 2011-02-26 17:29:08

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 7,246
Website

Re: User(s) Comment Bug

Gocom wrote:

Textpattern’s comment system doesn’t require cookies.

Hi Jukka. Honestly thought that it did. What’s the remember checkbox for then? Or maybe it provides them but they are not compulsory.


Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | Respbublika! | NeMe @ github

Offline

#7 2011-02-26 17:39:05

Els
Admin
From: The Netherlands
Registered: 2004-06-06
Posts: 7,458

Re: User(s) Comment Bug

Gocom wrote:

An user can’t post same message twice. For example if the user has once said generic “Nice.”, TXP will never after allow the same user to post comment with just the same single word, not in any article.

Didn’t know that, thanks. Nice ;)

Offline

#8 2011-02-26 18:23:22

Gocom
Plugin Author
From: Helsinki, Finland
Registered: 2006-07-14
Posts: 4,530
Website

Re: User(s) Comment Bug

colak wrote:

What’s the remember checkbox for then? Or maybe it provides them but they are not compulsory.

The cookies are not mandatory. The optional cookies are only used to store the values used in the fields for future sessions (pre-fill ftw), if the remember box is checked. Not required (nor used by the system) for posting.

Els wrote:

Didn’t know that, thanks. Nice ;)

:p

Offline

#9 2011-03-01 19:08:05

th3lonius
Member
From: Iowa City, IA
Registered: 2010-02-09
Posts: 67
Website

Re: User(s) Comment Bug

Thanks for the replies everyone. I’ve been away for a few days.

No anti-spam plugins installed and I think this guy has never posted a comment before. Just welcomed him to the staff a few weeks ago.

I have been under attack recently, though. Might that be related? I’ve had a few spam comments to delete recently, and I’ve noticed that two articles have far more hits than they should.

Offline

Board footer

Powered by FluxBB