Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2008-05-21 14:18:40

Registered: 2007-02-12
Posts: 79

fpx_image_import problems

Using this import method, I’m able to import individual images in the “import” folder, then categorize them as whatever… but if I try to import an entire folder named after the collective category, I get the error message below:

Warning: fpx_import(/nfs/c02/h02/mnt/24738/domains/suru-la.com/html/dev/textpattern/lib/classTextile.php) [function.fpx-import]: failed to open stream: No such file or directory in /nfs/c02/h02/mnt/24738/domains/suru-la.com/html/textpattern/lib/txplib_misc.php(574) : eval()'d code on line 419

Warning: fpx_import() [function.include]: Failed opening '/nfs/c02/h02/mnt/24738/domains/suru-la.com/html/dev/textpattern/lib/classTextile.php' for inclusion (include_path='.:/usr/local/php-4.4.8-1/share/pear') in /nfs/c02/h02/mnt/24738/domains/suru-la.com/html/textpattern/lib/txplib_misc.php(574) : eval()'d code on line 419

Fatal error: Cannot instantiate non-existent class: textile in /nfs/c02/h02/mnt/24738/domains/suru-la.com/html/textpattern/lib/txplib_misc.php(574) : eval()'d code on line 420

I tried using PHP 4 and PHP 5 and get the same thing. I’ve also tried reinstalling the plugin… I guess I’ll go through the most recently added and see if there’s a conflict..?

Last edited by fowler (2008-05-21 14:19:51)


#2 2008-05-21 15:57:22

From: Cologne
Registered: 2006-08-15
Posts: 4,272

Re: fpx_image_import problems


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links


#3 2008-12-12 20:10:41

From: Brooklyn NY
Registered: 2006-08-06
Posts: 51

Re: fpx_image_import problems

I’ve had this same problem, anyone figure out what the issue was?


#4 2010-10-15 16:00:04

Plugin Author
From: munich / dtschermani
Registered: 2008-08-25
Posts: 183

Re: fpx_image_import problems

the problem is right here: include_once $txpcfg[‘txpath’].’/lib/classTextile.php’;

as you can see, the path is incorrect:
in the second row the folder dev is missing.

i had the same problem. i fixed it by inserting the path manually. its in line 418, simply put include_once ‘/nfs/c02/h02/mnt/24738/domains/suru-la.com/html/dev/textpattern/lib/classTextile.php’;

sorry for the late fix LOL.
but maybe this helps other people with that issue.. ;)
and maybe i helped pushing the developer into the right direction..


Board footer

Powered by FluxBB