Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2010-06-16 20:55:33

neilbag00
Member
Registered: 2006-03-11
Posts: 9

Saving a form now causes 404 error (but can save Pages ok)

Hi

Just wondering if anyone has any ideas as to why saving a Textpattern Form should suddenly start going to the Error 404 page (+ doesn’t actually save)? Saving Pages and Articles are unaffected.

The strange thing is, after clickg Save (to save a Form), I get Error 404 yet the url is still …/textpattern/index.php (that url is fine if I simply type it in or go to another textpattern page).

The problem persists even if I restore very old databases that definitely worked so I wonder if it could be a change on the server? But if so, why aren’t the other textpattern pages affected, how come I can save Pages and Articles?

Strange! Any thoughts would be appreciated.

Many Thanks
Neil

EDITBTW, I just tried logging in and saving a form on this Textpattern demo site: http://php.opensourcecms.com/scripts/details.php?scriptid=86&name=Textpattern and I got exactly the same problem with their setup (error 404 when saving a textpattern Form but could save Pages etc ok).

Last edited by neilbag00 (2010-06-16 22:00:58)

Offline

#2 2010-06-17 06:20:36

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,013
Website

Re: Saving a form now causes 404 error (but can save Pages ok)

Hi neilbag00,

There’s another thread with the same heading. Did you check the advise there?


Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | NeMe @ github | Covid-19; a resource
I do my best editing after I click on the submit button.

Offline

#3 2010-06-19 15:18:26

neilbag00
Member
Registered: 2006-03-11
Posts: 9

Re: Saving a form now causes 404 error (but can save Pages ok)

Hi Colak

Thanks, yeah I did see that when I typed in a search but the link came back as broken at the time (I wasn’t being lazy : )

Anyhow, I’ve aaded some comments to that post, basically it could be due to my hosts upgrading mod_security (I don’t really know much about that side of things).

What I DO know, is that, very strangely, I can save Forms if the don’t contain any double speech marks. For example, through a lot of trial and error, I discovered that if I delete all “ and replace with ‘ the Form will save. So, replacing <p class=“myclass”> with <p class=‘myclass’> seems to allow the form to save.
I’ve never know anything so bizarre! Does anybody know what could be causing this? Tearing my hair out : (

Thanks for any advice.

Offline

#4 2010-06-19 15:39:11

neilbag00
Member
Registered: 2006-03-11
Posts: 9

Re: Saving a form now causes 404 error (but can save Pages ok)

Ah, managed to upgrade and seems ok now.

Great stuff although I think the note in the readme about upgrading from < 4.2.0 could be clearer. I had to delete all cookies and keep logging a few times before it all settled down and error messages stopped appearing. I almost gave up hope. Phew!

Offline

#5 2010-06-19 16:02:40

Gocom
Plugin Author
From: Helsinki, Finland
Registered: 2006-07-14
Posts: 4,533
Website

Re: Saving a form now causes 404 error (but can save Pages ok)

neilbag00 wrote:

I’ve never know anything so bizarre! Does anybody know what could be causing this? Tearing my hair out : (

Might be the security filters, who knows. Best to ask your host.

Offline

#6 2010-06-25 11:04:22

Robin.l
New Member
Registered: 2010-06-25
Posts: 1

Re: Saving a form now causes 404 error (but can save Pages ok)

Hi

Im new around here but:

I’m having a similar problem where: I can’t edit a form and it gives a 403 error (Forbidden).

I have tryed adding a .htaccess file to /textpattern/ with:

SecFilterScanPOST Off

-It doesnt help, it causes the whole of /textpattern/ to give a error 500.

Again its only the forms I can’t edit. And I can edit them if they are either: only one line long or no tags are present in the lines following the first.

Is this going to be a server security thing? Is there anything I can do?

Many Thanks,

Robin

Offline

#7 2010-06-25 12:43:59

neilbag00
Member
Registered: 2006-03-11
Posts: 9

Re: Saving a form now causes 404 error (but can save Pages ok)

Hmmm. I still have this problem it seems. I thought it had gone away when I upgraded but I was mistaken.

Robin – have you tried replacing double quotes with single quotes? Works for me. Makes me wonder though whether double quotes are causing the failure due to the posted string being ‘closed off early’ by the double quotes that are typed in (I’m just guessing here, I haven’t a clue how things work beind the scenes).

I can only guess it’s something to do with upgraded php security or php libraries. Who knows?!?

Offline

#8 2010-06-25 14:27:24

Gocom
Plugin Author
From: Helsinki, Finland
Registered: 2006-07-14
Posts: 4,533
Website

Re: Saving a form now causes 404 error (but can save Pages ok)

Robin.l wrote:

It doesnt help, it causes the whole of /textpattern/ to give a error 500.

Which might happen when the hosting provider doesn’t allow you to change server’s configuration.

Is this going to be a server security thing? Is there anything I can do?

If your host has limited what you can configure, and there is a security filter set, you need to ask your host. Your host might know more than we do.

neilbag00 wrote:

I can only guess it’s something to do with upgraded php security or php libraries. Who knows?!?

Yes, most likely it’s the server’s security filters. Your host should know, ask them.

Offline

Board footer

Powered by FluxBB