Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2009-02-11 18:21:40

maxvoltar
Member
From: Machelen, Belgium
Registered: 2007-08-16
Posts: 76
Website

[resolved] [Solved] Moved host, unable to upload images

I finally moved away from GoDaddy, and moved my blog to a host where all my other sites are. I’ve never had any problem with Textpattern on that host, and was surprised to see following error when I tried to upload a new image:

Warning: tempnam() [function.tempnam]: open_basedir restriction in effect. File(/usr/home/deb7131/domains/maxvoltar.com/public_html/textpattern/tmp) is not within the allowed path(s): (/home/deb7131n5/:/tmp:/usr/local/lib/php/) in /usr/home/deb7131n5/domains/maxvoltar.com/public_html/textpattern/lib/txplib_misc.php on line 1331

When I go to Diagnostics, it tells me this:

File directory path is not writable: /usr/home/deb7131/domains/maxvoltar.com/public_html/files
Temporary directory path is not writable: /usr/home/deb7131/domains/maxvoltar.com/public_html/textpattern/tmp ?
The following PHP functions (which may be necessary to run Textpattern) are disabled on your server: proc_get_status, proc_nice, proc_terminate, pcntl_exec

Now what’s weird is that the files and temp folders ARE writable (777).
Any idea the disabled PHP functions might cause anything?

I’ve updated Textpattern to the latest version, tried disabling all plugins, … Cant find a solution I’m afraid.

Anyone has any idea?

EDIT: Just realised I posted this in the wrong forum. Can someone replace it? So sorry! /me feels like a noob

Last edited by maxvoltar (2009-02-11 18:23:35)


Textpattern projects: Maxvoltar, Made by Elephant, Twunch

Offline

#2 2009-02-11 21:11:44

wet
Developer Emeritus
From: Schoerfling, Austria
Registered: 2005-06-06
Posts: 3,274
Website

Re: [resolved] [Solved] Moved host, unable to upload images

... File(

/usr/home/deb7131/domains/maxvoltar.com/public_html/textpattern/tmp) 

is not within the allowed path(s): (

/home/deb7131n5/:/tmp:/usr/local/lib/php/) 

Check your preferences for the “tmp” and “files” folder, plus the $txpcfg['txpath'] setting in config.php. I think /home/deb7131n5/ is not equivalent to /usr/home/deb7131/

Last edited by wet (2009-02-11 21:13:07)

Offline

#3 2009-02-11 21:13:26

maxvoltar
Member
From: Machelen, Belgium
Registered: 2007-08-16
Posts: 76
Website

Re: [resolved] [Solved] Moved host, unable to upload images

@wet: You’re right, that was the problem! Feeling like such an idiot for not seeing that…

Move along, nothing to see here :)


Textpattern projects: Maxvoltar, Made by Elephant, Twunch

Offline

Board footer

Powered by FluxBB