Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2021-09-01 13:10:43

ibrahima
Member
Registered: 2021-04-16
Posts: 23

Site corrupt for no obvious reason, please help!

Hi All
My [under construction] blog is now displaying just text without any picture or theme. I have no idea what happened. I did not do anything for several weeks. First it stated showing nothing, even domain name not pointing to the website. I wonder if someone did not just mess up with the file. One other person had access to the server. But I don’t know what happended.
All admin pages show “404 Nnot found”!
Any thoughts? Solutions?
Cheers all
Ibrahima

Offline

#2 2021-09-01 14:16:04

Dragondz
Moderator
From: Algérie
Registered: 2005-06-12
Posts: 1,442
Website GitHub Twitter

Re: Site corrupt for no obvious reason, please help!

Hi,

Can you give a little more details ? The domain name of your blog, the txp version, can you log to txp admin ?

Cheers.

Offline

#3 2021-09-01 15:02:11

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,614
Website GitHub

Re: Site corrupt for no obvious reason, please help!

If your admin side is 404ing there are two main possible reasons:

  1. Your site files are missing for some reason on the server. Perhaps re-upload the files from your Textpattern distribution zip file following the guidelines for installation or upgrading.
  2. Your .htaccess file is missing from the root of your site, which is what helps Textpattern route content pages through the main file. Check that file exists on your server, as copied from your Textpattern distribution (note the preceding dot).

Try one or both of those and see if things improve.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#4 2021-09-01 16:43:33

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,794
Website GitHub Twitter

Re: Site corrupt for no obvious reason, please help!

A third possibility is that your database tables may need repairing.


Yiannis
——————————
neme.org | hblack.net | State Machines | NeMe @ github
I do my best editing after I click on the submit button.

Offline

#5 2021-09-01 17:03:00

ibrahima
Member
Registered: 2021-04-16
Posts: 23

Re: Site corrupt for no obvious reason, please help!

Hi

Dragondz wrote #331490:

Hi,

Can you give a little more details ? The domain name of your blog, the txp version, can you log to txp admin ?

Cheers.

Yes, sorry about that:
url: <http://blog.pulaar-fulfulde.org/blog/ibrahima-sarr />
- I cannot see the Admin login page!
- Textpattern 4.8.5 but tried to uprade to 4.8.7 today to see if issue would be solved.

Thanks

Last edited by ibrahima (2021-09-01 17:10:10)

Offline

#6 2021-09-01 17:06:05

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,614
Website GitHub

Re: Site corrupt for no obvious reason, please help!

Isn’t this it? blog.pulaar-fulfulde.org/textpattern/ or have you installed a second instance of Textpattern at the URL you posted above?

Last edited by Bloke (2021-09-01 17:07:04)


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#7 2021-09-01 17:06:08

ibrahima
Member
Registered: 2021-04-16
Posts: 23

Re: Site corrupt for no obvious reason, please help!

Bloke wrote #331491:

If your admin side is 404ing there are two main possible reasons:

  1. Your site files are missing for some reason on the server. Perhaps re-upload the files from your Textpattern distribution zip file following the guidelines for installation or upgrading.
  2. Your .htaccess file is missing from the root of your site, which is what helps Textpattern route content pages through the main file. Check that file exists on your server, as copied from your Textpattern distribution (note the preceding dot).

Try one or both of those and see if things improve.

Thanks a lot!
Actually, everything seemed to be there. But I need to check. The url is: Yes, sorry about that:
url: http://blog.pulaar-fulfulde.org/blog/ibrahima-sarr/
- I cannot see the Admin login page!
Everything seems to be corrupt!

Thanks

Offline

#8 2021-09-01 17:16:47

ibrahima
Member
Registered: 2021-04-16
Posts: 23

Re: Site corrupt for no obvious reason, please help!

Bloke wrote #331495:

Isn’t this it? blog.pulaar-fulfulde.org/textpattern/ or have you installed a second instance of Textpattern at the URL you posted above?

Textpattern is installed here: http://blog.pulaar-fulfulde.org/blog/ibrahima-sarr/textpattern/ url but it is weird to access admin from the one you posted.

Last edited by ibrahima (2021-09-01 17:17:34)

Offline

#9 2021-09-01 18:01:45

GugUser
Member
From: Quito (Ecuador)
Registered: 2007-12-16
Posts: 1,468

Re: Site corrupt for no obvious reason, please help!

Textpattern is on http://blog.pulaar-fulfulde.org/textpattern/.

On http://blog.pulaar-fulfulde.org I see: “config.php is missing or corrupt. To install Textpattern, visit setup.”

Offline

#10 2021-11-13 11:26:47

ibrahima
Member
Registered: 2021-04-16
Posts: 23

Re: Site corrupt for no obvious reason, please help!

Hi All
Hope you are doing great. It’s been quite some time since I opened this topic. Gave me a lot of headaches! After some random tweaking, looks like I have access to the content and admin but the theme looks corrupt and pictures are not showing.
I am very upset cause someone messed up my work by moving files and pretended they did not touch anything.
Now I want to solve the issues:
- theme looks corrupt
- pictures are not showing
- I get a NOT FOUND message when trying to access the texpattern installation directory: http://blog.pulaar-fulfulde.org/blog/ibrahima-sarr/textpattern/
I get it here: http://blog.pulaar-fulfulde.org/textpattern/. So if I understand, you get to textpattern admin by url/texpattern instead of url/path-to-texpattern?

Any help welcome and thanks in advance!

Ibrahima

Last edited by ibrahima (2021-11-13 11:36:27)

Offline

#11 2021-11-13 14:45:37

jakob
Admin
From: Germany
Registered: 2005-01-20
Posts: 4,231
Website

Re: Site corrupt for no obvious reason, please help!

Hi ibrahima,

I think you just have a problem with your paths and URLs but with a bit of luck everything is still there. You need to omit /blog/ibrahima-sarr/ from your URLs (even if they are in the server path). Then it looks like everything is there:

Textpattern admin:

https://blog.pulaar-fulfulde.org/textpattern/

Images – I tried a few that showed error and they can be found correctly at:

http://blog.pulaar-fulfulde.org/images/16.jpg
http://blog.pulaar-fulfulde.org/images/17.png
http://blog.pulaar-fulfulde.org/images/18.gif

CSS:

https://blog.pulaar-fulfulde.org/css.php?n=default&t=four-point-eight

If you look carefully you’ll see they’re almost all the same as what you wrote except for blog/ibrahima-sarr/. Try the following:

  1. Log into the admin address at https://blog.pulaar-fulfulde.org/textpattern/ with your user and password.
  2. Visit Admin › Preferences › Site and then make sure Site URL is blog.pulaar-fulfulde.org. Save your changes.
  3. Try visiting the site.

With luck you should find your site working at: https://blog.pulaar-fulfulde.org.


TXP Builders – finely-crafted code, design and txp

Offline

#12 2021-11-14 16:48:28

ibrahima
Member
Registered: 2021-04-16
Posts: 23

Re: Site corrupt for no obvious reason, please help!

jakob wrote #331947:

Hi ibrahima,

I think you just have a problem with your paths and URLs but with a bit of luck everything is still there. You need to omit /blog/ibrahima-sarr/ from your URLs (even if they are in the server path). Then it looks like everything is there:

Textpattern admin:

https://blog.pulaar-fulfulde.org/textpattern/...

Images – I tried a few that showed error and they can be found correctly at:

http://blog.pulaar-fulfulde.org/images/16.jpg...

CSS:

https://blog.pulaar-fulfulde.org/css.php?n=default&t=four-point-eight...

If you look carefully you’ll see they’re almost all the same as what you wrote except for blog/ibrahima-sarr/. Try the following:

  1. Log into the admin address at https://blog.pulaar-fulfulde.org/textpattern/ with your user and password.
  2. Visit Admin › Preferences › Site and then make sure Site URL is blog.pulaar-fulfulde.org. Save your changes.
  3. Try visiting the site.

With luck you should find your site working at: https://blog.pulaar-fulfulde.org.

Yeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeah! WORKED! I was so desperate! Thank you so much! Cannot thank you enough! My wife got scared when I screamed. Now she is mad at me. Any solution for that? ;)

Offline

Board footer

Powered by FluxBB