Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2021-06-26 16:33:21

kaline
Member
From: Plymouth, MN
Registered: 2005-07-18
Posts: 38
Website

4.8.7 Upgrade problems

Hi again, everyone.

Last night I upgraded another textpattern site I run and things went pretty smoothly. So, today I decided to tackle another one, and it’s not going so well.

I followed all of the instructions, made sure folders are writeable, etc. When I go to the admin page and try to log in, I get an error back saying “could_not_log_in”. Also weird on that login page is the checkbox with label “stay_logged_in” and a button labeled “log_in_button”. So it’s almost like there’s something else going on.

I tried to reset my password by clicking the “password_forgotton” link, and that said it was successful, but I never received an email.

I didn’t touch my textpattern/config.php file. It’s the same as it was before I upgraded when things were still working. I know it’s something stupid, but I can’t figure it out. Thanks in advance!

Last edited by kaline (2021-06-26 16:33:40)

Offline

#2 2021-06-27 04:05:29

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,687
Website GitHub Twitter

Re: 4.8.7 Upgrade problems

Did you try reuploading? Sometimes, gremlins appear when files are in transit.


Yiannis
——————————
neme.org | hblack.net | State Machines | NeMe @ github
I do my best editing after I click on the submit button.

Offline

#3 2021-06-27 13:39:00

kaline
Member
From: Plymouth, MN
Registered: 2005-07-18
Posts: 38
Website

Re: 4.8.7 Upgrade problems

Yes, @colak. In fact, I removed the old /textpattern folder (minus config.php) and re-uploaded it. Also did a re-upload of the files in / but it didn’t make a difference.

Offline

#4 2021-06-27 14:10:19

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,481
Website GitHub

Re: 4.8.7 Upgrade problems

If you can’t log into the back-end at all, it may be that the cookie is somehow mangled. So try and locate any Textpattern cookies and delete them. I’ve had it before where it just goes round in a loop and won’t let you log in.

However, if you’re seeing those untranslated strings, it seems as if the language pack isn’t being loaded properly, which points to a deeper problem. What language are you using? en-us?

If all the files are uploaded fine and clearing your Textpattern cookies doesn’t resolve it, try resetting your password at the database level, just to eliminate that. You should be safe to use the MySQL 8+ process on any version of MySQL, btw. It might be prudent for us to remove the docs that state the process for the other one, as most versions we support should now be able to use the latter process.

While you’re in your database admin interface, try checking a few things:

1) Check the collation of the database and all the tables / columns matches – they should all be the same.
2) Check the database charset in config.php matches the database.
3) In your txp_prefs table, check the ‘version’ string and let us know what it says. Seems as if the upgrade process isn’t working so knowing which version you’re upgrading from might be handy.
4) In the txp_prefs table, change the production_mode value to debug and then refresh your browser to see if there are any errors thrown which might help diagnose what’s going on.

Beyond that, I’m not sure what else could be the problem. It seems like it’s connected to a database okay but something between there and the browser is not working. Very odd.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#5 2021-06-29 16:12:42

kaline
Member
From: Plymouth, MN
Registered: 2005-07-18
Posts: 38
Website

Re: 4.8.7 Upgrade problems

Thanks, @bloke! It looks like resetting the password following the instructions in the link your provided fixed things. Thank you for your help!

Offline

Board footer

Powered by FluxBB