Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2021-03-24 20:19:15

jrmartin
Member
From: California | Italy
Registered: 2013-03-07
Posts: 108
Website

A problem with Themes

I’ve decided to update the Wandering Italy Blog. The last update was in 2018. I duplicated the theme and worked on the Archive page. Everything was fine. Then I added a new form to the 2018 update theme and now there are two problems.

I can’t see the 2021 default template. So if I’m looking at the pages in the 2021 update and click on the default template, it switches me to the default template of the 2018 update theme. If I try to change the theme to 2021 I get an error message that reads, “I’m sorry. I’m afraid I can’t do that; page page_skin_change is an unsafe operation.”

All this is on Firefox. When I switch to Chrome and try to log in, the login panel tells me that I need to have cookies enabled, which I do. I can log in on other textpattern sites on chrome without this message.

I probably haven’t described this very well, but I’m wondering if anyone has any clues as to why this is happening. I just can’t seem to edit the default page of the 2021 update, but know it is there, I just can’t get to it.

james

The site is running 4.8.4. I’ve cleared cache and cookies but the issue remains.

Online

#2 2021-03-24 21:48:27

bici
Member
From: vancouver
Registered: 2004-02-24
Posts: 1,819
Website

Re: A problem with Themes

i don’t have any ideas on the issues …but i love your blog


…. texted postive

Offline

#3 2021-03-24 22:51:11

jrmartin
Member
From: California | Italy
Registered: 2013-03-07
Posts: 108
Website

Re: A problem with Themes

Thanks. I should write more frequently, but I’ve been away from my house in Italy for so long I can’t think of much to add. First post was written in 2005. The web has changed a lot since then.

james

Online

#4 2021-03-24 23:16:45

bici
Member
From: vancouver
Registered: 2004-02-24
Posts: 1,819
Website

Re: A problem with Themes

jrmartin wrote #329450:

Thanks. I should write more frequently, but I’ve been away from my house in Italy for so long I can’t think of much to add. First post was written in 2005. The web has changed a lot since then.

james

where about is yr house in Italy…


…. texted postive

Offline

#5 2021-03-24 23:35:17

jrmartin
Member
From: California | Italy
Registered: 2013-03-07
Posts: 108
Website

Re: A problem with Themes

We’re in far northern Tuscany, the poor, virtually tourist free part north of the marble mountains in a historic territory called La Lunigiana, in a tiny village called Piano di Collecchia. My nearest neighbors mostly make their own food, from prize winning salami to DOP honey. One of them, Enrico, produced one of Tuscany’s ten best olive oils according to some glossy mag. We seldom eat together a meal that isn’t produced with ingredients further from us then we can see by looking out the window. Health care costs us 350 euro a year. We really should be living there full time because life there is a bit of an adventure for us worth writing about, but got caught out when the plague hit.

james

Online

#6 2021-03-26 18:35:03

jrmartin
Member
From: California | Italy
Registered: 2013-03-07
Posts: 108
Website

Re: A problem with Themes

Ok, I can get to the page on the themes panel, but when I try to save the revised default page it looks like it’s saving but I don’t get the green confirmation and it isn’t saved.

Should I delete the page and make a new default page and start from there? The other pages seem to be fine.

james

Online

#7 2021-03-26 19:59:53

etc
Developer
Registered: 2010-11-11
Posts: 4,253
Website GitHub

Re: A problem with Themes

jrmartin wrote #329480:

Ok, I can get to the page on the themes panel, but when I try to save the revised default page it looks like it’s saving but I don’t get the green confirmation and it isn’t saved.

Could you open the browser console and inspect the server response when saving a page?

Offline

#8 2021-03-26 20:26:49

jrmartin
Member
From: California | Italy
Registered: 2013-03-07
Posts: 108
Website

Re: A problem with Themes

The next time I tried to save, it actually did. Then it stopped saving. I have no experience using the Browser Console, but this seems to repeat after I try an unsuccessful save:

context.runSafeWithoutClone called while context is inactive 4 ExtensionCommon.jsm:610
Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist. background.js:2
context.runSafeWithoutClone called while context is inactive

Online

#9 2021-03-26 20:42:37

etc
Developer
Registered: 2010-11-11
Posts: 4,253
Website GitHub

Re: A problem with Themes

This rather looks like some browser extension error and shouldn’t be related to page saves. You need to open Network console, do a save, click on the request and look at the response tab. It’s possible that you’ll see some errors there that could give us a clue.

That’s more or less how it looks, but we need Response and not Headers tab:

Offline

#10 2021-03-26 20:57:24

jrmartin
Member
From: California | Italy
Registered: 2013-03-07
Posts: 108
Website

Re: A problem with Themes

Thanks for your clarification. Got it all set up and…

After days of frustration, it now has saved properly 5 times in a row. I’m beginning to believe that this installation is haunted somehow.

j

Online

#11 2021-03-26 21:05:31

jrmartin
Member
From: California | Italy
Registered: 2013-03-07
Posts: 108
Website

Re: A problem with Themes

So the network console is blank when I do the page save and it works properly. Is that right?

Online

#12 2021-03-26 21:10:27

etc
Developer
Registered: 2010-11-11
Posts: 4,253
Website GitHub

Re: A problem with Themes

jrmartin wrote #329487:

So the network console is blank when I do the page save and it works properly. Is that right?

Blank? You mean the response? It should be something like

;
textpattern.Console.addMessage(["Pages updated: <strong>sitemap</strong>.",0]);
...

Otherwise you don’t get the green confirmation bar, though the page might still be saved.

Offline

Board footer

Powered by FluxBB