Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2020-10-28 16:15:10

jrmartin
Member
Registered: 2013-03-07
Posts: 88

Upgrading from 4.5.7

Just a quick question. I have a site using textpattern 4.5.7 and the diagnostics page reports: “New Textpattern version 4.8.2 available for download.”

I’ve been updating many sites recently, and it’s always told me that version 4.8.3 is available. Is there a problem going straight to 4.8.3 from here?

Thanks,

james

Offline

#2 2020-10-28 16:40:39

gaekwad
Admin
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,239

Re: Upgrading from 4.5.7

It’s possible (likely) that the version check is cached. It will poll https://textpattern.com/version.json if it’s a recent Textpattern, and check our legacy RPC server if it’s an older version.

Which raises an issue…I ran the 4.8.3 release process, and I didn’t update the RPC server version number…so that’s probably my fault.

I’ll update the build doc, and the RPC server, and that should fix it.

And yes, you should be OK with 4.8.3 as long as your server meets or exceeds the system requirements.

Offline

#3 2020-10-28 16:45:34

jrmartin
Member
Registered: 2013-03-07
Posts: 88

Re: Upgrading from 4.5.7

Thanks. I’m moving about 15 sites to a new server and updating them, and this was the first that didn’t report that 4.8.3 was available, although the link did go to the right page.

Offline

#4 2020-10-28 17:09:45

gaekwad
Admin
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,239

Re: Upgrading from 4.5.7

gaekwad wrote #326585:

I’ll update the build doc, and the RPC server, and that should fix it.

Now done. Thanks for the heads up, jrmartin!

Offline

Board footer

Powered by FluxBB