Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2020-07-17 14:52:22

dspears
Member
Registered: 2020-07-15
Posts: 10

[SOLVED] Diagnostics issues when putting site online

I’ve got my site running locally and I’m currently putting it online and I’m getting the following on the diagnostics page under admin:

Clean URL test failed.
File directory path is not writable: I’ve removed the URL to post it here
Temporary directory path is not writable: /home/gi3xmsi3/public_html/textpattern/tmp I’ve removed the URL to post it here

Clean URL test failed.
Before importing a copy of my local MySQL I did try running a clean install of 4.8.0 and it worked. The Diagnostics didn’t show this warning. But it is now.
Checking the site the URLs look clean and are similar to my local instance. Any ideas why this is showing?

The two directory warnings. I’ve checked the permissions on the server and they both have rwxrwxr-x (775) which is the same for the images directory. I’ve tried changing the permissions to something different and changed it back to rwxrwxr-x (775) but it still shows the issue. Do I need to update something?

Thank you in advance for your help.

Last edited by dspears (2020-07-17 14:54:23)

Offline

#2 2020-07-17 14:58:16

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,294
Website

Re: [SOLVED] Diagnostics issues when putting site online

Sites in local installs often behave differently to how they do in their eventual servers but here are some questions.

  1. Do you have the htaccess file in there?
  2. What txp version are you using?
  3. Can you post your diagnostics here?

Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | NeMe @ github | Covid-19; a resource
I do my best editing after I click on the submit button.

Offline

#3 2020-07-17 15:00:52

gaekwad
Admin
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,171

Re: [SOLVED] Diagnostics issues when putting site online

Is your Synology going to be internal only or external, too? I ask because clean URLs are doable with Textpattern on Nginx, they’re just a bit fiddly to achieve if you’re hacking around with a site config where it’s not very transparent. Can you see the Nginx site config on your Synology? If you can post it here (anonymised if you like), I can have a look and tell you what I’d change.

The permissions might be related to how Nginx runs and the actual owner:group of the files. Given that you uploaded the files (presumably) using FTP, chances are they are owned by your username and not the user that Nginx runs as (typically www-data). So, best thing to do here is to set the owner and group to Nginx, then the file permissions should take.

Try this in a terminal:

cd /to/your/textpattern/root/dir/
chown -R www-data:www-data ./*
chmod -R 775 ./*

That last line might not be necessary but wouldn’t hurt since it’ll rattle through and get all the files.

Last edited by gaekwad (2020-07-17 15:09:01)

Offline

#4 2020-07-17 15:50:36

dspears
Member
Registered: 2020-07-15
Posts: 10

Re: [SOLVED] Diagnostics issues when putting site online

Hi,

Here are some more details:

  • Yes, the .htaccess file is in there, it has the text pattern details.
  • Running version 4.8.0 of textpattern.
  • The synology drive is just internal. I’ve developed the site there. I’m moving it to some online space.

Regarding the diagnostic:

Textpattern version: 4.8.0 (3a700fa86044132fa6b97439de8272c7)
Last update: 2020-07-17 14:18:30
Site URL: nowthencreative.co.uk
Admin URL: nowthencreative.co.uk/textpattern
Document root: /home/gj3xmsi3/public_html
$path_to_site: /home/gj3xmsi3/public_html
Textpattern path: /home/gj3xmsi3/public_html/textpattern
Article URL pattern: section_title
Production status: testing
Temporary directory path: /home/gi3xmsi3/public_html/textpattern/tmp
PHP version: 7.2.22
GD Graphics Library: bundled (2.1.0 compatible); Supported formats: GIF, JPEG, PNG, WebP.
Server timezone: UTC
Server local time: 2020-07-17 15:44:11
Daylight Saving Time enabled?: 0
Automatically adjust Daylight Saving Time setting?: 0
Time zone (GMT offset in seconds): Europe/London (0)
MySQL: 5.6.39-cll-lve (MySQL Community Server (GPL)) 
Database server time: 2020-07-17 15:44:11
Database server time offset: 0 s
Database server timezone: SYSTEM
Database session timezone: SYSTEM
Locale: C
Site / Admin language: en-gb / en-gb
Web server: Apache
PHP server API: litespeed
RFC 2616 headers: 
Server OS: Linux 2.6.32-954.3.5.lve1.4.71.el6.x86_64
Admin-side theme: hive 4.8.0

Pre-flight check: 
------------------------

New Textpattern version 4.8.1 available for download.

Clean URL test failed.

File directory path is not writable: /home/gi3xmsi3/public_html/files
Temporary directory path is not writable: /home/gi3xmsi3/public_html/textpattern/tmp
------------------------

.htaccess file contents: 
------------------------

# BEGIN Textpattern

#DirectoryIndex index.php index.html

<IfModule mod_rewrite.c>
    RewriteEngine On

    # Enable the `FollowSymLinks` option below if it isn't already.
    #Options +FollowSymlinks

    #RewriteBase /relative/web/path/

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^(.+) - [PT,L]

    RewriteCond %{REQUEST_URI} !=/favicon.ico
    RewriteRule ^(.*) index.php

    RewriteCond %{HTTP:Authorization}  !^$
    RewriteRule .* - [E=REMOTE_USER:%{HTTP:Authorization}]
</IfModule>

<IfModule mod_mime.c>
    AddType image/svg+xml  svg svgz
    AddEncoding gzip       svgz
</IfModule>

# For additional Apache-compatible web server configuration settings to enhance
# site performance and security, we recommend:
# https://github.com/h5bp/server-configs-apache/blob/master/dist/.htaccess

# END Textpattern
AuthType Basic
AuthName "now then creative site"
AuthUserFile "/home/gj3xmsi3/.htpasswds/public_html/passwd"
require valid-user

------------------------

Edit by gaekwad: formatting on diags block.

Last edited by gaekwad (2020-07-17 15:51:54)

Offline

#5 2020-07-17 15:53:38

gaekwad
Admin
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,171

Re: [SOLVED] Diagnostics issues when putting site online

AuthType Basic
AuthName "now then creative site"
AuthUserFile "/home/gj3xmsi3/.htpasswds/public_html/passwd"
require valid-user

I wonder whether this is causing the clean URL check to bomb out. What happens if you comment this out?

Offline

#6 2020-07-17 15:58:30

dspears
Member
Registered: 2020-07-15
Posts: 10

Re: [SOLVED] Diagnostics issues when putting site online

Yep, As I was working on the site I had password protected the folder and the warning clean URL warning has disappeared.

Just need to sort the file path warnings out now.

Offline

#7 2020-07-17 15:59:47

gaekwad
Admin
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,171

Re: [SOLVED] Diagnostics issues when putting site online

What owner:group combo own the files and directories at the moment?

Edit: pretty sure Apache also uses www-data for user and group, so that stuff is still relevant.

Last edited by gaekwad (2020-07-17 16:00:17)

Offline

#8 2020-07-17 16:01:39

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,294
Website

Re: [SOLVED] Diagnostics issues when putting site online

Also, I would wait for an upgrade to 4.8.2 it eliminates some bugs.


Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | NeMe @ github | Covid-19; a resource
I do my best editing after I click on the submit button.

Offline

#9 2020-07-17 16:58:36

dspears
Member
Registered: 2020-07-15
Posts: 10

Re: [SOLVED] Diagnostics issues when putting site online

Regarding 2 warnings:

  • File directory path is not writable: /home/gi3xmsi3/public_html/files
  • Temporary directory path is not writable: /home/gi3xmsi3/public_html/textpattern/tmp Help

I’ve not used the command line much but I have used chmod to change the permissions and it still does not work.

Offline

#10 2020-07-17 17:02:46

dspears
Member
Registered: 2020-07-15
Posts: 10

Re: [SOLVED] Diagnostics issues when putting site online

Got it sort!

I checked the URLs in the preference/admin section for the file and temporary directory path and there was a mistake.

Everything seems to be working.

Thanks for your help.

Offline

Board footer

Powered by FluxBB