Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2019-06-17 13:10:59

anth
New Member
Registered: 2019-06-17
Posts: 2

Remove article

Hi, noob here (installed Textpattern yesterday).

I can write articles and they appear where I want them to.
But I can’t remove the original “welcome”-article that followed with the installation.
If I choose “hide”, it disappears from the section, but it still shows up under the Default (Home)-section.
Then I tried to set the expire date, but it still showed up.

Finally I had to delete the whole article to make it disappear.
How do I choose what articles to show in the Default (Home)-section on the site?
Or does alla articles always shows up there?

Offline

#2 2019-06-17 13:24:40

gaekwad
Admin
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 2,572

Re: Remove article

anth wrote #318503:

Hi, noob here (installed Textpattern yesterday).

Welcome!

I can write articles and they appear where I want them to.
But I can’t remove the original “welcome”-article that followed with the installation.
If I choose “hide”, it disappears from the section, but it still shows up under the Default (Home)-section.
Then I tried to set the expire date, but it still showed up.

Finally I had to delete the whole article to make it disappear.

The most straightforward way to remove an article completely: Content -> Articles -> check the article(s) in that list you want to delete -> use the “With n selected…” dropdown -> Delete.

How do I choose what articles to show in the Default (Home)-section on the site?
Or does alla articles always shows up there?

Presentation -> Sections -> find the section (e.g. Articles) -> find the “On default page” column -> select the Yes or No to toggle whether it appears on the front page.

Offline

#3 2019-06-17 13:41:16

jakob
Admin
From: Germany
Registered: 2005-01-20
Posts: 3,503
Website

Re: Remove article

anth wrote #318503:

But I can’t remove the original “welcome”-article that followed with the installation.
If I choose “hide”, it disappears from the section, but it still shows up under the Default (Home)-section.

Hi and welcome!

Hiding or altering the expiry date should definitely hide it completely, also from the home page. I just tested it on the current public demo site – https://release-demo.textpattern.co – and it worked as expected. I wonder if either you accidentally forget to resave after setting to hidden, or whether some browser caching was in effect?


TXP Builders – finely-crafted code, design and txp

Offline

#4 2019-06-17 14:11:52

anth
New Member
Registered: 2019-06-17
Posts: 2

Re: Remove article

jakob wrote #318505:

whether some browser caching was in effect?

That seems to be the problem. I usually update with F5, but that wasn’t enough. CTRL+F5 did thet trick though.

Offline

Board footer

Powered by FluxBB