Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#37 2012-11-05 13:38:25

Gallex
Member
Registered: 2006-10-08
Posts: 1,223

Re: [textile] Textile 2.4 now available.

uli wrote:

If I remember correctly, Textile does its work when an article is saved. That means that, if you want to profit from new versions’s features (or hacks), you need to re-save the articles in question. Have you done so?

nope. and you are right again, not working in any webserver without that fix ;)

Offline

#38 2012-11-05 15:18:18

net-carver
Archived Plugin Author
Registered: 2006-03-08
Posts: 1,648

Re: [textile] Textile 2.4 now available.

Gallex wrote:

nope. and you are right again, not working in any webserver without that fix ;)

That sounds right.

@all,

If you need to get in contact about textile stuff, it’s probably best to post an issue on github as I infrequently read the forum here now.

Last edited by net-carver (2012-11-05 15:20:18)


Steve

Offline

#39 2012-11-06 01:02:20

net-carver
Archived Plugin Author
Registered: 2006-03-08
Posts: 1,648

Re: [textile] Textile 2.4 now available.

@all

I’ve done some work on the link handling part of textile tonight as I’ve been becoming increasingly unhappy with it recently. If anyone would care to test what I’ve come up with so far (warning: still unoptimized) then please pull down this version of classTextile.php and see how it works out for you.

As always, thanks in advance to any testers!


Steve

Offline

#40 2012-11-09 12:29:05

Gallex
Member
Registered: 2006-10-08
Posts: 1,223

Re: [textile] Textile 2.4 now available.

tested…

…putted code below into article. it sends the data, but “thank’s” text won’t show up and form itself doesn’t disapper.

<txp:zem_contact to="name@gmail.com" label="Send answers" subject="Survey" thanks="Thanks.">
<txp:zem_contact_text label="Question 1" break="" />
<txp:zem_contact_text label="Question 2" break="" />
<txp:zem_contact_text label="Name" break="" />
<txp:zem_contact_email label="E-mail" break="" />
<txp:zem_contact_submit label="Send" />
</txp:zem_contact>

Offline

#41 2012-11-09 13:15:45

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,774
Website GitHub Twitter

Re: [textile] Textile 2.4 now available.

did you put notextile.. in the beginning of the code?


Yiannis
——————————
neme.org | hblack.net | State Machines | NeMe @ github
I do my best editing after I click on the submit button.

Offline

#42 2012-11-09 13:32:44

Gallex
Member
Registered: 2006-10-08
Posts: 1,223

Re: [textile] Textile 2.4 now available.

colak wrote:

did you put notextile.. in the beginning of the code?

no. but tryed with notextile.. and, same.

it’s just so wierd. at the homepage in the same webserver, but in different subfolder – and no problems…
p.s. this ‘problematic’ homepage is also installed into subfolder.

Offline

#43 2012-11-09 13:49:07

Gallex
Member
Registered: 2006-10-08
Posts: 1,223

Re: [textile] Textile 2.4 now available.

reinstalled with latest 4.5.2 version, created new article, putted code into it and, nothing changed… :)

p.s. debugging mode shows no errors
p.p.s …and the page i’m talking about

Last edited by Gallex (2012-11-09 13:56:01)

Offline

#44 2012-11-09 15:11:01

GugUser
Member
From: Quito (Ecuador)
Registered: 2007-12-16
Posts: 1,467

Re: [textile] Textile 2.4 now available.

Gallex wrote:

…and the page i’m talking about

I see the form correctly and it seems to work.

Last edited by GugUser (2012-11-09 15:11:16)

Offline

#45 2012-11-09 15:31:59

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,774
Website GitHub Twitter

Re: [textile] Textile 2.4 now available.

I tested your form and it does not show the thanks message. Did you receive the email though?


Yiannis
——————————
neme.org | hblack.net | State Machines | NeMe @ github
I do my best editing after I click on the submit button.

Offline

#46 2012-11-09 22:50:22

net-carver
Archived Plugin Author
Registered: 2006-03-08
Posts: 1,648

Re: [textile] Textile 2.4 now available.

Hi Gallex, thank you for trying this out.

I’ve run your code example through the link-detection-rewrite branch which seems to convert it cleanly. For now, could you…

  1. try using the thanks_form attribute instead of the thanks text and see if that works?
  2. try putting your form into a static section instead of into an article?

Thank you!


Steve

Offline

#47 2012-11-12 08:19:15

Gallex
Member
Registered: 2006-10-08
Posts: 1,223

Re: [textile] Textile 2.4 now available.

colak wrote:

I tested your form and it does not show the thanks message. Did you receive the email though?

yes i did.

net-carver wrote:

try using the thanks_form attribute instead of the thanks text and see if that works?

nope.

try putting your form into a static section instead of into an article?

working

Offline

#48 2012-11-27 11:20:39

Gallex
Member
Registered: 2006-10-08
Posts: 1,223

Re: [textile] Textile 2.4 now available.

Gallex wrote:

putted code below into article. it sends the data, but “thank’s” text won’t show up and form itself doesn’t disapper.

<txp:zem_contact to=“name@gmail.com” label=“Send answers” subject=“Survey” thanks=“Thanks.”>
<txp:zem_contact_text label=“Question 1” break=”“ />
<txp:zem_contact_text label=“Question 2” break=”“ />
<txp:zem_contact_text label=“Name” break=”“ />
<txp:zem_contact_email label=“E-mail” break=”“ />
<txp:zem_contact_submit label=“Send” />
</txp:zem_contact>

found the devil! it was typo inside a <txp:rah_metas…/> code in the head section!
fixed it and using the code above inside an article is possible again. problem solved.

Offline

Board footer

Powered by FluxBB