Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#31 2012-10-29 08:35:31

Gallex
Member
Registered: 2006-10-08
Posts: 1,160

Re: [textile] Textile 2.4 now available.

it fixed my classname issue i describe here too. thank’s

Offline

#32 2012-11-01 14:15:24

Gallex
Member
Registered: 2006-10-08
Posts: 1,160

Re: [textile] Textile 2.4 now available.

well, well, well, looks like i was delighted too early. still doesn’t add class names like this: "(various fancybox.iframe)Grizzly Bear - Yet again":http://www.youtube.com/embed/AuG9i5cwGW0?rel=0;autoplay=1 in some webhosting servers. steve, can you investigate it?

Offline

#33 2012-11-04 02:39:48

net-carver
Archived Plugin Author
Registered: 2006-03-08
Posts: 1,648

Re: [textile] Textile 2.4 now available.

@pompilos

Jose, it seems the change I made for you affects the encoding of other URL schemes like “tel” and “mailto” which can both have literal meanings for ‘+’ characters in them and which will still require encoding. I’ve updated the dev branch to reflect this and would appreciate if you could try this version out and let me know if it still works for you.

@Gallex

…steve, can you investigate it?

It looks like you already posted a good solution to your own issue here. The changes I made addressing Jose’s problem don’t touch the part of the codebase affecting the periods in class names. I removed period support from classes for a reason but I’ll reconsider adding them back into the mix.


Steve

Offline

#34 2012-11-05 10:15:05

Gallex
Member
Registered: 2006-10-08
Posts: 1,160

Re: [textile] Textile 2.4 now available.

steve, i found another bug caused by your latest fix. links inside tables not working without spaces before and after code. no problems in older versions.

not working

|Laupäev|Kokkuleppel|Algajad|Inspira|"Jelena":http//www.lena.ee|
|Laupäev|Kokkuleppel|Edasijõudnud|Inspira|"Jelena":http//www.lena.ee|

working

|Laupäev|Kokkuleppel|Algajad|Inspira| "Jelena":http//www.lena.ee |
|Laupäev|Kokkuleppel|Edasijõudnud|Inspira| "Jelena":http//www.lena.ee |

Last edited by Gallex (2012-11-06 08:22:39)

Offline

#35 2012-11-05 11:48:37

Gallex
Member
Registered: 2006-10-08
Posts: 1,160

Re: [textile] Textile 2.4 now available.

net-carver wrote:

It looks like you already posted a good solution to your own issue here. The changes I made addressing Jose’s problem don’t touch the part of the codebase affecting the periods in class names. I removed period support from classes for a reason but I’ll reconsider adding them back into the mix.

only wierd thing that in some webservers those complicated classnames working without uli’s fix…

Offline

#36 2012-11-05 12:45:31

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,225

Re: [textile] Textile 2.4 now available.

Gallex wrote:

only wierd thing that in some webservers those complicated classnames working without uli’s fix…

If I remember correctly, Textile does its work when an article is saved. That means that, if you want to profit from new versions’s features (or hacks), you need to re-save the articles in question. Have you done so?

IIRC2: Someone was so kind to write a script that would re-save all articles in an installation at once. I just don’t have a link at hand.


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#37 2012-11-05 13:38:25

Gallex
Member
Registered: 2006-10-08
Posts: 1,160

Re: [textile] Textile 2.4 now available.

uli wrote:

If I remember correctly, Textile does its work when an article is saved. That means that, if you want to profit from new versions’s features (or hacks), you need to re-save the articles in question. Have you done so?

nope. and you are right again, not working in any webserver without that fix ;)

Offline

#38 2012-11-05 15:18:18

net-carver
Archived Plugin Author
Registered: 2006-03-08
Posts: 1,648

Re: [textile] Textile 2.4 now available.

Gallex wrote:

nope. and you are right again, not working in any webserver without that fix ;)

That sounds right.

@all,

If you need to get in contact about textile stuff, it’s probably best to post an issue on github as I infrequently read the forum here now.

Last edited by net-carver (2012-11-05 15:20:18)


Steve

Offline

#39 2012-11-06 01:02:20

net-carver
Archived Plugin Author
Registered: 2006-03-08
Posts: 1,648

Re: [textile] Textile 2.4 now available.

@all

I’ve done some work on the link handling part of textile tonight as I’ve been becoming increasingly unhappy with it recently. If anyone would care to test what I’ve come up with so far (warning: still unoptimized) then please pull down this version of classTextile.php and see how it works out for you.

As always, thanks in advance to any testers!


Steve

Offline

#40 2012-11-09 12:29:05

Gallex
Member
Registered: 2006-10-08
Posts: 1,160

Re: [textile] Textile 2.4 now available.

tested…

…putted code below into article. it sends the data, but “thank’s” text won’t show up and form itself doesn’t disapper.

<txp:zem_contact to="name@gmail.com" label="Send answers" subject="Survey" thanks="Thanks.">
<txp:zem_contact_text label="Question 1" break="" />
<txp:zem_contact_text label="Question 2" break="" />
<txp:zem_contact_text label="Name" break="" />
<txp:zem_contact_email label="E-mail" break="" />
<txp:zem_contact_submit label="Send" />
</txp:zem_contact>

Offline

Board footer

Powered by FluxBB