Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2010-11-04 15:19:40

wet
Developer
From: Lenzing, Austria
Registered: 2005-06-06
Posts: 3,267
Website

Feedback for the Textpattern 4.3.0 release

Please provide any feedback, reports and success stories related to the Textpattern 4.3.0 release in this thread.

Offline

#2 2010-11-04 15:29:39

net-carver
Archived Plugin Author
Registered: 2006-03-08
Posts: 1,648

Re: Feedback for the Textpattern 4.3.0 release

Here at last — thank you Robert, Sam & Stef!


Steve

Offline

#3 2010-11-04 15:53:54

GugUser
Member
From: Quito (Ecuador)
Registered: 2007-12-16
Posts: 1,467

Re: Feedback for the Textpattern 4.3.0 release

I am very pleased, many thanks to all involved.

Offline

#4 2010-11-04 16:00:11

the_ghost
Plugin Author
From: Minsk, The Republic of Belarus
Registered: 2007-07-26
Posts: 907
Website

Re: Feedback for the Textpattern 4.3.0 release

/readme.txt starts with “Textpattern 4.2.0”


Providing help in hacking ATM! Come to courses and don’t forget to bring us notebook and hammer! What for notebook? What a kind of hacker you are without notebok?

Offline

#5 2010-11-04 16:23:00

wet
Developer
From: Lenzing, Austria
Registered: 2005-06-06
Posts: 3,267
Website

Re: Feedback for the Textpattern 4.3.0 release

No more.

Offline

#6 2010-11-04 16:41:20

the_ghost
Plugin Author
From: Minsk, The Republic of Belarus
Registered: 2007-07-26
Posts: 907
Website

Re: Feedback for the Textpattern 4.3.0 release

Can’t understand – was little confused by renaming image_list to images. After renaming all calls everything works perfect. Very pleased that now we can build simple galleries without plugins.

Perfect work!


Providing help in hacking ATM! Come to courses and don’t forget to bring us notebook and hammer! What for notebook? What a kind of hacker you are without notebok?

Offline

#7 2010-11-04 16:57:25

zero
Member
From: Lancashire
Registered: 2004-04-19
Posts: 1,445
Website

Re: Feedback for the Textpattern 4.3.0 release

in css, n is deprecated, replaced by name but in Tag Builder, it still uses n


Gud One Blog
Wondrous Healing Wondrous ways to a healthy old age

Offline

#8 2010-11-05 16:17:08

redbot
Plugin Author
Registered: 2006-02-14
Posts: 1,410

Re: Feedback for the Textpattern 4.3.0 release

Even if I still haven’t had the time to install it I want to congratulate for another great release. Thank you all!

Offline

#9 2010-11-06 02:59:19

GugUser
Member
From: Quito (Ecuador)
Registered: 2007-12-16
Posts: 1,467

Re: Feedback for the Textpattern 4.3.0 release

I have updated all my TxP websites to the version 4.3. That was very easy and almost without problems. I detect two bugs, as I believe.

In the version 4.2 I used the very useful upm_image plug-in in the following manner:

<txp:upm_article_image form="foto-thumbnail" />

Form “foto-thumbnail”:

<a href="<txp:upm_img_full_url />" rel="large" title="<txp:upm_img_caption />">
	<img src="<txp:upm_img_thumb_url />" width="<txp:upm_img_thumb_width />" height="<txp:upm_img_thumb_height />" alt="<txp:upm_img_alt />" />
</a>

For the TxP Version 4.3 I changed this in:

<txp:images auto_detect="article" form="foto-thumbnail" />

I work with <txp:images /> because in some article image fields exists more than one numbers. The form “foto-thumbnail” contains:

<a href="<txp:image_url />" rel="large" title="<txp:image_info />">
	<img src="<txp:image_url thumbnail="1" />" width="<txp:image_info type="thumb_w" />" height="<txp:image_info type="thumb_h" />" alt="<txp:image_info type="alt" />" />
</a>

In another context, I use a different form with the list-element (I know, I could make it shorter, with wraptag="ul" class="fotos" break="li", but this here serves to show the bug):

<ul class="fotos"><txp:images auto_detect="article" form="galeria-miniaturas" /></ul>

And the form “galeria-miniaturas”:

<li><a href="<txp:image_url />" rel="ampliar-galeria" title="<txp:image_info />">
	<img src="<txp:image_url thumbnail="1" />" width="<txp:image_info type="thumb_w" />" height="<txp:image_info type="thumb_h" />" alt="<txp:image_info type="alt" />" />
</a></li>

In this context, <txp:images auto_detect="article" form="galeria-miniaturas" /> need a break="", although in the Textbook is written for break="tag text" “default: unset”.

This bug may not be important.

But the following second bug seems to me more important:

I noticed that for some pictures the widths and heights of the thumbnails have the values "0". After a long examination, I found out that this affected only the photos added to TxP before the version 4.2.

I hope that there is a solution for this problem, because it affects hundreds of photos.

Offline

#10 2010-11-06 04:25:03

MattD
Plugin Author
From: Monterey, California
Registered: 2008-03-21
Posts: 1,254
Website

Re: Feedback for the Textpattern 4.3.0 release

GugUser wrote:

I noticed that for some pictures the widths and heights of the thumbnails have the values "0". After a long examination, I found out that this affected only the photos added to TxP before the version 4.2.

I hope that there is a solution for this problem, because it affects hundreds of photos.

There is a plugin to fix this


My Plugins

Piwik Dashboard, Google Analytics Dashboard, Minibar, Article Image Colorpicker, Admin Datepicker, Admin Google Map, Admin Colorpicker

Offline

#11 2010-11-06 12:54:36

GugUser
Member
From: Quito (Ecuador)
Registered: 2007-12-16
Posts: 1,467

Re: Feedback for the Textpattern 4.3.0 release

MattG

Thank you for your very helpful tip, and many thanks to Jeff for the great plug-in.

Strange is that the problem was not noticeable in TxP 4.2 and with the upm_image plug-in.

Offline

#12 2010-11-13 22:17:41

alan
Member
From: earth
Registered: 2006-04-20
Posts: 14

Re: Feedback for the Textpattern 4.3.0 release

Have any changes/improvements been made to the Wordpress importer? Having issues in 4.2.0 with imported WP posts being truncated.

Suggestions or links welcome!

Thanks, Alan

Offline

Board footer

Powered by FluxBB