Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2009-09-20 18:31:49

sarah
Member
Registered: 2009-08-13
Posts: 46

[Solved] .htaccess and 000webhost.com

When I click on “view site”, why doesn’t my web page appear, but the list of folders in my directory instead?

My website address is: nonameyet.net16.net.

My article address is: http://nonameyet.net16.net/textpattern-4.2.0/textpattern/index.php

Thanks.

Last edited by els (2009-09-21 20:17:22)

Offline

#2 2009-09-20 19:01:25

els
Moderator
From: The Netherlands
Registered: 2004-06-06
Posts: 7,458

Re: [Solved] .htaccess and 000webhost.com

sarah wrote:

My website address is: nonameyet.net16.net.

No, I don’t think it is. http://nonameyet.net16.net/textpattern-4.2.0/index.php works, so if you enter nonameyet.net16.net/textpattern-4.2.0 in Admin > Preferences > Site URL, and if you change this line in .htaccess

#Options -Indexes

to

Options -Indexes

http://nonameyet.net16.net/textpattern-4.2.0/ will work too (as well as your CSS).

Offline

#3 2009-09-20 19:19:47

sarah
Member
Registered: 2009-08-13
Posts: 46

Re: [Solved] .htaccess and 000webhost.com

Hi Els,

Thanks for your response!

May I ask, if I want my site to be accessible at: nonameyet.net16.net, what do I have to change, and to what?

Thanks for the trouble.

Offline

#4 2009-09-20 21:26:03

els
Moderator
From: The Netherlands
Registered: 2004-06-06
Posts: 7,458

Re: [Solved] .htaccess and 000webhost.com

Hi Sarah, in that case you need to move your Textpattern files and folders one level up. You probably uploaded the ‘textpattern-4.2.0’ folder to your server, but you should have uploaded only that folder’s content.
If you do that, you should also change the paths in config.php (take out the /textpattern-4.2.0 part), and in Admin > Preferences > Advanced change the paths to the files and temp directory accordingly. And of course your Site URL in Basic Preferences.

Offline

#5 2009-09-21 03:42:13

sarah
Member
Registered: 2009-08-13
Posts: 46

Re: [Solved] .htaccess and 000webhost.com

Hi Els,

Thank you so much for your help and instructions.

What I have done:

1. I have moved my directory up one level by removing the textpattern 4.2.0 folder

2. I have changed the part of my .htaccess file from “#Options -Indexes” to “#Options -Indexes”

3. I have changed my site URL address to nonameyet.net16.net

All is well, apart from one thing. My site is only accesible by typing in: nonameyet.net16.net/ index.php , and not nonameyet.net16.net.

Could you help me out on the last hurdle?

Thanks!

Offline

#6 2009-09-21 14:20:57

els
Moderator
From: The Netherlands
Registered: 2004-06-06
Posts: 7,458

Re: [Solved] .htaccess and 000webhost.com

Does this FAQ help?

Offline

#7 2009-09-21 15:16:25

sarah
Member
Registered: 2009-08-13
Posts: 46

Re: [Solved] .htaccess and 000webhost.com

Hi Els, I followed the instructs on the FAQ page, but the following message is what I’m getting:

*Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, cpanel@hosting24.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.*

Now, I’ve now removed two “#” from my .htacess file, but to no avail….

I also sought help from my web hosting providers forum. I did find this following thread, which I followed, but to no avail again: http://www.000webhost.com/forum/web-programming/8441-problems-my-site.html

Offline

#8 2009-09-21 15:24:58

sarah
Member
Registered: 2009-08-13
Posts: 46

Re: [Solved] .htaccess and 000webhost.com

Hi again,

I’ve found a thread on my web hosting providers thread: http://www.000webhost.com/forum/customer-assistance/7848-textpattern-problem.html

The problem I’m having seems to be common for those who are using textpattern and my webhosting provider, but there is a yet to be found a solution….

Offline

#9 2009-09-21 15:36:47

els
Moderator
From: The Netherlands
Registered: 2004-06-06
Posts: 7,458

Re: [Solved] .htaccess and 000webhost.com

Hi Sarah, can you post your diagnostics? We can still try a couple of things.

Offline

#10 2009-09-21 17:52:55

sarah
Member
Registered: 2009-08-13
Posts: 46

Re: [Solved] .htaccess and 000webhost.com

Okay. My diagnostics are as follows:

Pre-flight check

Image directory is not writable: /home/a8390429/public_html/images
File directory path is not writable: /home/a8390429/public_html/files

/home/a8390429/public_html/textpattern/setup/ still exists

The following PHP functions (which may be necessary to run Textpattern) are disabled on your server: show_source, set_time_limit, ini_restore, mysql_list_dbs, ini_alter, pfsockopen, openlog, syslog, symlink, link, chgrp, leak, escapeshellcmd, apache_child_terminate, apache_get_modules, apache_get_version, apache_getenv, apache_note, apache_setenv, virtual, mb_send_mail

Diagnostic info

Warning: apache_get_version() has been disabled for security reasons in /home/a8390429/public_html/textpattern/include/txp_diag.php on line 493

Textpattern version: 4.2.0 (r3275)
Last Update: 2009-09-20 17:12:40/2009-09-21 01:45:10
Document root: /usr/local/apache/htdocs ()
$path_to_site: /home/a8390429/public_html
Textpattern path: /home/a8390429/public_html/textpattern
Permanent link mode: messy
open_basedir: /home/:/usr/lib/php:/tmp
upload_tmp_dir: /tmp
Temporary directory path: /tmp
Site URL: nonameyet.net16.net
PHP version: 5.2.10
GD Image Library: bundled (2.0.34 compatible); supported formats: GIF, JPG, PNG.
Server TZ: America/New_York
Server Local Time: 2009-09-21 13:47:58
DST enabled?: 0
Automatically adjust DST setting?: 0
Time Zone: America/Caracas (-16200)
MySQL: 5.0.81-community
Locale: en_GB.UTF-8
Server: Apache
Apache version:
PHP Server API: apache2handler
RFC 2616 headers:
Server OS: Linux 2.6.29.5-grsec-hostnoc-4.2.0-i386-libata
Admin-side theme: classic 4.2.0

Pre-flight check:
————————————
Image directory is not writable: /home/a8390429/public_html/images
File directory path is not writable: /home/a8390429/public_html/files
/home/a8390429/public_html/textpattern/setup/ still exists
The following PHP functions (which may be necessary to run Textpattern) are disabled on your server: show_source, set_time_limit, ini_restore, mysql_list_dbs, ini_alter, pfsockopen, openlog, syslog, symlink, link, chgrp, leak, escapeshellcmd, apache_child_terminate, apache_get_modules, apache_get_version, apache_getenv, apache_note, apache_setenv, virtual, mb_send_mail
————————————

.htaccess file contents:
————————————

DirectoryIndex index.php index.html

#Options +FollowSymLinks
Options -Indexes

<IfModule mod_rewrite.c>
	RewriteEngine On
	#RewriteBase /relative/web/path/

	RewriteCond %{REQUEST_FILENAME} -f [OR]
	RewriteCond %{REQUEST_FILENAME} -d
	RewriteRule ^(.+) - [PT,L]

	RewriteCond %{REQUEST_URI} !=/favicon.ico
	RewriteRule ^(.*) index.php

	RewriteCond %{HTTP:Authorization}  !^$
	RewriteRule .* - [E=REMOTE_USER:%{HTTP:Authorization}]
</IfModule>

#php_value register_globals 0

————————————

Last edited by ruud (2009-09-21 18:07:24)

Offline

#11 2009-09-21 18:21:34

ruud
Developer emeritus
From: a galaxy far far away
Registered: 2006-06-04
Posts: 5,068
Website

Re: [Solved] .htaccess and 000webhost.com

This article from the 000webhost.com FAQ might help.

Edit the .htaccess file and replace #RewriteBase /relative/web/path/ with RewriteBase /

Offline

#12 2009-09-21 19:11:54

sarah
Member
Registered: 2009-08-13
Posts: 46

Re: [Solved] .htaccess and 000webhost.com

Hi, thanks for the tip. But now I can’t even access textpattern….

I’m now getting a 500 internal server error message…

Offline

Board footer

Powered by FluxBB