Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2008-01-25 20:00:06

Mary
Sock Enthusiast
Registered: 2004-06-27
Posts: 6,236

Admin-side plugin privileges are now required

Folks, please make sure your admin-side plugins use privileges. As of 4.0.6 they will be required.

Reading material:
http://forum.textpattern.com/viewtopic.php?pid=64600#p64600
http://svn.textpattern.com/development/4.0-plugin-template/zem_plugin_example.php
http://textbook.textpattern.net/wiki/index.php?title=User_Roles_and_Permissions
http://rpc.textpattern.com/help/index.php?item=about_privileges&language=en-gb

Last edited by Mary (2008-01-25 20:31:26)

Offline

#2 2008-01-25 20:08:54

Manfre
Plugin Author
From: North Carolina
Registered: 2004-05-22
Posts: 588
Website

Re: Admin-side plugin privileges are now required

Will the core test for the existence of privilege checks? Is a naming convention going to be enforced, where by allowing the core to check for required privileges?

Offline

#3 2008-01-25 20:13:38

Mary
Sock Enthusiast
Registered: 2004-06-27
Posts: 6,236

Re: Admin-side plugin privileges are now required

Test?

Naming convention? Did you read link #1 or #2?

Offline

#4 2008-01-25 20:58:53

Manfre
Plugin Author
From: North Carolina
Registered: 2004-05-22
Posts: 588
Website

Re: Admin-side plugin privileges are now required

Let me rephrase for you.

Will the 4.0.6 core have any specific code changes to enforce this requirement?

Offline

#5 2008-01-25 21:05:32

Mary
Sock Enthusiast
Registered: 2004-06-27
Posts: 6,236

Re: Admin-side plugin privileges are now required

Yes.

Offline

#6 2008-01-25 21:16:16

ruud
Developer emeritus
From: a galaxy far far away
Registered: 2006-06-04
Posts: 5,068
Website

Re: Admin-side plugin privileges are now required

Admin-side plugins that are currently working for non-publishers, should be okay.
Only admin-side plugins, where only publishers are privileged and which do not use add_privs (or are using it incorrectly), are affected.

Offline

#7 2008-01-25 22:38:57

Manfre
Plugin Author
From: North Carolina
Registered: 2004-05-22
Posts: 588
Website

Re: Admin-side plugin privileges are now required

Thanks for the explanation ruud. It seems my automatic SVN notifications have stopped functioning.

Offline

Board footer

Powered by FluxBB