Textpattern CMS support forum

You are not logged in. Register | Login | Help

#31 2008-01-14 14:44:46

swf
Plugin Author
From: Saskatoon, Saskatchewan Canada
Registered: 2004-06-21
Posts: 109
Website

Re: asv_tumblelog

I sent you my email unfortunately the address is spam@…. so it will likely jump into your spam folder.
I’ve tried adding new twitter posts after running the script and it still doesn’t import any of them. Hopefully this new version will fix my problem.
Thank you

Offline

#32 2008-01-18 13:37:42

swf
Plugin Author
From: Saskatoon, Saskatchewan Canada
Registered: 2004-06-21
Posts: 109
Website

Re: asv_tumblelog

i still fifn’t get your email, but I’ve had some problems with my mail server lately so you can try alteeffour[at]gmil[dot]com
Thank you

Offline

#33 2008-01-24 13:54:02

mapu
Member
From: Munich, Germany
Registered: 2004-03-16
Posts: 141

Re: asv_tumblelog

tmonkey wrote:

Sorry, stupid n00b question. It doesn’t recognize my simplepie.inc install path.

The only path that worked is straight “simplepie.inc” (it’s in the textpattern directory, I tested it and the demo works). asv_tumblelog saved without throwing an error but when I tried to update the feed, it gave me this error:

“A problem occured while loading the plugin: asv_tumblelog -> Warning: require_once(simplepie.inc) [function.require-once]: failed to open stream: No such file or directory on line 1480

Fatal error: require_once() [function.require]: Failed opening required ‘simplepie.inc’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/redub3/public_html/irwinchen/kenyajournal/textpattern/lib/txplib_misc.php(534) : eval()’d code on line 1480”

I’m getting the same error when updating a feed.

Offline

#34 2008-02-02 22:26:25

michaelkpate
Moderator
From: Avon Park, FL
Registered: 2004-02-24
Posts: 1,169
Website

Re: asv_tumblelog

swf wrote:

can anyone help with my problem? I don’t evn know where to start looking to figure out why it would say not importing

Was this problem ever fixed? I was trying to setup the plugin on my personal site hosted by Dreamhost and I am experiencing the same issue.

Offline

#35 2008-02-02 22:51:06

swf
Plugin Author
From: Saskatoon, Saskatchewan Canada
Registered: 2004-06-21
Posts: 109
Website

Re: asv_tumblelog

No I still can’t import and am on Dreamhost too.

Offline

#36 2008-02-03 04:14:37

michaelkpate
Moderator
From: Avon Park, FL
Registered: 2004-02-24
Posts: 1,169
Website

Re: asv_tumblelog

I think I isolated the problem down to this bit of code:

//Check to see if the article has already been imported
$exists = safe_count(‘textpattern’, “Title = ‘“.$out[‘title’].”’ AND Posted=$when AND Section=’$section’”);

Apparently $exists is always set to the wrong value. Why it is doing that I am not sure.

Offline

#37 2008-02-08 13:25:50

swf
Plugin Author
From: Saskatoon, Saskatchewan Canada
Registered: 2004-06-21
Posts: 109
Website

Re: asv_tumblelog

I tried to install the plugin on my local mamp server and it doesn’t import feeds either. Could it be a problem with the newest version of simplepie?

Offline

#38 2008-02-09 18:06:54

deliberatepixel
New Member
Registered: 2008-02-09
Posts: 1

Re: asv_tumblelog

Last edited by deliberatepixel (2008-05-04 22:26:27)

Offline

#39 2008-02-28 14:40:50

swf
Plugin Author
From: Saskatoon, Saskatchewan Canada
Registered: 2004-06-21
Posts: 109
Website

Re: asv_tumblelog

I have got the plugin to work on my local mamp installation, but only with a flickr feed, twitter doesn’t work.
The flickr feed only works to import images, but it doesn’t create the articles for the images. below is the code the import spits out.
I’m going to be gone for a few days next week and want to be able to send twitter and flickr updates to my site while I’m away so I would really like to get this fixed.

A problem occured while loading the plugin: asv_tumblelog -> Warning: imagecreatetruecolor() [function.imagecreatetruecolor]: Invalid image dimensions on line 211

A problem occured while loading the plugin: asv_tumblelog -> Warning: imagecopyresampled(): supplied argument is not a valid Image resource on line 212

A problem occured while loading the plugin: asv_tumblelog -> Warning: imagesx(): supplied argument is not a valid Image resource on line 363

A problem occured while loading the plugin: asv_tumblelog -> Warning: imagesy(): supplied argument is not a valid Image resource on line 363

A problem occured while loading the plugin: asv_tumblelog -> Warning: imagecreatetruecolor() [function.imagecreatetruecolor]: Invalid image dimensions on line 366

A problem occured while loading the plugin: asv_tumblelog -> Warning: imagecopy(): supplied argument is not a valid Image resource on line 377

A problem occured while loading the plugin: asv_tumblelog -> Warning: imagecopymerge(): supplied argument is not a valid Image resource on line 378

A problem occured while loading the plugin: asv_tumblelog -> Warning: imagecopymerge(): supplied argument is not a valid Image resource on line 379

A problem occured while loading the plugin: asv_tumblelog -> Warning: imagecopymerge(): supplied argument is not a valid Image resource on line 380

A problem occured while loading the plugin: asv_tumblelog -> Warning: imagecopymerge(): supplied argument is not a valid Image resource on line 381

A problem occured while loading the plugin: asv_tumblelog -> Warning: imagecopymerge(): supplied argument is not a valid Image resource on line 382

A problem occured while loading the plugin: asv_tumblelog -> Warning: imagecopymerge(): supplied argument is not a valid Image resource on line 383

A problem occured while loading the plugin: asv_tumblelog -> Warning: imagecopymerge(): supplied argument is not a valid Image resource on line 384

A problem occured while loading the plugin: asv_tumblelog -> Warning: imagecopymerge(): supplied argument is not a valid Image resource on line 385

A problem occured while loading the plugin: asv_tumblelog -> Warning: imagejpeg(): supplied argument is not a valid Image resource on line 248

A problem occured while loading the plugin: asv_tumblelog -> Warning: imagedestroy(): supplied argument is not a valid Image resource on line 256

	image_uploaded: Sunset at dog park

A problem occured while loading the plugin: asv_tumblelog -> User_Warning: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '
						uid             = '56bf6df2aa39f0500c9428bf2b27a288',
						feed_time  ' at line 21
insert into textpattern set Title           = 'Sunset at dog park',
						Body            = '

Scott Woods-Fehr posted a photo:
\n

\"Sunset
',
						Body_html       = '

Scott Woods-Fehr posted a photo:
\n

\"Sunset
',
						Excerpt         = '',
						Excerpt_html    = '',
						Image           = '23',
						Keywords        = '',
						Status          =  4,
						Posted          =  from_unixtime(1204209088),
						LastMod         =  now(),
						AuthorID        = 'scott',
						Section         = 'about',
						Category1       = 'Photo',
						Category2       = '',
						textile_body    =  0,
						textile_excerpt =  0,
						Annotate        =  1,
						override_form   = 'notes_photo',
						url_title       = '',
						custom_3 		= 'http://www.flickr.com/photos/woodsfehr/2297611353/',
						AnnotateInvite  = ,
						uid             = '56bf6df2aa39f0500c9428bf2b27a288',
						feed_time       = from_unixtime(1204209088), custom_3 = '3' on line 81@

Offline

#40 2008-04-08 16:06:08

merz1
Member
From: Hamburg
Registered: 2006-05-04
Posts: 994
Website

Re: asv_tumblelog

Installation went fine so far, but…

Setup problems with TXP 4.0.6

Simplepie.inc 1.1.1 is in homepage/textpattern/lib/simplepie.inc

Setup won’t accept ./textpattern/lib/simplepie.inc or textpattern/lib/simplepie.inc. Error: ./textpattern/lib/simplepie.inc not found. Settings saved.

Accepted path is ./lib/simplepie.inc or lib/simplepie.inc (or absolute, see below). I put it in custom2.

But clicking manually update feeds results in two errors:

1. Error

Ein Fehler trat auf beim Laden des Plugins: asv_tumblelog -> Warning: asv_rssgrab(lib/simplepie.inc) [function.asv-rssgrab]: failed to open stream: Datei oder Verzeichnis nicht gefunden on line 1480

Translation: Error when loading the plugin. (…) File or directory not found (…).

2. Error

Fatal error: asv_rssgrab() [function.require]: Failed opening required ‘lib/simplepie.inc’ (include_path=’.:/usr/lib/php’) in <shortened absolute path>/textpattern/lib/txplib_misc.php(574) : eval()’d code on line 1480

OK, trying absolute path (Ahemm) which is accepted. No, same errors.

Feed ID Field is empty. Using it (custom3) makes no difference.

What is (include_path=’.:/usr/lib/php’) trying to tell me? Doing a ‘cd .:/usr/lib/php’ via FTP shell results in:

  • CWD .:/usr/lib/php
  • 550 .:/usr/lib/php: No such file or directory

Btw: If I delete my test feeds the error stays the same. I expected ‘no feeds added’ or a similar error message.

Posting via Bookmarklet: Works but has some output issues. Article form is used double. To-Be resolved later :)


Get all online mentions of Textpattern via OPML subscription: TXP Info Sources: Textpattern RSS feeds as dynamic OPML

Offline

Board footer

Powered by FluxBB