Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2006-11-16 08:35:55

Mary
Sock Enthusiast
Registered: 2004-06-27
Posts: 6,236

[plugin] [ORPHAN] upm_file_popper: A file picker, for use with upm_file.

upm_file_popper

An easy-to-use file picker, for use with upm_file.

Last edited by uli (2013-01-24 17:15:03)

Offline

#2 2007-01-05 04:46:02

nardo
Member
From: tuvalahiti
Registered: 2004-04-22
Posts: 741

Re: [plugin] [ORPHAN] upm_file_popper: A file picker, for use with upm_file.

install failed with the following msg:

Warning: Data too long for column 'help' at row 1 insert into txp_plugin set name = 'upm_file_popper', status = 0, type = 1, author = 'Mary Fredborg', author_uri = 'http://utterplush.com/txp-plugins/upm_file_popper', version = '0.1', description = 'An easy-to-use file picker, for use with upm_file.', help = '
upm_file_popper
\n\n

This plugin adds a link to a popup window of a list of your files, to be used with upm_file.
\n\n

The “Attach” icon is from Mark James’ Silk�icon set.
', code = 'if (txpinterface == \'admin\')\n {\n add_privs(\'upm_file_popper\', \'1,2,3,4,5\');\n register_callback(\'upm_file_popper\', \'upm_file_popper\');\n\n add_privs(\'upm_file_popper_link\', \'1,2,3,4,5\');\n register_callback(\'upm_file_popper_link\', \'article\');\n\n add_privs(\'upm_file_popper_js\', \'1,2,3,4,5\ in E:\tst\textpattern\lib\txplib_db.php on line 84

this is on a Windows server … cheers Mary

Offline

#3 2007-01-06 19:33:59

Mary
Sock Enthusiast
Registered: 2004-06-27
Posts: 6,236

Re: [plugin] [ORPHAN] upm_file_popper: A file picker, for use with upm_file.

Crap. I used to have this exact problem with one of Rob’s plugins too (not anymore). I’ll try and figure out what the problem is.

Offline

#4 2007-01-08 00:04:13

Mary
Sock Enthusiast
Registered: 2004-06-27
Posts: 6,236

Re: [plugin] [ORPHAN] upm_file_popper: A file picker, for use with upm_file.

Okay, try again with a new copy from my site (some strange encoding problem with the plugin file).

Offline

#5 2007-01-10 04:42:29

nardo
Member
From: tuvalahiti
Registered: 2004-04-22
Posts: 741

Re: [plugin] [ORPHAN] upm_file_popper: A file picker, for use with upm_file.

tried just now but no luck – what’s the “?” in the last phrase here?

This plugin adds a link to a popup window of a list of your files, to be used with upm_file.

The “Attach” icon is from Mark James’ Silk�icon set.

seems to be same error msg as first report

Offline

#6 2007-01-11 07:53:51

Mary
Sock Enthusiast
Registered: 2004-06-27
Posts: 6,236

Re: [plugin] [ORPHAN] upm_file_popper: A file picker, for use with upm_file.

Hmm, it might be my FTP proggy acting funny again, ‘cuz I know I re-uploaded. I’ve done so again, and it seems it now seems to work okay for me.

Offline

#7 2007-01-11 22:16:04

nardo
Member
From: tuvalahiti
Registered: 2004-04-22
Posts: 741

Re: [plugin] [ORPHAN] upm_file_popper: A file picker, for use with upm_file.

Mary wrote:

Hmm, it might be my FTP proggy acting funny again, ‘cuz I know I re-uploaded. I’ve done so again, and it seems it now seems to work okay for me.

yes – installed fine – thanks!

Offline

#8 2007-01-12 14:11:02

Papuass
Member
From: Rīga, Latvija
Registered: 2006-03-28
Posts: 21
Website

Re: [plugin] [ORPHAN] upm_file_popper: A file picker, for use with upm_file.

Looks great. I just dumped bas_image_selector.

Edit: Woops, I was actually reffering to upm_img_popper :)

Last edited by Papuass (2007-01-12 14:15:21)

Offline

#9 2007-01-23 11:17:25

Logoleptic
Plugin Author
From: Kansas, USA
Registered: 2004-02-29
Posts: 482

Re: [plugin] [ORPHAN] upm_file_popper: A file picker, for use with upm_file.

When I enable the popper, I get a pop-up warning that I’ve forgotten to setup a custom field for upm_file. I know I have done this, so I can’t figure out what the problem is. Could this have something to do with still being on Txp 4.0.3?

Offline

#10 2007-01-23 21:02:15

Logoleptic
Plugin Author
From: Kansas, USA
Registered: 2004-02-29
Posts: 482

Re: [plugin] [ORPHAN] upm_file_popper: A file picker, for use with upm_file.

Logoleptic wrote:

Could this have something to do with still being on Txp 4.0.3?

  1. Return to plugin page, read “All plugins require Textpattern v.4.0.4.”
  2. Smack self on forehead.
  3. Repeat as needed for additional plugins.

Offline

#11 2007-01-24 15:02:03

Mary
Sock Enthusiast
Registered: 2004-06-27
Posts: 6,236

Re: [plugin] [ORPHAN] upm_file_popper: A file picker, for use with upm_file.

It’s a warning I give to all my plugins – whatever the latest stable version of Txp is, that’s the version I support.

The error you get is because you need to go to the plugin’s pref page and tell the plugin which field you want it to use. But, if memory serves correct, changes in 4.0.4 meant some adjustments, making it so that in past versions the file popper link won’t show up in the write tab.

Offline

#12 2007-01-24 16:18:34

Logoleptic
Plugin Author
From: Kansas, USA
Registered: 2004-02-29
Posts: 482

Re: [plugin] [ORPHAN] upm_file_popper: A file picker, for use with upm_file.

Mary wrote:

The error you get is because you need to go to the plugin’s pref page and tell the plugin which field you want it to use. But, if memory serves correct, changes in 4.0.4 meant some adjustments, making it so that in past versions the file popper link won’t show up in the write tab.

I made the setting change that designates a custom field, but still got the warning I mentioned. It looks like the popper’s JavaScript code could be giving the same warning message for both the preferences problem and the Txp version conflict problem.

The forgot_field error message is triggered when document.getElementById('$upm_file_field') fails to find anything. This can be true either because no field was defined or because 4.0.3 doesn’t use id attributes on any of the custom fields that display on the Write tab. Results may differ in Internet Explorer for Windows, which will fall back to searching name attributes if it doesn’t find any matching id values (yet another of the small ways that Microsoft makes our lives harder).

I’ll be upgrading to 4.0.4 later this week, and this shouldn’t be a problem for me after that. Thanks again for the plugin, Mary, and for all your hard work on Textpattern. :-)

Offline

Board footer

Powered by FluxBB