Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#13 2018-08-21 12:37:53

gaekwad
Multi-hyphenate
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,558
GitHub

Re: Server migration - status, discussion

philwareham wrote #313553:

I want to eventually move docs back to .com namespace when we are ready.

Great idea.

Offline

#14 2018-08-21 15:14:34

gaekwad
Multi-hyphenate
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,558
GitHub

Re: Server migration - status, discussion

The next property to move is rpc.textpattern.com, which commences at 1700UTC today (about 1 hour 45 minutes after the timestamp on this post).

Wish me luck, this will be fun.

Refer to original post for current status.

Offline

#15 2018-08-21 15:43:24

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,241

Re: Server migration - status, discussion

gaekwad wrote #313555:

Wish me luck, this will be fun.

Sending good vibes in your direction :)


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#16 2018-08-21 17:47:49

gaekwad
Multi-hyphenate
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,558
GitHub

Re: Server migration - status, discussion

Well, the rpc.textpattern.com migration didn’t go smoothly, it needs a second pair of eyes from a dev and/or plugin author. I suspect it’s a combination of out of date plugins and some tweaks needed for 4.7.x.

I’ve directed RPC DNS back to its original home (Joyent) until we can resolve the issues. Normal service should resume for everyone in the next couple of hours.

Offline

#17 2018-08-21 18:55:15

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,241

Re: Server migration - status, discussion

I can not reach textpattern.org: FF says SSL_ERROR_PROTOCOL_VERSION_ALERT (Chromium calls it ERR_SSL_VERSION_OR_CIPHER_MISMATCH).


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#18 2018-08-21 19:05:58

gaekwad
Multi-hyphenate
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,558
GitHub

Re: Server migration - status, discussion

uli wrote #313561:

I can not reach textpattern.org: FF says SSL_ERROR_PROTOCOL_VERSION_ALERT (Chromium calls it ERR_SSL_VERSION_OR_CIPHER_MISMATCH).

Hey uli – thanks for the report. I’ve got the all-clear here, you might have stale DNS since it moved in the last 24 hours. Can you try pinging it from your command line and post the results here?

ping -t www.textpattern.org

Edit: I’m not seeing any SSL/TLS cipher mismatch, so it might be localised to you. What operating system and browser versions are you running?

SSL test results: www.ssllabs.com/ssltest/analyze.html?d=textpattern.org&latest

Last edited by gaekwad (2018-08-21 19:16:25)

Offline

#19 2018-08-21 20:55:17

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,241

Re: Server migration - status, discussion

ping: invalid timeout: `www.textpattern.org' is output.
FF is 45.9.0 ESR, Chromium is 50.0.2643.0


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#20 2018-08-22 11:27:38

gaekwad
Multi-hyphenate
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,558
GitHub

Re: Server migration - status, discussion

uli wrote #313565:

ping: invalid timeout: `www.textpattern.org' is output.
FF is 45.9.0 ESR, Chromium is 50.0.2643.0

Mea culpa. Can you try: ping www.textpattern.org instead?

You should see a ping response from 46.101.236.252 if you’re on IPv4 and 2a03:b0c0:3:d0::ce8:2001 if you’re on IPv6.

Offline

#21 2018-08-22 12:37:18

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,241

Re: Server migration - status, discussion

gaekwad wrote #313573:

You should see a ping response from 46.101.236.252

Yes, I got

PING www.textpattern.org (46.101.236.252): 56 data bytes
64 bytes from 46.101.236.252: icmp_seq=0 ttl=57 time=3383.539 ms
64 bytes from 46.101.236.252: icmp_seq=1 ttl=57 time=42.747 ms
64 bytes from 46.101.236.252: icmp_seq=2 ttl=57 time=43.558 ms
64 bytes from 46.101.236.252: icmp_seq=3 ttl=57 time=42.809 ms
64 bytes from 46.101.236.252: icmp_seq=4 ttl=57 time=42.769 ms
64 bytes from 46.101.236.252: icmp_seq=5 ttl=57 time=43.509 ms
64 bytes from 46.101.236.252: icmp_seq=6 ttl=57 time=43.011 ms
64 bytes from 46.101.236.252: icmp_seq=7 ttl=57 time=43.471 ms
64 bytes from 46.101.236.252: icmp_seq=8 ttl=57 time=42.913 ms
64 bytes from 46.101.236.252: icmp_seq=9 ttl=57 time=43.148 ms
…

Can I do something to visit .org again or would I simply have to be patient?


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#22 2018-08-22 12:39:57

gaekwad
Multi-hyphenate
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,558
GitHub

Re: Server migration - status, discussion

uli wrote #313575:

Can I do something to visit .org again or would I simply have to be patient?

Something to try – reset Chrome SSL state – I’ve used this approach before for related SSL cache strangeness and it has worked well for me.

Offline

#23 2018-08-22 22:19:53

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,241

Re: Server migration - status, discussion

I could not make it work, alas, but currently something is annoying much much more (and I hope I’m not going to be locked out completely very soon):

The forum shows the same message (SSL_ERROR_PROTOCOL_VERSION_ALERT in FF) when I click links to user’s profiles (try e.g. this one, ). At least those pages where the URL contains the .com domain. I can reach pages though when I replace .com by .io in the adress bar. When I call the same URL on my smartphone I even get a 404.

I hope I can keep using the forum in the long run.


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#24 2018-08-23 06:48:01

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,627
Website GitHub Twitter

Re: Server migration - status, discussion

Hi Uli. forum.textpattern.com returns 404s from here. It is only the .io domain which is currently working.


Yiannis
——————————
neme.org | hblack.net | State Machines | NeMe @ github
I do my best editing after I click on the submit button.

Offline

Board footer

Powered by FluxBB