Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#37 2018-05-16 15:04:45

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,516
Website GitHub

Re: Two issues with 4.7.0

Ah, bingo!

If you set one of the theme directories within the themes directory itself with permissions that are not readable by the web server, you do indeed get UnexpectedValueException. So it is the (stupidly named, imo) RecursiveIteratorIterator that’s complaining.

At least we have something to go on now..


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#38 2018-05-16 15:09:11

funtoosh
Member
From: Münster, Germany
Registered: 2006-10-09
Posts: 149
Website

Re: Two issues with 4.7.0

I was thinking it might have to do with the subdirectory though, which might as well lead to a path error.

In this configuration, their root is not muenster.org but muenster.org/medienforum/ …
It’s handled like the old paradigm server.org/~user/

Offline

#39 2018-05-16 15:09:17

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,516
Website GitHub

Re: Two issues with 4.7.0

Now, this may be an issue if somebody manually extracts a theme – say one they downloaded from our one-day themes site or that was shared by the community – and doesn’t set the same permissions as the surrounding directory. Or maybe if some themes in the /themes directory are symlinked somewhere else in a multi-site installation.

So we definitely need to counter this somehow, but the whole RecursiveIterator thing is above my pay grade right now. Will take some time for me to grok it, so if anyone knows anything about why it does this and can offer a patch/solution before I get a chance to look at it later in the week, please be my guest.

Last edited by Bloke (2018-05-16 15:10:10)


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#40 2018-05-16 15:21:25

gaekwad
Server grease monkey
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 3,627
GitHub

Re: Two issues with 4.7.0

Sher-Bloke Holmes strikes again!

Can you summarise in an issue so we can track it, Stef?

Offline

#41 2018-05-16 15:22:04

etc
Developer
Registered: 2010-11-11
Posts: 4,513
Website GitHub

Re: Two issues with 4.7.0

Them say

Optional flag. Possible values are RecursiveIteratorIterator::CATCH_GET_CHILD which will then ignore exceptions thrown in calls to RecursiveIteratorIterator::getChildren().

Not tested :-/

Offline

#42 2018-09-21 14:30:44

funtoosh
Member
From: Münster, Germany
Registered: 2006-10-09
Posts: 149
Website

Re: Two issues with 4.7.0

By the way, has anybody figured out what the real problem was here? Had the exact same problem today when trying to upgrade another site on a different server from 4.6.2 to 4.7.1 …

Offline

#43 2018-09-21 14:38:49

funtoosh
Member
From: Münster, Germany
Registered: 2006-10-09
Posts: 149
Website

Re: Two issues with 4.7.0

Again, I find myself stuck in the language panel when attempting to downgrade to 4.6.2, and have this error:

User_Error "Unknown column 'prefs_id' in 'field list'"
in /home/sites/******/web/cms/textpattern/lib/txplib_db.php at line 409.
textpattern/lib/txplib_misc.php:1676 adminErrorHandler()
updateErrorHandler()
textpattern/lib/txplib_db.php:409 trigger_error()
textpattern/lib/txplib_db.php:483 safe_query()
textpattern/update/_to_1.0.0.php:203 safe_insert()
textpattern/update/_update.php:90 include()
textpattern/index.php:180 include()

When I look for prefs_id in txp_prefs in my db, I find the following entry. Can I modify this in a way that will help me make it past the language panel?

Last edited by funtoosh (2018-09-21 14:45:44)

Offline

#44 2018-09-21 19:01:36

etc
Developer
Registered: 2010-11-11
Posts: 4,513
Website GitHub

Re: Two issues with 4.7.0

funtoosh wrote #314124:

Again, I find myself stuck in the language panel when attempting to downgrade to 4.6.2, and have this error:

User_Error "Unknown column 'prefs_id' in 'field list'"...

There was an unused prefs_id column in 4.6 that has been removed in 4.7. You can add it manually, but there are other (themes and GDPR related) db changes between 4.6 and 4.7, so 4.6 downgrade is not straightforward. You’d need to do a fresh 4.6 install and then switch 4.7 tables structure to 4.6.

Offline

#45 2018-09-25 10:38:28

funtoosh
Member
From: Münster, Germany
Registered: 2006-10-09
Posts: 149
Website

Re: Two issues with 4.7.0

So, I managed to solve this. Here’s what I did: I went into phpmyadmin and deactivated all plugins, then I made the upgrade to 4.7 again, was able to login, was able to update languages. I reactivated all plugins one by one and — even without upgrading them — everything is fine.

As I had this problem before, I guess it’s best to remember the good old WordPress rule and de-activate all plugins before upgrading from 4.6 to 4.7 …

Here’s the list of my plugins:

Offline

#46 2018-09-25 10:43:23

funtoosh
Member
From: Münster, Germany
Registered: 2006-10-09
Posts: 149
Website

Re: Two issues with 4.7.0

… or in more detail:

bot_write_tab_customize / v0.6.2
rah_urltolink / v0.4.4
smd_where_used / v0.30
zem_contact_lang / v4.0.3.6
zem_contact_reborn / v4.0.3.20

The culprit will most likely not be rah_urltolink + zem_contact as they were not used in that other installation that failed upgrading.

Offline

#47 2018-09-25 13:27:12

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,256

Re: Two issues with 4.7.0

funtoosh wrote #314161:

bot_write_tab_customize / v0.6.2...

This might be the one that caused you headaches. jakob has released an adjusted version of bot_wtc for 4.7.


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#48 2018-09-28 12:34:28

funtoosh
Member
From: Münster, Germany
Registered: 2006-10-09
Posts: 149
Website

Re: Two issues with 4.7.0

Yes, I think so, too. Love that plugin and install it on almost every site, but you need to keep an eye on the version & compatibility each time you update.

Offline

Board footer

Powered by FluxBB