Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#361 2022-10-02 06:51:07

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,923
Website GitHub Twitter

Re: com_connect - form and contact mailer

Just noticed that the <txp:com_connect_email /> tag does not support inline styles. ie <txp:com_connect_email name="Email" label="Your Email:" required="1" style="width:100%;height:3em;"/>. Is this a bug or a feature?


Yiannis
——————————
neme.org | hblack.net | EMAP | A Sea change | NeMe @ github
I do my best editing after I click on the submit button.

Offline

#362 2022-10-02 09:49:38

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,792
Website

Re: com_connect - form and contact mailer

colak wrote #333935:

Just noticed that the <txp:com_connect_email /> tag does not support inline styles. i

Does any <com_connect_* /> tag support inline styling? The “Style” subheading in the help file only refers to class and ID, and no individual tag mentions a style attribute.

scratch that, a style attribute is mentioned at the very top of the “tags” section. Sorry about the confusion.

To be honnest, it never occured to me to use inline style.

Last edited by phiw13 (2022-10-02 09:58:59)


Where is that emoji for a solar powered submarine when you need it ?

Offline

#363 2022-10-02 10:25:26

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,923
Website GitHub Twitter

Re: com_connect - form and contact mailer

phiw13 wrote #333936:

To be honnest, it never occured to me to use inline style.

It’s for an external, independent, temporary, page. Having inline styles is much easier.


Yiannis
——————————
neme.org | hblack.net | EMAP | A Sea change | NeMe @ github
I do my best editing after I click on the submit button.

Offline

#364 2022-10-02 11:03:42

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,792
Website

Re: com_connect - form and contact mailer

colak wrote #333937:

It’s for an external, independent, temporary, page. Having inline styles is much easier.

Inserting a <style /> element in the <head /> or anywhere after the <form /> is not an option?


Where is that emoji for a solar powered submarine when you need it ?

Offline

#365 2022-10-02 13:45:26

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,854
Website GitHub

Re: com_connect - form and contact mailer

That’s weird. style is listed as a global attribute so it should work for all tags. I wonder if something broke when we tinkered with the lAtts() function to stop globals interfering with local atts?


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#366 2022-10-02 16:24:07

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,923
Website GitHub Twitter

Re: com_connect - form and contact mailer

phiw13 wrote #333938:

Inserting a <style /> element in the <head /> or anywhere after the <form /> is not an option?

I had the page in an iframe but changed it to html with styles on the head. It does the job:)


Yiannis
——————————
neme.org | hblack.net | EMAP | A Sea change | NeMe @ github
I do my best editing after I click on the submit button.

Offline

#367 2022-10-03 05:44:38

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,792
Website

Re: com_connect - form and contact mailer

Bloke wrote #333940:

That’s weird. style is listed as a global attribute so it should work for all tags. I wonder if something broke when we tinkered with the lAtts() function to stop globals interfering with local atts?

FWIW, a quick check on a local install: all but <txp:com_connect_email /> work as expected. Source-code inspection of the one offending tag: the style attribute is swallowed by a big ugly monster and never makes it into the generated HTML, debug mode does not tell anything more.

colak wrote #333943:

I had the page in an iframe but changed it to html with styles on the head. It does the job:)

Glad you could find a clean (and more versatil) solution! You could, in case you need it, insert the <style /> inside the <txp:com_connect /> container. e.g:

<txp:com_connect>
<!-- all your com_connect_* tags -->
<style>
/* all needed styles */
</style>
</txp:com_connect>

That will work everywhere.


Where is that emoji for a solar powered submarine when you need it ?

Offline

#368 2022-10-26 02:26:28

peterj
Member
From: Melbourne, Australia
Registered: 2005-06-02
Posts: 94

Re: com_connect - form and contact mailer

I’m getting a tag error with com_connect 4.7.0 on TXP4.8.8 and PHP8.1. When using com_connect as self-closing (using as a container is fine). 8.1 doesn’t like NULL much.

<txp:com_connect to="me@me.com" /> ->  8192: preg_replace(): 
Passing null to parameter #3 ($subject) of type array|string is deprecated 
while parsing form default on page archive
textpattern/plugins/com_connect/com_connect.php:100 preg_replace()
com_connect()

Offline

#369 2022-10-30 03:47:07

Kjeld
Member
From: Tokyo, Japan
Registered: 2005-02-05
Posts: 433
Website

Re: com_connect - form and contact mailer

com_connect : Not receiving messages through contact form

I just moved one of my sites to a new domain (dejima-tokyo.com) with a new hosting provider.

The comment form worked flawlessly with the previous hosting service, but now I don’t receive any of the test messages I send…

I am using the following tag:

<txp:com_connect to="email@example.com" form="contact" label="" />

This is my form:

<!-- START CONTACT uses etc_query to remove class from label -->
<div class="row g-2 my-5 fs-6">
  <div class="col-md-6 form-floating">
    <txp:etc_query data='<txp:com_connect_text label="First Name *" class="form-control" break="" label_position="after" placeholder="First Name *" />' replace="//label@@class"/>
  </div>
  <div class="col-md-6 form-floating">
    <txp:etc_query data='<txp:com_connect_text label="Last Name *" class="form-control" break="" label_position="after" placeholder="Last Name *" />' replace="//label@@class"/>
  </div>

  <div class="col-md-6 form-floating">
    <txp:etc_query data='<txp:com_connect_email label="Email *" class="form-control" break="" label_position="after" placeholder="Email *" />' replace="//label@@class"/>
  </div>
  <div class="col-md-6 form-floating">
    <txp:etc_query data='<txp:com_connect_text type="tel" label="Phone" class="form-control" break="" label_position="after" placeholder="Phone" required="0" />' replace="//label@@class"/>
  </div>

  <div class="col-md-12 form-floating">
    <txp:etc_query data='<txp:com_connect_text label="Company or Organization" class="form-control" break="" label_position="after" placeholder="Company or Organization" required="0" />' replace="//label@@class"/>
  </div>

  <div class="col-md-12 form-floating">
    <txp:etc_query data='<txp:com_connect_textarea label="Message *" class="form-control" break="" label_position="after" placeholder="Message *" />' replace="//label@@class"/>
  </div>

  <div class="col-12">
    <txp:com_connect_submit label="Send" class="btn btn-primary" />
  </div>

</div>
<!-- /END CONTACT -->

When I contacted support about the issue, I received the following response:

Regarding your case, we have checked the DNS records and Email Routing configuration for “dejima-tokyo.com” and noticed that the SPF record, which is required for email authentication, is not configured.

For this reason, we have setup the SPF record with the value for the SpamExperts Outbound Filter, which is included in all our shared hosting plans by default, via Zone Editor tool in cPanel:
> https://imgur.com/ucEC0j2

To test the email service, we have created the following email account:

fctest@dejima-tokyo.com

And proceeded to send a test message to and from the above-mentioned email account. As shown in the screenshots below, both messages arrived successfully:
> https://imgur.com/xRKMMKT – Outgoing message
> https://imgur.com/U9S842O – Incoming message

For further confirmation, please review the Exim log below:

2022-10-30 02:05:14 1oopGk-00FMqj-SG <= fctest@dejima-tokyo.com H=localhost (jppro2.fcomet.com) [127.0.0.1]:35432 P=esmtpsa X=TLS1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no A=dovecot_plain:fctest@dejima-tokyo.com S=976 id=20221030020514.Horde.YrtSzNgGIpmR1o_XfmvCYDB@jppro2.fcomet.com T=“This is an email to review the availability of your Email service,\n please ignore this message” for nikolay.grozdanov@fastcomet.com
2022-10-30 02:05:14 1oopGk-00FMqj-SG SMTP connection outbound 1667063114 1oopGk-00FMqj-SG dejima-tokyo.com nikolay.grozdanov@fastcomet.com
2022-10-30 02:06:02 1oopGk-00FMqj-SG => nikolay.grozdanov@fastcomet.com R=smarthost_dkim T=remote_smtp_smart_dkim H=smtp.antispamcloud.com [149.13.75.71] X=TLS1.3:TLS_AES_256_GCM_SHA384:256 CV=yes C=“250 OK id=1oopHU-000DKL-AM”
2022-10-30 02:07:37 1oopJ1-00FNmu-GY <= nikolay.grozdanov@fastcomet.com H=mail-oa1-f52.google.com [209.85.160.52]:40877 P=esmtps X=TLS1.3:TLS_AES_128_GCM_SHA256:128 CV=no S=5109 id=CAJyKy1spKLgjoM+o-Pix1KZwgyeJudfUGa6FT70EvMcX07z3Lw@mail.gmail.com T=“Re: This is an email to review the availability of your Email\n service, please ignore this message” for fctest@dejima-tokyo.com

Also, if you are sending emails via your website’s Contact form, kindly take note to configure the same to use SMTP protocol, in order to authenticate outgoing emails successfully. Here are the SMTP details required:

• Host/Server: jppro2.fcomet.com
• Port: 465/587(SSL/TLS) – ( Using SSL/TLS is recommended )
• Protocol: SMTP
• Username: the email you are about to use
• Password: the password for the email account you are about to use
• Authentication – Server requires authentication: Yes

Any idea what I am doing wrong, or need to change?

And is it possible, or needed, to adjust configurations in com_connect as suggested by support?


Old Photos of Japan – Japan in the 1850s~1960s (100% txp)
MeijiShowa – Stock photos of Japan in the 1850s~1960s (100% txp)
JapaneseStreets.com – Japanese street fashion (mostly txp)

Offline

#370 2022-10-30 04:37:09

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,792
Website

Re: com_connect - form and contact mailer

Kjeld wrote #334045:

com_connect : Not receiving messages through contact form

  • Did you insert that same email address in the email fields on the Admin > Preferences > Admin panel (the “SMTP envelope sender address” one and the following one)?
  • you probably need to configure the SPF record for you domain (duits.co) somewhere on the domain configuration part of your host UI – probably under DNS, but make sure with your host.

Example: for one host, I insert a DNS record of type TXT with as content: v=spf1 include:spf.my-hosting-service.com ~all.

(And test by sending a test email to (your/a) Gmail address)


Where is that emoji for a solar powered submarine when you need it ?

Offline

#371 2022-10-30 05:18:02

Kjeld
Member
From: Tokyo, Japan
Registered: 2005-02-05
Posts: 433
Website

Re: com_connect - form and contact mailer

phiw13 wrote #334046:

  • Did you insert that same email address in the email fields on the Admin > Preferences > Admin panel (the “SMTP envelope sender address” one and the following one)?
  • you probably need to configure the SPF record for you domain (duits.co) somewhere on the domain configuration part of your host UI – probably under DNS, but make sure with your host.

Example: for one host, I insert a DNS record of type TXT with as content: v=spf1 include:spf.my-hosting-service.com ~all.

(And test by sending a test email to (your/a) Gmail address)

Thank you.

I tried inserting the same email address in Admin > Preferences, but no luck.

I think you are probably right about the SPF record at duits.co. I am moving this domain to the new hosting service as well, so will try that.

For the time being, using an email address with the same domain name as the site seems to work fine.


Old Photos of Japan – Japan in the 1850s~1960s (100% txp)
MeijiShowa – Stock photos of Japan in the 1850s~1960s (100% txp)
JapaneseStreets.com – Japanese street fashion (mostly txp)

Offline

#372 2022-10-31 01:42:38

peterj
Member
From: Melbourne, Australia
Registered: 2005-06-02
Posts: 94

Re: com_connect - form and contact mailer

I had similar issues recently due to increased outgoing spam filtering by host, ended up fixing by adding the from attribute to the com_connect tag. By default I think it tries to send from the address of the person filling in the form, which may not authenticate. For best authentication the “from” and the “to” email addresses should be on the same domain as the website.

Offline

Board footer

Powered by FluxBB