Textpattern CMS support forum

You are not logged in. Register | Login | Help

#11 2019-03-16 10:45:03

etc
Developer
Registered: 2010-11-11
Posts: 3,170
Website

Re: etc_cache: cache trying hard to be smart

jakob wrote #317102:

Is there a way of disabling caching globally temporarily, for example via a prefs switch or in debugging* mode?

Good idea, thanks, will think of it.

I’m currently doing flat theme updates to a site and have to clear the cache regularly. Disabling the plugin throws up missing tag errors. You have a $nolog global in the code but I can’t see where it’s actually used.

Well, if your cache update is properly configured, it should be refreshed automatically when something relevant changes, even in debug mode. But I’m not sure that lastmod pref is updated in flat mode, so the cache update is probably not triggered. $nolog serves just to suppress “false” visitors logging when etc_cache “visits” its update page.

*Using debugging mode to disable caching would make things easy, but would one sacrifice being able to debug etc_cache at the same time?

I don’t remember whether etc_cache has its proper debugger. Core-level errors display (syntaxes, etc) shouldn’t be impacted.


etc_[ query | search | pagination | date | tree | cache ]

Offline

Board footer

Powered by FluxBB