Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#13 2016-10-05 21:47:35

jakob
Admin
From: Germany
Registered: 2005-01-20
Posts: 4,090
Website

Re: Feedback to: Textpattern CMS 4.6.1 released

Bloke wrote #301989:

Crap, I’m not getting blocked at the Languages panel, but my version string isn’t being updated … You get an ‘internal error’ because the result set from an ALTER statement contains no rows: it returns true/false.

Interesting. I had the same problem updating to the current dev version from an earlier 4.6. beta. At some point I did get an internal error that I couldn’t clear. I did manage to get around it at some point, and I think it was through manually editing the version number string (which was still on 4.5.7 despite being a 4.6 dev), manually setting to live, killing cookies, and reloading the public site before logging in again. I thought it was down to my beta-version update, so didn’t report.


TXP Builders – finely-crafted code, design and txp

Offline

#14 2016-10-05 22:03:03

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,092
Website

Re: Feedback to: Textpattern CMS 4.6.1 released

jakob wrote #301991:

I thought it was down to my beta-version update, so didn’t report.

Not your fault, I should have picked it up. The problem was that I made a fatal assumption: that the version reported in Diagnostics and the bottom of the admin screen was the version set in the DB txp_prefs table. That is NOT the case.

The update script was not running at all, but the Diagnostics screen reported 4.6.1. I should have checked the value in the DB too and I’d have noticed the update script was (silently) failing and uncovered the bug.

Note to self: add version check in Diagnostics panel to verify that DB value of version matches file version number.

I’ve patched txplib_db.php locally. That one’s easy to fix. What’s tougher to fix is how to service point releases that don’t have an entry in the $dbupdates array. Thought it might be a simple case of setting the $dbversion to $thisversion to match what’s set in the index.php file if we’ve dropped off the end of the array, but upgrading from earlier versions resets that again when it runs that specific update script. Makes for messy code. There has to be a better way…


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#15 2016-10-05 22:37:00

mrdale
Member
From: Walla Walla
Registered: 2004-11-19
Posts: 2,212
Website

Re: Feedback to: Textpattern CMS 4.6.1 released

Here’s how I managed to get past the language roadblock.

  • I had duplicated my root directory so I had a
    • “public.old” (existing 4.6dev) and
    • “public” (new 4.7dev)
  • version in the prefs was 4.5.7
  • renamed the directories so that the old dir was used.
  • updated my language selection
  • renamed the public folders

Worked.

Offline

#16 2016-10-06 00:30:57

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,275
Website

Re: Feedback to: Textpattern CMS 4.6.1 released

Fwiw I just had the same issue (stuck at Languages panel) while installing a brand new TXP4.7-dev site on localhost.

  • Fetched the code (git checkout …)
  • create DB etc.
  • go to /textpattern/setup, go through the little dance – OK.
  • login, this brings me to the Languages panel (surprised by this actually, it is a brand new install).

No way to navigate any further. I can login / logout etc, but always land on the Languages panel. Attempts to install addition languages also fails.

I see the following in my apache error log:

[Thu Oct 06 09:15:12.684442 2016] [:error] [pid 546] [client 127.0.0.1:53978] PHP Warning:  include(/Users/username/Sites/_txp47/textpattern/config.php): failed to open stream: No such file or directory in /Users/username/Sites/_txp47/index.php on line 81
[Thu Oct 06 09:15:12.701765 2016] [:error] [pid 546] [client 127.0.0.1:53978] PHP Warning:  include(): Failed opening '/Users/username/Sites/_txp47/textpattern/config.php' for inclusion (include_path='.:') in /Users/username/Sites/_txp47/index.php on line 81

Looking at the txp-prefs table through Sequel Pro, I see that the version is 4.6.0.

PS – installing, on the same localhost, a brand new TXP-4.6.1 works perfectly fine, as far as I can see.

Last edited by phiw13 (2016-10-06 00:31:12)


Where is that emoji for a solar powered submarine when you need it ?

Offline

#17 2016-10-06 07:08:01

NicolasGraph
Plugin Author
From: France
Registered: 2008-07-24
Posts: 860
Website

Re: Feedback to: Textpattern CMS 4.6.1 released

jakob wrote #301991:

I thought it was down to my beta-version update, so didn’t report.

Same; I thought it was my fault because I had the problem on only one install; but as far as I understand it is because of a different production status…

Bloke wrote #301989:

One thing you can do to make the upgrade go more smoothly is to switch production status to Live prior to upgrading.


Nicolas
Follow me on Twitter and GitHub!
Multiple edits are usually to correct my frenglish…

Offline

#18 2016-10-06 09:02:44

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,275
Website

Re: Feedback to: Textpattern CMS 4.6.1 released

phiw13 wrote #301994:

Fwiw I just had the same issue (stuck at Languages panel) while installing a brand new TXP4.7-dev site on localhost.

Patching my TXP-4.7.0-dev textpattern/lib/txplib_db.php with Bloke’s patch here allowed me to escape out of being stuck at the Languages panel. Dunno yet if everything works fine, I’ve had little time to test, busy with clean around my house after typhoon #18.

Last edited by phiw13 (2016-10-06 09:13:06)


Where is that emoji for a solar powered submarine when you need it ?

Offline

#19 2016-10-06 09:07:20

philwareham
Core designer
From: Haslemere, Surrey, UK
Registered: 2009-06-11
Posts: 3,481
Website

Re: Feedback to: Textpattern CMS 4.6.1 released

phiw13 wrote #301998:

Patching my TXP-4.7.0-dev textpattern/lib/txplib_db.php

I’ve copied that patch code into the 4.7.0-dev branch now, as a quick fix

Offline

#20 2016-10-06 09:13:18

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 2,275
Website

Re: Feedback to: Textpattern CMS 4.6.1 released

philwareham wrote #301999:

I’ve copied that patch code into the 4.7.0-dev branch now, as a quick fix

Cool, thanks.


Where is that emoji for a solar powered submarine when you need it ?

Offline

#21 2016-10-06 10:30:50

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,092
Website

Re: Feedback to: Textpattern CMS 4.6.1 released

NicolasGraph wrote #301995:

Same; I thought it was my fault because I had the problem on only one install; but as far as I understand it is because of a different production status…

Hehe, that’s the downside of having clever beta testers: you’re all too resourceful!

I think what also didn’t help was that txp_using_svn (i.e. our “is in dev” flag) wasn’t reset to true in the 4.6.1 branch, for some reason. At least, I can’t find where I did it in the commit history. So any beta testers may have been testing as if the release was ‘final’.

Note to self: be more thorough next time.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#22 2016-10-06 18:40:50

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,236

Re: Feedback to: Textpattern CMS 4.6.1 released

I just updated a 4.6.0-dev (i.e. a pre-beta, from April) to 4.6.1. All went well, I could visit all tabs. Thank you, guys!

Small “but” as I didn’t expect the following:
On visiting the Diagnostics window I’ve now a v4.6.1 (text area message) and the pre-flight note “New Textpattern version 4.6.1 available for download” (probably caused by my unorthodox version combo).

smd_prognostics, though, doesn’t have the update reminder in its “Advice” section any longer.


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#23 2016-10-06 19:05:34

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,092
Website

Re: Feedback to: Textpattern CMS 4.6.1 released

uli wrote #302005:

“New Textpattern version 4.6.1 available for download” (probably caused by my unorthodox version combo).

Yep, thanks for the report. The pre-flight check uses the DB version, which will still erroneously be reported as 4.6.0, but the Diagnostics panel itself uses the one from the index.php file, which is correctly identified as 4.6.1. *sigh*


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#24 2016-10-06 23:48:10

bici
Member
From: vancouver
Registered: 2004-02-24
Posts: 1,802
Website

Re: Feedback to: Textpattern CMS 4.6.1 released

ok. so bottom line. Is it now full proof to upgrade to 4.6.1?


…. texted postive

Offline

Board footer

Powered by FluxBB